summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-03 22:52:11 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-03 22:52:11 +0000
commitf3a26f258aaa37a886d4837e5e1355b683fb86ff (patch)
tree5a599f1fc8ab7f9b2f5f87613cf0d71e755897f2 /app-shells/bash
parentKeyword ~amd64 per bug #120112) (diff)
downloadgentoo-2-f3a26f258aaa37a886d4837e5e1355b683fb86ff.tar.gz
gentoo-2-f3a26f258aaa37a886d4837e5e1355b683fb86ff.tar.bz2
gentoo-2-f3a26f258aaa37a886d4837e5e1355b683fb86ff.zip
Add fix from upstream for comments in subshelled case statements.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/ChangeLog6
-rw-r--r--app-shells/bash/bash-4.0.ebuild3
-rw-r--r--app-shells/bash/files/bash-4.0-comsub-comments.patch31
3 files changed, 38 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 193d599aa809..3290eca2dde0 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.209 2009/03/03 19:58:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.210 2009/03/03 22:52:11 vapier Exp $
+
+ 03 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/bash-4.0-comsub-comments.patch, bash-4.0.ebuild:
+ Add fix from upstream for comments in subshelled case statements.
03 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+files/bash-4.0-read-timeout-reset.patch, bash-4.0.ebuild:
diff --git a/app-shells/bash/bash-4.0.ebuild b/app-shells/bash/bash-4.0.ebuild
index 6a5236a03ec5..40a9692b49ce 100644
--- a/app-shells/bash/bash-4.0.ebuild
+++ b/app-shells/bash/bash-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.13 2009/03/03 19:58:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.14 2009/03/03 22:52:11 vapier Exp $
EAPI="1"
@@ -76,6 +76,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-pipeline-reserved-word.patch
epatch "${FILESDIR}"/${P}-associative-array-subscripts.patch
epatch "${FILESDIR}"/${P}-comsub-herestring.patch
+ epatch "${FILESDIR}"/${P}-comsub-comments.patch
epatch "${FILESDIR}"/${P}-read-timeout-reset.patch
epatch "${FILESDIR}"/${PN}-4.0-negative-return.patch
# Log bash commands to syslog #91327
diff --git a/app-shells/bash/files/bash-4.0-comsub-comments.patch b/app-shells/bash/files/bash-4.0-comsub-comments.patch
new file mode 100644
index 000000000000..4a753d65be81
--- /dev/null
+++ b/app-shells/bash/files/bash-4.0-comsub-comments.patch
@@ -0,0 +1,31 @@
+http://lists.gnu.org/archive/html/bug-bash/2009-03/msg00018.html
+
+*** ../bash-4.0/parse.y 2009-01-08 08:29:12.000000000 -0500
+--- parse.y 2009-03-03 16:58:50.000000000 -0500
+***************
+*** 3172,3175 ****
+--- 3179,3187 ----
+ }
+
++ /* Not exactly right yet, should handle shell metacharacters, too. If
++ any changes are made to this test, make analogous changes to subst.c:
++ extract_delimited_string(). */
++ #define COMMENT_BEGIN(x) ((x) == '#' && (retind == 0 || ret[retind-1] == '\n' || shellblank (ret[retind - 1])))
++
+ /* Parse a $(...) command substitution. This is messier than I'd like, and
+ reproduces a lot more of the token-reading code than I'd like. */
+***************
+*** 3365,3369 ****
+ tflags &= ~LEX_RESWDOK;
+ }
+! else if (shellbreak (ch) == 0)
+ {
+ tflags &= ~LEX_RESWDOK;
+--- 3377,3383 ----
+ tflags &= ~LEX_RESWDOK;
+ }
+! else if MBTEST((tflags & LEX_CKCOMMENT) && COMMENT_BEGIN(ch))
+! ; /* don't turn off LEX_RESWDOK if we're starting a comment */
+! else if MBTEST(shellbreak (ch) == 0)
+ {
+ tflags &= ~LEX_RESWDOK;