summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-25 17:22:26 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-25 17:22:26 +0000
commit565d9fbc74031a40634c5d0023498b5dc65c447a (patch)
tree642909d511bb16a9e266763e814d820b2311145f /app-shells/bash
parentRemoved old version (diff)
downloadgentoo-2-565d9fbc74031a40634c5d0023498b5dc65c447a.tar.gz
gentoo-2-565d9fbc74031a40634c5d0023498b5dc65c447a.tar.bz2
gentoo-2-565d9fbc74031a40634c5d0023498b5dc65c447a.zip
Add fix from upstream for infinite loop with arrays.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/ChangeLog6
-rw-r--r--app-shells/bash/bash-4.0.ebuild3
-rw-r--r--app-shells/bash/files/bash-4.0-declare-identifier.patch18
3 files changed, 25 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 17d7c715f4fb..e16bfa867927 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.201 2009/02/24 22:13:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.202 2009/02/25 17:22:26 vapier Exp $
+
+ 25 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/bash-4.0-declare-identifier.patch, bash-4.0.ebuild:
+ Add fix from upstream for infinite loop with arrays.
24 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+files/bash-4.0-pcomplete-save-parser-state.patch, bash-4.0.ebuild:
diff --git a/app-shells/bash/bash-4.0.ebuild b/app-shells/bash/bash-4.0.ebuild
index d4e8a37f507e..87b649acea68 100644
--- a/app-shells/bash/bash-4.0.ebuild
+++ b/app-shells/bash/bash-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.6 2009/02/24 22:13:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.7 2009/02/25 17:22:26 vapier Exp $
EAPI="1"
@@ -71,6 +71,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-comsub-backslash-metacharacters.patch
epatch "${FILESDIR}"/${P}-save-current-token.patch
epatch "${FILESDIR}"/${P}-exit-checkjobs.patch
+ epatch "${FILESDIR}"/${P}-declare-identifier.patch
epatch "${FILESDIR}"/${PN}-4.0-negative-return.patch
# Log bash commands to syslog #91327
if use bashlogger ; then
diff --git a/app-shells/bash/files/bash-4.0-declare-identifier.patch b/app-shells/bash/files/bash-4.0-declare-identifier.patch
new file mode 100644
index 000000000000..30c17e337c8c
--- /dev/null
+++ b/app-shells/bash/files/bash-4.0-declare-identifier.patch
@@ -0,0 +1,18 @@
+http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00206.html
+
+*** ../bash-4.0/builtins/declare.def 2009-01-04 14:32:22.000000000 -0500
+--- builtins/declare.def 2009-02-25 09:41:35.000000000 -0500
+***************
+*** 288,291 ****
+--- 288,297 ----
+ }
+ }
++ else if (legal_identifier (name) == 0)
++ {
++ sh_invalidid (name);
++ assign_error++;
++ NEXT_VARIABLE ();
++ }
+ else
+ value = "";
+