summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2004-09-05 16:14:30 +0000
committerMalcolm Lashley <malc@gentoo.org>2004-09-05 16:14:30 +0000
commit24f4c7c2a04b404fbf5fa7c005959dfc47b5822c (patch)
tree136476cc9bc28dc214f4a2cef8e85da65e78c7c8 /app-sci
parentClosing #58658 (Manifest recommit) (diff)
downloadgentoo-2-24f4c7c2a04b404fbf5fa7c005959dfc47b5822c.tar.gz
gentoo-2-24f4c7c2a04b404fbf5fa7c005959dfc47b5822c.tar.bz2
gentoo-2-24f4c7c2a04b404fbf5fa7c005959dfc47b5822c.zip
~amd64, -fPIC and gcc3.4 mega-lovin - bug #62202
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/kemistry/ChangeLog7
-rw-r--r--app-sci/kemistry/files/kemistry-0.7-fPIC.patch45
-rw-r--r--app-sci/kemistry/files/kemistry-0.7-gcc3.4.patch58
-rw-r--r--app-sci/kemistry/kemistry-0.7.ebuild16
4 files changed, 122 insertions, 4 deletions
diff --git a/app-sci/kemistry/ChangeLog b/app-sci/kemistry/ChangeLog
index da9421db55af..2467f62b8795 100644
--- a/app-sci/kemistry/ChangeLog
+++ b/app-sci/kemistry/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/kemistry
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/kemistry/ChangeLog,v 1.11 2004/08/14 13:30:00 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/kemistry/ChangeLog,v 1.12 2004/09/05 16:14:30 malc Exp $
+
+ 05 Sep 2004; Malcolm Lashley <malc@gentoo.org>
+ +files/kemistry-0.7-fPIC.patch, +files/kemistry-0.7-gcc3.4.patch,
+ kemistry-0.7.ebuild:
+ ~amd64 -fPIC and gcc3.4 patches
14 Aug 2004; Sven Wegener <swegener@gentoo.org> kemistry-0.7.ebuild:
Fixed CVS Header.
diff --git a/app-sci/kemistry/files/kemistry-0.7-fPIC.patch b/app-sci/kemistry/files/kemistry-0.7-fPIC.patch
new file mode 100644
index 000000000000..50f9a816b1da
--- /dev/null
+++ b/app-sci/kemistry/files/kemistry-0.7-fPIC.patch
@@ -0,0 +1,45 @@
+--- kemistry-0.7/work/kemistry-0.7/kfile_plugins/Makefile.am 2003-01-21 14:03:28.000000000 +0000
++++ kemistry-0.7_patched/work/kemistry-0.7/kfile_plugins/Makefile.am 2004-09-05 12:36:53.862035280 +0100
+@@ -1,3 +1,4 @@
++KDE_CXXFLAGS = $(USE_RTTI) $(USE_EXCEPTIONS) -fPIC
+ INCLUDES = $(all_includes) -I../openbabel -I../libkemistry
+
+ # these are the headers for your project
+--- kemistry-0.7/work/kemistry-0.7/kdrawchem/Makefile.am 2003-01-02 17:47:58.000000000 +0000
++++ kemistry-0.7_patched/work/kemistry-0.7/kdrawchem/Makefile.am 2004-09-05 12:30:47.718697528 +0100
+@@ -1,3 +1,5 @@
++KDE_CXXFLAGS = $(USE_RTTI) $(USE_EXCEPTIONS) -fPIC
++
+ ####### kdevelop will overwrite this part!!! (begin)##########
+ lib_LTLIBRARIES = libkdrawchem.la
+ bin_PROGRAMS = kdrawchem
+@@ -23,7 +25,7 @@
+ fixeddialogwidget.ui
+
+ libkdrawchem_la_LDFLAGS = $(all_libraries) -version-info 1:0:0 -module \
+- -no-undefined
++ -no-undefined
+ libkdrawchem_la_LIBADD = ../libkemistry/libkemistry.la $(LIB_KDEPRINT) $(LIB_KFILE) $(LIB_KDEUI) \
+ $(LIB_KDECORE) $(LIB_QT) $(LIBSOCKET) -lkparts ../openbabel/libopenbabel_kemistry.la
+
+--- kemistry-0.7/work/kemistry-0.7/openbabel/Makefile.am 2003-01-21 14:03:29.000000000 +0000
++++ kemistry-0.7_patched/work/kemistry-0.7/openbabel/Makefile.am 2004-09-05 12:03:53.653072800 +0100
+@@ -2,7 +2,7 @@
+
+ METASOURCES=AUTO
+
+-KDE_CXXFLAGS = $(USE_RTTI) $(USE_EXCEPTIONS) -DDATADIR=\"$(kde_datadir)/openbabel\"
++KDE_CXXFLAGS = $(USE_RTTI) $(USE_EXCEPTIONS) -DDATADIR=\"$(kde_datadir)/openbabel\" -fPIC
+ INCLUDES = $(all_includes)
+
+ #bin_PROGRAMS = babel
+--- kemistry-0.7/work/kemistry-0.7/libkemistry/Makefile.am 2003-01-21 14:45:52.000000000 +0000
++++ kemistry-0.7_patched/work/kemistry-0.7/libkemistry/Makefile.am 2004-09-05 12:08:17.850908624 +0100
+@@ -1,6 +1,6 @@
+ METASOURCES=AUTO
+
+-KDE_CXXFLAGS = $(USE_RTTI) $(USE_EXCEPTIONS)
++KDE_CXXFLAGS = $(USE_RTTI) $(USE_EXCEPTIONS) -fPIC
+ INCLUDES = $(all_includes)
+
+ lib_LTLIBRARIES = libkemistry.la
diff --git a/app-sci/kemistry/files/kemistry-0.7-gcc3.4.patch b/app-sci/kemistry/files/kemistry-0.7-gcc3.4.patch
new file mode 100644
index 000000000000..b4eb22e79939
--- /dev/null
+++ b/app-sci/kemistry/files/kemistry-0.7-gcc3.4.patch
@@ -0,0 +1,58 @@
+--- kemistry-0.7/work/kemistry-0.7/kdrawchem/kdrawchempart.cpp 2003-01-02 17:47:58.000000000 +0000
++++ kemistry-0.7_patched/work/kemistry-0.7/kdrawchem/kdrawchempart.cpp 2004-09-05 12:18:13.204401136 +0100
+@@ -17,7 +17,7 @@
+ {
+ return new KDrawChemFactory;
+ }
+-};
++}
+
+ /**
+ * We need one static instance of the factory for our C 'main'
+@@ -115,4 +115,4 @@
+ //eof
+
+
+-#include "kdrawchempart.moc"
+\ No newline at end of file
++#include "kdrawchempart.moc"
+--- kemistry-0.7/work/kemistry-0.7/kdrawchem/kdrawchemdoc.cpp 2003-01-02 17:47:58.000000000 +0000
++++ kemistry-0.7_patched/work/kemistry-0.7/kdrawchem/kdrawchemdoc.cpp 2004-09-05 12:16:39.540640192 +0100
+@@ -183,7 +183,7 @@
+ OBMol *mol=new OBMol;
+
+ OBExtensionTable extab;
+- enum io_type importType;
++ io_type importType;
+
+ importType=extab.FilenameToType(const_cast<char*>(tmpfile.latin1())); //doesn't like being a const char*--casted it to a char*
+
+@@ -241,4 +241,4 @@
+ }
+
+
+-#include "kdrawchemdoc.moc"
+\ No newline at end of file
++#include "kdrawchemdoc.moc"
+--- kemistry-0.7/work/kemistry-0.7/kdrawchem/kdcpreview.cpp 2002-12-19 23:12:43.000000000 +0000
++++ kemistry-0.7_patched/work/kemistry-0.7/kdrawchem/kdcpreview.cpp 2004-09-05 12:14:07.154806360 +0100
+@@ -65,7 +65,7 @@
+ OBMol *mol=new OBMol;
+
+ OBExtensionTable extab;
+- enum io_type importType;
++ io_type importType;
+
+ importType=extab.FilenameToType(const_cast<char*>(filename.latin1())); //doesn't like being a const char*--casted it to a char*
+
+--- kemistry-0.7/work/kemistry-0.7/kfile_plugins/kfile_openbabel.cpp 2002-12-24 13:08:26.000000000 +0000
++++ kemistry-0.7_patched/work/kemistry-0.7/kfile_plugins/kfile_openbabel.cpp 2004-09-05 12:35:48.666946440 +0100
+@@ -37,7 +37,7 @@
+ typedef KGenericFactory<OpenBabelPlugin> OpenBabelFactory;
+
+ K_EXPORT_COMPONENT_FACTORY(kfile_openbabel,
+- OpenBabelFactory("kfile_openbabel"));
++ OpenBabelFactory("kfile_openbabel"))
+
+ OpenBabelPlugin::OpenBabelPlugin(QObject* parent, const char* name,
+ const QStringList &args)
diff --git a/app-sci/kemistry/kemistry-0.7.ebuild b/app-sci/kemistry/kemistry-0.7.ebuild
index 74ca9229515c..abbac9569adc 100644
--- a/app-sci/kemistry/kemistry-0.7.ebuild
+++ b/app-sci/kemistry/kemistry-0.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/kemistry/kemistry-0.7.ebuild,v 1.7 2004/08/14 13:30:00 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/kemistry/kemistry-0.7.ebuild,v 1.8 2004/09/05 16:14:30 malc Exp $
-inherit kde
+inherit kde eutils
DESCRIPTION="Kemistry--a set of chemistry related tools for KDE."
HOMEPAGE="http://kemistry.sourceforge.net"
@@ -10,8 +10,18 @@ SRC_URI="mirror://sourceforge/kemistry/${P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~sparc"
+KEYWORDS="x86 ~sparc ~amd64"
IUSE=""
DEPEND="kde-base/kdesdk"
need-kde 3
+
+src_unpack() {
+ kde_src_unpack
+
+ epatch ${FILESDIR}/${P}-gcc3.4.patch
+ if use amd64; then
+ epatch ${FILESDIR}/${P}-fPIC.patch
+ fi
+}
+