summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2004-07-27 00:49:41 +0000
committerChris Bainbridge <chrb@gentoo.org>2004-07-27 00:49:41 +0000
commitab277338af51d6e8396eb805f9d270e130bc8a7d (patch)
treecc61c152caa38edf89ca718c0da247399d235521 /app-sci/tbass
parentFix rev. (Manifest recommit) (diff)
downloadgentoo-2-ab277338af51d6e8396eb805f9d270e130bc8a7d.tar.gz
gentoo-2-ab277338af51d6e8396eb805f9d270e130bc8a7d.tar.bz2
gentoo-2-ab277338af51d6e8396eb805f9d270e130bc8a7d.zip
fix update
Diffstat (limited to 'app-sci/tbass')
-rw-r--r--app-sci/tbass/ChangeLog5
-rw-r--r--app-sci/tbass/tbass-3.4.ebuild43
2 files changed, 45 insertions, 3 deletions
diff --git a/app-sci/tbass/ChangeLog b/app-sci/tbass/ChangeLog
index 12a8f43ee57f..6483658679f1 100644
--- a/app-sci/tbass/ChangeLog
+++ b/app-sci/tbass/ChangeLog
@@ -1,11 +1,10 @@
# ChangeLog for app-sci/tbass
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tbass/ChangeLog,v 1.17 2004/07/26 17:45:36 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tbass/ChangeLog,v 1.18 2004/07/27 00:49:41 chrb Exp $
26 Jul 2004; Chris Bainbridge <chrb@gentoo.org> -tbass-20030108.ebuild,
-tbass-20030725.3.3.ebuild:
- removed unsupported upstream versions, added ebuild pointing to new package
- balsa-async
+ removed unsupported upstream versions, moved package to app-sci/balsa
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
tbass-20030108.ebuild, tbass-20030725.3.3.ebuild:
diff --git a/app-sci/tbass/tbass-3.4.ebuild b/app-sci/tbass/tbass-3.4.ebuild
new file mode 100644
index 000000000000..2733b0510364
--- /dev/null
+++ b/app-sci/tbass/tbass-3.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tbass/tbass-3.4.ebuild,v 1.1 2004/07/27 00:49:41 chrb Exp $
+
+inherit eutils
+
+IUSE=""
+Name="balsa"
+My_PV="3.4"
+
+DESCRIPTION="The Balsa asynchronous synthesis system"
+HOMEPAGE="http://www.cs.man.ac.uk/amulet/projects/balsa/"
+SRC_URI="ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/${Name}-${My_PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/BalsaManual${My_PV}.pdf
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/${Name}-tech-example-${My_PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/${Name}-sim-verilog-${My_PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/BalsaExamples${My_PV}.tar.gz"
+# ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/snapshots/${Name}-tech-verilog-20030204.tar.gz
+# ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/snapshots/${Name}-tech-xilinx-20021029.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/libc
+ sys-devel/binutils
+ dev-libs/gmp
+ dev-lang/perl
+ x11-libs/gtk+
+ app-sci/iverilog
+ app-sci/gplcver"
+
+RDEPEND="${DEPEND}
+ dev-util/guile
+ media-gfx/graphviz
+ app-sci/gtkwave
+ app-sci/espresso-ab"
+
+RESTRICT="fetch nostrip"
+
+pkg_nofetch() {
+ einfo "Please try emerging app-sci/balsa instead"
+}