summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-03-01 06:04:34 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-03-01 06:04:34 +0000
commite5f3781157e678c476be7c6dd8516002999d9666 (patch)
treebba2f0ed6069afa70dd11d791b5afec3bf532963 /app-sci/rasmol
parentfixed and tested -r1, temporarily removed ia64 due to repoman bork (Manifest ... (diff)
downloadgentoo-2-e5f3781157e678c476be7c6dd8516002999d9666.tar.gz
gentoo-2-e5f3781157e678c476be7c6dd8516002999d9666.tar.bz2
gentoo-2-e5f3781157e678c476be7c6dd8516002999d9666.zip
Version bump to 2.7 series, technically OpenRasMol but it's the continuation of RasMol development.
Diffstat (limited to 'app-sci/rasmol')
-rw-r--r--app-sci/rasmol/ChangeLog11
-rw-r--r--app-sci/rasmol/files/digest-rasmol-2.7.1.11
-rw-r--r--app-sci/rasmol/files/rasmol.sh.debian50
-rw-r--r--app-sci/rasmol/rasmol-2.7.1.1.ebuild58
4 files changed, 118 insertions, 2 deletions
diff --git a/app-sci/rasmol/ChangeLog b/app-sci/rasmol/ChangeLog
index f96beb08ffb4..25b7e63e4b4e 100644
--- a/app-sci/rasmol/ChangeLog
+++ b/app-sci/rasmol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-sci/rasmol
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/ChangeLog,v 1.5 2003/10/09 08:07:29 brandy Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/ChangeLog,v 1.6 2004/03/01 06:04:34 spyderous Exp $
+
+*rasmol-2.7.1.1 (01 Mar 2004)
+
+ 01 Mar 2004; Donnie Berkholz <spyderous@gentoo.org>; rasmol-2.7.1.1.ebuild,
+ files/rasmol.sh.debian:
+ Version bump to 2.7 series, technically OpenRasMol but it's the continuation
+ of RasMol development.
09 Oct 2003; Brandy Westcott brandy@gentoo.org rasmol-2.6_beta2.ebuild:
Fixed applying of patch. Closes Bug #30730
diff --git a/app-sci/rasmol/files/digest-rasmol-2.7.1.1 b/app-sci/rasmol/files/digest-rasmol-2.7.1.1
new file mode 100644
index 000000000000..62144d2932df
--- /dev/null
+++ b/app-sci/rasmol/files/digest-rasmol-2.7.1.1
@@ -0,0 +1 @@
+MD5 0d5c99eeda079d8cbf413944d284740b RasMol_2.7.1.1.tar.gz 4149367
diff --git a/app-sci/rasmol/files/rasmol.sh.debian b/app-sci/rasmol/files/rasmol.sh.debian
new file mode 100644
index 000000000000..e86da961a295
--- /dev/null
+++ b/app-sci/rasmol/files/rasmol.sh.debian
@@ -0,0 +1,50 @@
+#!/bin/sh
+# rasmol.sh
+# RasMol Molecular Graphics
+# Roger Sayle, August 1995
+# Version 2.6
+# script modified for linux
+# John Lapeyre
+#Wed, 12 Aug 1998 21:34:40 -0700
+#
+# Example Environment Variables
+#
+
+RASMOLPATH=/usr/lib/rasmol
+export RASMOLPATH
+
+RASMOL_VISUAL=8
+
+if [ -e /usr/bin/X11/xwininfo ]; then
+ RASMOL_VISUAL=`xwininfo -root | perl -ne 'chomp;print if s|\s+Depth:\s+||'` ;
+fi
+
+if [ -e "/etc/rasmol/.rasmol.conf" ]; then
+ . /etc/rasmol/.rasmol.conf;
+fi
+
+if [ -e ~/.rasmol.conf ]; then
+ . ~/.rasmol.conf;
+fi
+
+case "$1" in
+ -8)
+ RASMOL_VISUAL=8
+ shift;;
+ -16)
+ RASMOL_VISUAL=16
+ shift;;
+ -24)
+ RASMOL_VISUAL=32
+ shift;;
+ -32)
+ RASMOL_VISUAL=32
+ shift;;
+esac
+#echo Using binary rasmol.$RASMOL_VISUAL
+
+if [ $RASMOL_VISUAL == 24 ]; then
+ RASMOL_VISUAL=32;
+fi
+
+$RASMOLPATH/rasmol.$RASMOL_VISUAL $* \ No newline at end of file
diff --git a/app-sci/rasmol/rasmol-2.7.1.1.ebuild b/app-sci/rasmol/rasmol-2.7.1.1.ebuild
new file mode 100644
index 000000000000..da34be1214fa
--- /dev/null
+++ b/app-sci/rasmol/rasmol-2.7.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.1.1.ebuild,v 1.1 2004/03/01 06:04:34 spyderous Exp $
+
+MY_P="RasMol_${PV}"
+
+DESCRIPTION="Free program that displays molecular structure."
+HOMEPAGE="http://www.openrasmol.org/"
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="public-domain"
+DEPEND="virtual/x11"
+
+SRC_URI="http://www.bernstein-plus-sons.com/software/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Hack required for build
+ cd src
+ ln -s ../doc
+ gunzip doc/rasmol.1.gz
+}
+
+src_compile() {
+ cd src
+ xmkmf || die "xmkmf failed"
+ make DEPTHDEF=-DEIGHTBIT CC=${CC} \
+ CDEBUGFLAGS="${CFLAGS}" \
+ || die "8-bit make failed"
+ mv rasmol rasmol.8
+ make clean
+ make DEPTHDEF=-DSIXTEENBIT CC=${CC} \
+ CDEBUGFLAGS="${CFLAGS}" \
+ || die "16-bit make failed"
+ mv rasmol rasmol.16
+ make clean
+ make DEPTHDEF=-DTHIRTYTWOBIT CC=${CC} \
+ CDEBUGFLAGS="${CFLAGS}" \
+ || die "32-bit make failed"
+ mv rasmol rasmol.32
+ make clean
+}
+
+src_install () {
+ newbin ${FILESDIR}/rasmol.sh.debian rasmol
+ insinto /usr/lib/${PN}
+ doins doc/rasmol.hlp
+ exeinto /usr/lib/${PN}
+ doexe src/rasmol.{8,16,32}
+ dodoc INSTALL PROJECTS README TODO doc/*.{ps,pdf}.gz doc/rasmol.txt.gz
+ doman doc/rasmol.1
+ insinto /usr/lib/${PN}/databases
+ doins data/*
+}