summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-10-01 00:11:00 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-10-01 00:11:00 +0000
commitd7ae7d4e21cd569d09d20edebac16ac11e820e32 (patch)
tree71275a1eb29047838640d10048bf4243922f388f /app-sci/octave
parentadded ~mips keyword (Manifest recommit) (diff)
downloadgentoo-2-d7ae7d4e21cd569d09d20edebac16ac11e820e32.tar.gz
gentoo-2-d7ae7d4e21cd569d09d20edebac16ac11e820e32.tar.bz2
gentoo-2-d7ae7d4e21cd569d09d20edebac16ac11e820e32.zip
Late, but done... moved too virtual/blas + BUG 52604
Diffstat (limited to 'app-sci/octave')
-rw-r--r--app-sci/octave/ChangeLog6
-rw-r--r--app-sci/octave/octave-2.1.57-r1.ebuild16
2 files changed, 15 insertions, 7 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
index 141fb08d8461..1b1fdac5be4a 100644
--- a/app-sci/octave/ChangeLog
+++ b/app-sci/octave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/octave
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.34 2004/07/01 19:38:48 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.35 2004/10/01 00:11:00 kugelfang Exp $
+
+ 01 Oct 2004; Danny van Dyk <kugelfang@gentoo.org> octave-2.1.57-r1.ebuild:
+ Switched on blas use-flag as all arches have at least blas-atlas in testing
+ now.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
octave-2.1.36-r1.ebuild, octave-2.1.50.ebuild, octave-2.1.57-r1.ebuild,
diff --git a/app-sci/octave/octave-2.1.57-r1.ebuild b/app-sci/octave/octave-2.1.57-r1.ebuild
index a94ab9764c99..27e6642afdff 100644
--- a/app-sci/octave/octave-2.1.57-r1.ebuild
+++ b/app-sci/octave/octave-2.1.57-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.57-r1.ebuild,v 1.7 2004/07/01 11:53:45 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.57-r1.ebuild,v 1.8 2004/10/01 00:11:00 kugelfang Exp $
inherit flag-o-matic
@@ -12,8 +12,7 @@ SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha ~sparc amd64"
-IUSE="emacs static readline zlib tetex hdf5 mpi"
-#IUSE="emacs static readline zlib tetex hdf5 mpi ifc blas" NOTE: Already added to use.local.desc.
+IUSE="emacs static readline zlib tetex hdf5 mpi ifc blas"
DEPEND="virtual/libc
>=sys-libs/ncurses-5.2-r3
@@ -23,8 +22,8 @@ DEPEND="virtual/libc
zlib? ( sys-libs/zlib )
hdf5? ( dev-libs/hdf5 )
tetex? ( virtual/tetex )
- x86? ( ifc? ( dev-lang/ifc ) )"
-# blas? ( virtual/blas )" NOTE: Blas-* is not fully done.
+ x86? ( ifc? ( dev-lang/ifc ) )
+ blas? ( virtual/blas )"
# NOTE: octave supports blas/lapack from intel but this is not open
# source nor is it free (as in beer OR speech) Check out...
@@ -50,6 +49,11 @@ src_compile() {
use hdf5 || myconf="${myconf} --without-hdf5"
use mpi || myconf="${myconf} --without-mpi"
+ # Only add -lz to LDFLAGS if we have zlib in USE !
+ # BUG #52604
+ # Danny van Dyk 2004/08/26
+ use zlib && LDFLAGS="${LDFLAGS} -lz"
+
# NOTE: This version actually works with gcc-3.x
./configure ${myconf} --prefix=/usr \
--sysconfdir=/etc \
@@ -61,7 +65,7 @@ src_compile() {
--target=${CHOST} \
--enable-rpath \
--enable-lite-kernel \
- LDFLAGS=-lz || die "configure failed"
+ LDFLAGS=${LDFLAGS} || die "configure failed"
emake || die "emake failed"
}