summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-10-02 17:04:38 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-10-02 17:04:38 +0000
commitdaa6941e73a4f27967b6e44c1f519e279a297345 (patch)
tree6ebb341a5774b6f7353e90437e787a8d292ec25d /app-sci/mpqc
parentKeyword ~alpha, bug 65841. (Manifest recommit) (diff)
downloadgentoo-2-daa6941e73a4f27967b6e44c1f519e279a297345.tar.gz
gentoo-2-daa6941e73a4f27967b6e44c1f519e279a297345.tar.bz2
gentoo-2-daa6941e73a4f27967b6e44c1f519e279a297345.zip
Add some die()'s (#54595).
Diffstat (limited to 'app-sci/mpqc')
-rw-r--r--app-sci/mpqc/ChangeLog6
-rw-r--r--app-sci/mpqc/mpqc-2.2.2-r1.ebuild8
-rw-r--r--app-sci/mpqc/mpqc-2.2.2.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/app-sci/mpqc/ChangeLog b/app-sci/mpqc/ChangeLog
index 3ef7e1570d93..c61f956d735d 100644
--- a/app-sci/mpqc/ChangeLog
+++ b/app-sci/mpqc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/mpqc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/ChangeLog,v 1.14 2004/09/23 08:24:09 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/ChangeLog,v 1.15 2004/10/02 17:04:38 spyderous Exp $
+
+ 02 Oct 2004; Donnie Berkholz <spyderous@gentoo.org>; mpqc-2.2.2-r1.ebuild,
+ mpqc-2.2.2.ebuild:
+ Add some die()'s (#54595).
23 Sep 2004; Donnie Berkholz <spyderous@gentoo.org>; mpqc-2.2.2-r1.ebuild:
Add previous KEYWORDS as ~arch.
diff --git a/app-sci/mpqc/mpqc-2.2.2-r1.ebuild b/app-sci/mpqc/mpqc-2.2.2-r1.ebuild
index 8989656132a8..7d57610b4452 100644
--- a/app-sci/mpqc/mpqc-2.2.2-r1.ebuild
+++ b/app-sci/mpqc/mpqc-2.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.2.2-r1.ebuild,v 1.2 2004/09/23 08:24:09 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.2.2-r1.ebuild,v 1.3 2004/10/02 17:04:38 spyderous Exp $
DESCRIPTION="The Massively Parallel Quantum Chemistry Program"
HOMEPAGE="http://www.mpqc.org/"
@@ -24,13 +24,13 @@ src_compile() {
myconf="${myconf} --prefix=/usr"
use X && myconf="${myconf} --x-includes=/usr/X11R6/include \
--x-libraries=/usr/X11R6/lib"
- ./configure ${myconf}
+ ./configure ${myconf} || die "configure failed"
sed -e "s:^CFLAGS =.*$:CFLAGS=${CFLAGS_SAVE}:" \
-e "s:^FFLAGS =.*$:FFLAGS=${CFLAGS_SAVE}:" \
-e "s:^CXXFLAGS =.*$:CXXFLAGS=${CXXFLAGS_SAVE}:" \
lib/LocalMakefile > lib/LocalMakefile.foo
mv lib/LocalMakefile.foo lib/LocalMakefile
- emake
+ emake || die "emake failed"
}
src_install() {
@@ -38,5 +38,5 @@ src_install() {
> lib/LocalMakefile.foo
mv lib/LocalMakefile.foo lib/LocalMakefile
use doc && doman ${WORKDIR}/${PN}-man-${PV}/man3/*
- make install install_devel install_inc
+ make install install_devel install_inc || die "install failed"
}
diff --git a/app-sci/mpqc/mpqc-2.2.2.ebuild b/app-sci/mpqc/mpqc-2.2.2.ebuild
index 92519fd97a97..1579e10632f5 100644
--- a/app-sci/mpqc/mpqc-2.2.2.ebuild
+++ b/app-sci/mpqc/mpqc-2.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.2.2.ebuild,v 1.6 2004/09/21 10:09:22 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.2.2.ebuild,v 1.7 2004/10/02 17:04:38 spyderous Exp $
DESCRIPTION="The Massively Parallel Quantum Chemistry Program"
HOMEPAGE="http://www.mpqc.org/"
@@ -24,13 +24,13 @@ src_compile() {
myconf="${myconf} --prefix=/usr"
use X && myconf="${myconf} --x-includes=/usr/X11R6/include \
--x-libraries=/usr/X11R6/lib"
- ./configure ${myconf}
+ ./configure ${myconf} || die "configure failed"
sed -e "s:^CFLAGS =.*$:CFLAGS=${CFLAGS_SAVE}:" \
-e "s:^FFLAGS =.*$:FFLAGS=${CFLAGS_SAVE}:" \
-e "s:^CXXFLAGS =.*$:CXXFLAGS=${CXXFLAGS_SAVE}:" \
lib/LocalMakefile > lib/LocalMakefile.foo
mv lib/LocalMakefile.foo lib/LocalMakefile
- emake
+ emake || die "emake failed"
}
src_install() {
@@ -38,5 +38,5 @@ src_install() {
> lib/LocalMakefile.foo
mv lib/LocalMakefile.foo lib/LocalMakefile
use doc && doman ${WORKDIR}/${PN}-man-${PV}/man3/*
- make install install_devel install_inc
+ make install install_devel install_inc || die "install failed"
}