summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-09-23 10:29:54 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-09-23 10:29:54 +0000
commiteea8ec30f199ab2dafbc9c98f5f9af9121a1d432 (patch)
treefbcc69eb92bc2895f26c1a522d671f9982dd04f6 /app-portage
parentversion bump (diff)
downloadgentoo-2-eea8ec30f199ab2dafbc9c98f5f9af9121a1d432.tar.gz
gentoo-2-eea8ec30f199ab2dafbc9c98f5f9af9121a1d432.tar.bz2
gentoo-2-eea8ec30f199ab2dafbc9c98f5f9af9121a1d432.zip
revision bump to fix Launchpad bug 434385
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/g-ctan/ChangeLog9
-rw-r--r--app-portage/g-ctan/files/g-ctan-2008.1-fix-overlay-detection.patch13
-rw-r--r--app-portage/g-ctan/g-ctan-2008.1-r1.ebuild (renamed from app-portage/g-ctan/g-ctan-2008.1.ebuild)8
3 files changed, 28 insertions, 2 deletions
diff --git a/app-portage/g-ctan/ChangeLog b/app-portage/g-ctan/ChangeLog
index 70e686f6cfb9..4d95a2bfdc85 100644
--- a/app-portage/g-ctan/ChangeLog
+++ b/app-portage/g-ctan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/g-ctan
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/g-ctan/ChangeLog,v 1.7 2009/09/21 23:37:22 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/g-ctan/ChangeLog,v 1.8 2009/09/23 10:29:54 fauli Exp $
+
+*g-ctan-2008.1-r1 (23 Sep 2009)
+
+ 23 Sep 2009; Christian Faulhammer <fauli@gentoo.org>
+ -g-ctan-2008.1.ebuild, +g-ctan-2008.1-r1.ebuild,
+ +files/g-ctan-2008.1-fix-overlay-detection.patch:
+ revision bump to fix Launchpad bug 434385
21 Sep 2009; Christian Faulhammer <fauli@gentoo.org> -g-ctan-9999.ebuild:
clean up
diff --git a/app-portage/g-ctan/files/g-ctan-2008.1-fix-overlay-detection.patch b/app-portage/g-ctan/files/g-ctan-2008.1-fix-overlay-detection.patch
new file mode 100644
index 000000000000..76b64953b3f6
--- /dev/null
+++ b/app-portage/g-ctan/files/g-ctan-2008.1-fix-overlay-detection.patch
@@ -0,0 +1,13 @@
+=== modified file 'modules/ebuild'
+--- modules/ebuild 2009-09-14 21:41:25 +0000
++++ modules/ebuild 2009-09-23 10:09:51 +0000
+@@ -48,7 +48,7 @@
+ # Manifest generation.
+ prepare_ebuild() {
+ # Make sure that set_up() (for PV variable) has been called before.
+- if ! [[ $(portageq portdir_overlay | grep "${G_OVERLAY_DIR%%/}.") ]]
++ if ! [[ $(portageq portdir_overlay | grep "${G_OVERLAY_DIR%%/}") ]]
+ then
+ failure "Configured location ${G_OVERLAY_DIR} is not found in"
+ failure "PORTDIR_OVERLAY variable in /etc/make.conf. Please"
+
diff --git a/app-portage/g-ctan/g-ctan-2008.1.ebuild b/app-portage/g-ctan/g-ctan-2008.1-r1.ebuild
index 16da25fac683..668d471b6811 100644
--- a/app-portage/g-ctan/g-ctan-2008.1.ebuild
+++ b/app-portage/g-ctan/g-ctan-2008.1-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/g-ctan/g-ctan-2008.1.ebuild,v 1.1 2009/09/21 23:32:03 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/g-ctan/g-ctan-2008.1-r1.ebuild,v 1.1 2009/09/23 10:29:54 fauli Exp $
EAPI=2
+inherit eutils
+
DESCRIPTION="Generate and install ebuilds from the TeXLive package manager"
HOMEPAGE="http://launchpad.net/g-ctan"
SRC_URI="http://launchpad.net/g-ctan/2008/${PV}/+download/${P}.tar.bz2"
@@ -18,6 +20,10 @@ RDEPEND="~app-text/texlive-2008
|| ( app-arch/xz-utils app-arch/lzma-utils[-nocxx] )
>=dev-libs/libpcre-0.7.6"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-overlay-detection.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die
}