summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-04-17 16:07:52 +0000
committerMichał Górny <mgorny@gentoo.org>2012-04-17 16:07:52 +0000
commitc10f54e2b2225a9798fd626fa4291bb2fc7f21d5 (patch)
tree66d34154a5bb899775d34106695df5c6aa869dd5 /app-portage
parentMarking pybliographer-1.2.14 ppc for bug 404615 (diff)
downloadgentoo-2-c10f54e2b2225a9798fd626fa4291bb2fc7f21d5.tar.gz
gentoo-2-c10f54e2b2225a9798fd626fa4291bb2fc7f21d5.tar.bz2
gentoo-2-c10f54e2b2225a9798fd626fa4291bb2fc7f21d5.zip
Version bump. This time it fixes the timeout issue definitely.
(Portage version: 2.2.0_alpha100_p9/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/ChangeLog8
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.2.3.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/app-portage/smart-live-rebuild/ChangeLog b/app-portage/smart-live-rebuild/ChangeLog
index 015ec30810a2..808540fec880 100644
--- a/app-portage/smart-live-rebuild/ChangeLog
+++ b/app-portage/smart-live-rebuild/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/smart-live-rebuild
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.36 2012/04/17 16:03:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.37 2012/04/17 16:07:52 mgorny Exp $
+
+*smart-live-rebuild-1.2.3 (17 Apr 2012)
+
+ 17 Apr 2012; Michał Górny <mgorny@gentoo.org>
+ +smart-live-rebuild-1.2.3.ebuild:
+ Version bump. This time it fixes the timeout issue definitely.
17 Apr 2012; Michał Górny <mgorny@gentoo.org>
-smart-live-rebuild-1.2.2.ebuild:
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.3.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.3.ebuild
new file mode 100644
index 000000000000..52d7af8fc819
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.3.ebuild,v 1.1 2012/04/17 16:07:52 mgorny Exp $
+
+EAPI=4
+
+PYTHON_DEPEND='2:2.6'
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
+DISTUTILS_SRC_TEST=setup.py
+
+inherit base distutils
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://bitbucket.org/mgorny/smart-live-rebuild/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1
+ !sys-apps/portage[python3]"
+
+PYTHON_MODNAME=smartliverebuild
+
+src_prepare() {
+ base_src_prepare
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example ${PN}.conf
+}