summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-04-05 21:04:18 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-04-05 21:04:18 +0000
commitaeb37ac3d139c0968b3accba2e28dd851503e1e8 (patch)
tree2a09d24ec4a91c8725cf4de52f9bf91ce85bc805 /app-portage
parentamd64/arm/x86 stable, bug #310015 (diff)
downloadgentoo-2-aeb37ac3d139c0968b3accba2e28dd851503e1e8.tar.gz
gentoo-2-aeb37ac3d139c0968b3accba2e28dd851503e1e8.tar.bz2
gentoo-2-aeb37ac3d139c0968b3accba2e28dd851503e1e8.zip
Version bump to 0.3.0_rc10, please take a look at bug 237964 for more information about the changes in this release. Thanks to all contributors! Merge ebuild related changes in _rc10 to gentoolkit-9999 as well.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/ChangeLog10
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.3.0_rc10.ebuild63
-rw-r--r--app-portage/gentoolkit/gentoolkit-9999.ebuild20
3 files changed, 80 insertions, 13 deletions
diff --git a/app-portage/gentoolkit/ChangeLog b/app-portage/gentoolkit/ChangeLog
index bc532a408603..caad6a600434 100644
--- a/app-portage/gentoolkit/ChangeLog
+++ b/app-portage/gentoolkit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-portage/gentoolkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.186 2010/04/01 17:15:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.187 2010/04/05 21:04:18 idl0r Exp $
+
+*gentoolkit-0.3.0_rc10 (05 Apr 2010)
+
+ 05 Apr 2010; Christian Ruppert <idl0r@gentoo.org>
+ +gentoolkit-0.3.0_rc10.ebuild, gentoolkit-9999.ebuild:
+ Version bump to 0.3.0_rc10, please take a look at bug 237964 for more
+ information about the changes in this release. Thanks to all contributors!
+ Merge ebuild related changes in _rc10 to gentoolkit-9999 as well.
01 Apr 2010; Raúl Porcel <armin76@gentoo.org>
gentoolkit-0.2.4.6.1.ebuild, gentoolkit-0.3.0_rc8.ebuild,
diff --git a/app-portage/gentoolkit/gentoolkit-0.3.0_rc10.ebuild b/app-portage/gentoolkit/gentoolkit-0.3.0_rc10.ebuild
new file mode 100644
index 000000000000..f87dea8da4c6
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.3.0_rc10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-0.3.0_rc10.ebuild,v 1.1 2010/04/05 21:04:18 idl0r Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_DISABLE_VERSIONING_OF_PYTHON_SCRIPTS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+
+inherit distutils python
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/tools/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# Drop ~sparc-fbsd ~x86-fbsd due to app-misc/realpath dependency
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="sys-apps/portage
+ >=dev-lang/python-2.6[xml]
+ !!>=dev-lang/python-2.6[-xml]"
+RDEPEND="${DEPEND}
+ app-misc/realpath
+ sys-apps/gawk
+ sys-apps/grep"
+
+distutils_src_compile_pre_hook() {
+ echo VERSION="${PV}" "$(PYTHON)" setup.py set_version
+ VERSION="${PV}" "$(PYTHON)" setup.py set_version
+}
+
+src_install() {
+ python_convert_shebangs -r "" build-*/scripts-*
+ distutils_src_install
+
+ # Create cache directory for revdep-rebuild
+ dodir /var/cache/revdep-rebuild
+ keepdir /var/cache/revdep-rebuild
+ fowners root:root /var/cache/revdep-rebuild
+ fperms 0700 /var/cache/revdep-rebuild
+
+ # Can distutils handle this?
+ dosym eclean /usr/bin/eclean-dist
+ dosym eclean /usr/bin/eclean-pkg
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ # Make sure that our ownership and permissions stuck
+ chown root:root "${ROOT}/var/cache/revdep-rebuild"
+ chmod 0700 "${ROOT}/var/cache/revdep-rebuild"
+
+ einfo
+ einfo "For further information on gentoolkit, please read the gentoolkit"
+ einfo "guide: http://www.gentoo.org/doc/en/gentoolkit.xml"
+ einfo
+ einfo "Another alternative to equery is app-portage/portage-utils"
+}
diff --git a/app-portage/gentoolkit/gentoolkit-9999.ebuild b/app-portage/gentoolkit/gentoolkit-9999.ebuild
index f63f70a94a21..ae429ad9afec 100644
--- a/app-portage/gentoolkit/gentoolkit-9999.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-9999.ebuild,v 1.7 2010/03/12 20:19:12 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-9999.ebuild,v 1.8 2010/04/05 21:04:18 idl0r Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
DISTUTILS_DISABLE_VERSIONING_OF_PYTHON_SCRIPTS="1"
RESTRICT_PYTHON_ABIS="2.[45]"
-inherit distutils subversion
+inherit distutils python subversion
ESVN_REPO_URI="svn://anonsvn.gentoo.org/gentoolkit/trunk/gentoolkit"
ESVN_PROJECT="gentoolkit"
@@ -22,13 +22,13 @@ IUSE=""
KEYWORDS=""
-DEPEND=">=dev-lang/python-2.6[xml]
- sys-apps/portage
- dev-lang/perl
- sys-apps/grep
- sys-apps/gawk"
+DEPEND="sys-apps/portage
+ >=dev-lang/python-2.6[xml]
+ !!>=dev-lang/python-2.6[-xml]"
RDEPEND="${DEPEND}
- app-misc/realpath"
+ app-misc/realpath
+ sys-apps/gawk
+ sys-apps/grep"
distutils_src_compile_pre_hook() {
echo VERSION="9999-r${ESVN_WC_REVISION}" "$(PYTHON)" setup.py set_version
@@ -68,7 +68,3 @@ pkg_postinst() {
einfo
einfo "Another alternative to equery is app-portage/portage-utils"
}
-
-pkg_info() {
- eselect python show
-}