summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-06-24 18:02:10 +0000
committerAron Griffis <agriffis@gentoo.org>2005-06-24 18:02:10 +0000
commit845f99ecf3a1a8fff5c7f3d8c3831fad0628a4d7 (patch)
treeaddf02ef637134ce5cebc45f09a228410d6e1bd0 /app-portage
parentStable on IA64. (diff)
downloadgentoo-2-845f99ecf3a1a8fff5c7f3d8c3831fad0628a4d7.tar.gz
gentoo-2-845f99ecf3a1a8fff5c7f3d8c3831fad0628a4d7.tar.bz2
gentoo-2-845f99ecf3a1a8fff5c7f3d8c3831fad0628a4d7.zip
Use pkg_preinst for chgrp rather than pkg_postinst
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/herdstat/ChangeLog4
-rw-r--r--app-portage/herdstat/herdstat-1.1.1_p1.ebuild8
2 files changed, 7 insertions, 5 deletions
diff --git a/app-portage/herdstat/ChangeLog b/app-portage/herdstat/ChangeLog
index 1260c31b9b63..00af33b6214a 100644
--- a/app-portage/herdstat/ChangeLog
+++ b/app-portage/herdstat/ChangeLog
@@ -1,9 +1,9 @@
# ChangeLog for app-portage/herdstat
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/herdstat/ChangeLog,v 1.42 2005/06/24 16:13:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/herdstat/ChangeLog,v 1.43 2005/06/24 18:02:10 agriffis Exp $
24 Jun 2005; Aron Griffis <agriffis@gentoo.org> herdstat-1.1.1_p1.ebuild:
- fowners root:portage in src_install doesn't work. Use chgrp in pkg_postinst
+ fowners root:portage in src_install doesn't work. Use chgrp in pkg_preinst
instead
*herdstat-1.1.1_p1 (24 Jun 2005)
diff --git a/app-portage/herdstat/herdstat-1.1.1_p1.ebuild b/app-portage/herdstat/herdstat-1.1.1_p1.ebuild
index 9e3f11a1e810..5e60a982d457 100644
--- a/app-portage/herdstat/herdstat-1.1.1_p1.ebuild
+++ b/app-portage/herdstat/herdstat-1.1.1_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/herdstat/herdstat-1.1.1_p1.ebuild,v 1.2 2005/06/24 16:13:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/herdstat/herdstat-1.1.1_p1.ebuild,v 1.3 2005/06/24 18:02:10 agriffis Exp $
inherit bash-completion toolchain-funcs
@@ -44,9 +44,11 @@ src_install() {
fperms 0775 /var/lib/herdstat
}
-pkg_postinst() {
- chgrp portage ${ROOT}/var/lib/herdstat
+pkg_preinst() {
+ chgrp portage ${IMAGE}/var/lib/herdstat
+}
+pkg_postinst() {
# remove any previous caches, as it's possible that the internal
# format has changed, and may cause bugs.
rm -f ${ROOT}var/lib/herdstat/*cache*