summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-23 08:28:53 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-23 08:28:53 +0000
commit8255bbfd090ceaa2f2cec167c787ecd73a4c5e0d (patch)
tree44d04affa038d236c6230ef2a9393bb135f060b1 /app-portage
parent2.1.6.10 bump. This fixes bug #263081 (UnicodeDecodeError when using the (diff)
downloadgentoo-2-8255bbfd090ceaa2f2cec167c787ecd73a4c5e0d.tar.gz
gentoo-2-8255bbfd090ceaa2f2cec167c787ecd73a4c5e0d.tar.bz2
gentoo-2-8255bbfd090ceaa2f2cec167c787ecd73a4c5e0d.zip
old
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portage-utils/files/qmerge-posix-180871.patch16
-rw-r--r--app-portage/portage-utils/portage-utils-0.1.28.ebuild67
2 files changed, 0 insertions, 83 deletions
diff --git a/app-portage/portage-utils/files/qmerge-posix-180871.patch b/app-portage/portage-utils/files/qmerge-posix-180871.patch
deleted file mode 100644
index 63172f174b24..000000000000
--- a/app-portage/portage-utils/files/qmerge-posix-180871.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: qmerge.c
-===================================================================
-RCS file: /var/cvsroot/gentoo-projects/portage-utils/qmerge.c,v
-retrieving revision 1.75
-diff -u -b -B -r1.75 qmerge.c
---- qmerge.c 3 Jun 2007 19:17:39 -0000 1.75
-+++ qmerge.c 4 Jun 2007 16:50:32 -0000
-@@ -952,7 +952,7 @@
-
- if (pkg->MD5[0]) {
- if ((hash = (char*) hash_file(fname, HASH_MD5)) == NULL) {
-- errf("hash is NULL for %s %s", fname, get_current_dir_name());
-+ errf("hash is NULL for %s", fname);
- }
- if (strcmp(hash, pkg->MD5) == 0) {
- if (display)
diff --git a/app-portage/portage-utils/portage-utils-0.1.28.ebuild b/app-portage/portage-utils/portage-utils-0.1.28.ebuild
deleted file mode 100644
index 59215049f87f..000000000000
--- a/app-portage/portage-utils/portage-utils-0.1.28.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/portage-utils/portage-utils-0.1.28.ebuild,v 1.11 2007/08/25 13:46:58 vapier Exp $
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="small and fast portage helper tools written in C"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/qmerge-posix-180871.patch"
-}
-
-src_compile() {
- tc-export CC
- emake || die
-}
-
-src_install() {
- dobin q || die "dobin failed"
- doman man/*.[0-9]
- for applet in $(<applet-list) ; do
- dosym q /usr/bin/${applet}
- done
-}
-
-pkg_postinst() {
- [ -e ${ROOT}/etc/portage/bin/post_sync ] && return 0
- mkdir -p ${ROOT}/etc/portage/bin/
-
-cat <<__EOF__ > ${ROOT}/etc/portage/bin/post_sync
-#!/bin/sh
-# Copyright 2006-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-if [ -d /etc/portage/postsync.d/ ]; then
- for f in /etc/portage/postsync.d/* ; do
- if [ -x \${f} ] ; then
- \${f}
- fi
- done
-else
- :
-fi
-__EOF__
- chmod 755 ${ROOT}/etc/portage/bin/post_sync
- if [ ! -e ${ROOT}/etc/portage/postsync.d/q-reinitialize ]; then
- mkdir -p ${ROOT}/etc/portage/postsync.d/
- echo '[ -x /usr/bin/q ] && /usr/bin/q -qr' > ${ROOT}/etc/portage/postsync.d/q-reinitialize
- elog "${ROOT}/etc/portage/postsync.d/q-reinitialize has been installed for convenience"
- elog "If you wish for it to be automatically run at the end of every --sync simply chmod +x ${ROOT}/etc/portage/postsync.d/q-reinitialize"
- elog "Normally this should only take a few seconds to run but file systems such as ext3 can take a lot longer."
- elog "If ever you find this to be an inconvenience simply chmod -x ${ROOT}/etc/portage/postsync.d/q-reinitialize"
- fi
- :
-}