summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-09-08 15:40:46 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-09-08 15:40:46 +0000
commit73f3e6496321bda893d58d6264c9cc1f367505bd (patch)
tree7510b449aae9a54ddaee0f86b932cc94dcd3b26e /app-portage
parentMask =app-portage/eix-0.17.1 because it needs xz-utils and that conflicts wit... (diff)
downloadgentoo-2-73f3e6496321bda893d58d6264c9cc1f367505bd.tar.gz
gentoo-2-73f3e6496321bda893d58d6264c9cc1f367505bd.tar.bz2
gentoo-2-73f3e6496321bda893d58d6264c9cc1f367505bd.zip
Version bump, misc bug fixes and USE=bzip2 support
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog8
-rw-r--r--app-portage/eix/eix-0.17.1.ebuild77
-rw-r--r--app-portage/eix/metadata.xml1
3 files changed, 85 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 8ce0f44ff0ae..e765fc04611a 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.302 2009/09/01 16:29:24 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.303 2009/09/08 15:40:46 darkside Exp $
+
+*eix-0.17.1 (08 Sep 2009)
+
+ 08 Sep 2009; Jeremy Olexa <darkside@gentoo.org> +eix-0.17.1.ebuild,
+ metadata.xml:
+ Version bump, misc bug fixes and USE=bzip2 support
01 Sep 2009; Tiago Cunha <tcunha@gentoo.org> eix-0.17.0.ebuild:
stable sparc, bug 282379
diff --git a/app-portage/eix/eix-0.17.1.ebuild b/app-portage/eix/eix-0.17.1.ebuild
new file mode 100644
index 000000000000..3ab0905f7e9e
--- /dev/null
+++ b/app-portage/eix/eix-0.17.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.17.1.ebuild,v 1.1 2009/09/08 15:40:46 darkside Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.sourceforge.net"
+SRC_URI="mirror://sourceforge/eix/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="+bzip2 +deprecated doc nls sqlite tools"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ doc? ( dev-python/docutils )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ local i s
+ for i in ${A}
+ do
+ s="${DISTDIR%/}/${i}"
+ einfo "Unpacking ${s} to ${PWD}"
+ test -s "${s}" || die "${s} does not exist"
+ xz -dc -- "${s}" | tar xof - || die "Unpacking ${s} failed"
+ done
+}
+
+src_configure() {
+ econf $(use_with bzip2) $(use_with sqlite) $(use_with doc rst) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ $(use_enable deprecated obsolete-reminder)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog doc/format.txt
+ use doc && dodoc doc/format.html
+}
+
+pkg_postinst() {
+ elog "Ask your overlay maintainers to provide metadata or consider to run"
+ elog " egencache --repo=foo --update"
+ elog "after updates (e.g. in /etc/eix-sync)."
+ elog "This will speed up portage and eix-update (when the new default cache method"
+ elog "\"...#metadata-flat\" is used and file dates are correct) for those overlays."
+ elog "If metadata is provided but file dates are mangled during overlay updates,"
+ elog "you may switch to cache method \"metadata-flat\" instead for that overlay:"
+ elog "This is even faster, but works only if metadata is actually up-to-date."
+ ewarn
+ ewarn "Security Warning:"
+ ewarn
+ ewarn "Since >=eix-0.12.0, eix uses by default OVERLAY_CACHE_METHOD=\"parse|ebuild*\""
+ ewarn "(since >=eix-0.16.1 with automagic \"#metadata-flat\")."
+ ewarn "This is rather reliable, but ebuilds may be executed by user \"portage\". Set"
+ ewarn "OVERLAY_CACHE_METHOD=parse in /etc/eixrc if you do not trust the ebuilds."
+ if use deprecated; then
+ elog "ATTENTION: The old eix executable names will be going away in 6"
+ elog "months or the next major release, whichever is first. Update"
+ elog "your scripts"
+ else
+ elog "ATTENTION: The eix executable names have changed. Update your"
+ elog "scripts, if needed. This message will go away soon."
+ fi
+
+}
diff --git a/app-portage/eix/metadata.xml b/app-portage/eix/metadata.xml
index 76b48b510d19..10881363bafa 100644
--- a/app-portage/eix/metadata.xml
+++ b/app-portage/eix/metadata.xml
@@ -13,6 +13,7 @@
<description>Proxy committer, CC bugs</description>
</maintainer>
<use>
+ <flag name="bzip2">Support for parsing of environment.bz2 to guess repository name of packages installed with ancient portage versions (requires <pkg>app-arch/bbzip2</pkg>). This flag is safe to disable for portage users that have re-merged all packages since 2007. This flag will be phased out.</flag>
<flag name="deprecated">Installs wrapper scripts for all the previous executable names that will soon be going away</flag>
<flag name="doc">Create description of the eix cache file additionally in html format</flag>
<flag name="nls">Support foreign language messages (experimental; currently only de)</flag>