summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-06-22 11:44:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-06-22 11:44:01 +0000
commitf48cef4b83bb4cced23366b2fb575202e1ca92b4 (patch)
tree1085abc980cacbdc4edf90173f65bb5623e27388 /app-pda
parentwrt bug 514244, missing patch fixed (diff)
downloadgentoo-2-f48cef4b83bb4cced23366b2fb575202e1ca92b4.tar.gz
gentoo-2-f48cef4b83bb4cced23366b2fb575202e1ca92b4.tar.bz2
gentoo-2-f48cef4b83bb4cced23366b2fb575202e1ca92b4.zip
Fix building with >=dev-libs/libwbxml-0.11.0 by using #include <wbxml/wbxml.h> instead of #include <wbxml.h> wrt #425738 by Diego Elio Pettenò
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libsyncml/ChangeLog10
-rw-r--r--app-pda/libsyncml/libsyncml-0.5.4.ebuild29
-rw-r--r--app-pda/libsyncml/libsyncml-9999.ebuild27
3 files changed, 36 insertions, 30 deletions
diff --git a/app-pda/libsyncml/ChangeLog b/app-pda/libsyncml/ChangeLog
index dfea00ffcbf4..8bfa15b7b4cb 100644
--- a/app-pda/libsyncml/ChangeLog
+++ b/app-pda/libsyncml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/libsyncml
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.20 2012/05/03 20:20:59 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.21 2014/06/22 11:44:01 ssuominen Exp $
+
+ 22 Jun 2014; Samuli Suominen <ssuominen@gentoo.org> libsyncml-0.5.4.ebuild,
+ libsyncml-9999.ebuild:
+ Fix building with >=dev-libs/libwbxml-0.11.0 by using #include <wbxml/wbxml.h>
+ instead of #include <wbxml.h> wrt #425738 by Diego Elio Pettenò
03 May 2012; Jeff Horelick <jdhore@gentoo.org> libsyncml-0.5.4.ebuild,
libsyncml-9999.ebuild:
@@ -109,4 +114,3 @@
13 Nov 2006; Piotr Jaroszyński <peper@gentoo.org> +metadata.xml,
+libsyncml-0.4.2.ebuild:
New package.
-
diff --git a/app-pda/libsyncml/libsyncml-0.5.4.ebuild b/app-pda/libsyncml/libsyncml-0.5.4.ebuild
index 85b1f36cdbdd..bab756754450 100644
--- a/app-pda/libsyncml/libsyncml-0.5.4.ebuild
+++ b/app-pda/libsyncml/libsyncml-0.5.4.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.5.4.ebuild,v 1.3 2012/05/03 20:20:59 jdhore Exp $
-
-EAPI="2"
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.5.4.ebuild,v 1.4 2014/06/22 11:44:01 ssuominen Exp $
+EAPI=5
inherit cmake-utils
DESCRIPTION="Implementation of the SyncML protocol"
@@ -30,29 +29,31 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
test? ( >=dev-libs/check-0.9.7 )"
-pkg_setup() {
- if ! use obex && ! use http; then
- eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
- eerror "Please enable \"obex\" or/and \"http\" USE flags."
- die "Please enable \"obex\" or/and \"http\" USE flags."
- fi
+REQUIRED_USE="|| ( http obex )"
+
+DOCS="AUTHORS CODING ChangeLog RELEASE"
- DOCS="AUTHORS CODING ChangeLog RELEASE"
+src_prepare() {
+ # http://bugs.gentoo.org/425738
+ sed -i \
+ -e '/include/s:wbxml.h:wbxml/&:' \
+ libsyncml/parser/sml_wbxml_internals.h tests/mobiles/obex_mobile_ds_client.c || die
}
src_configure() {
- local mycmakeargs="
+ local mycmakeargs=(
-DHAVE_LIBSOUP22=OFF
-DDOC_INSTALL_DIR=/usr/share/doc/${PF}
$(cmake-utils_use_enable debug TRACE)
$(cmake-utils_use_enable http HTTP)
$(cmake-utils_use_enable obex OBEX)
$(cmake-utils_use_enable obex BLUETOOTH)
- $(cmake-utils_use_enable test UNIT_TEST)"
+ $(cmake-utils_use_enable test UNIT_TEST)
+ )
if use http && use obex; then
# Doc builds with those previous USE flags only
- mycmakeargs="${mycmakeargs} $(cmake-utils_use_build doc DOCUMENTATION)"
+ mycmakeargs+=( $(cmake-utils_use_build doc DOCUMENTATION) )
fi
cmake-utils_src_configure
diff --git a/app-pda/libsyncml/libsyncml-9999.ebuild b/app-pda/libsyncml/libsyncml-9999.ebuild
index a83bd4b3ee47..d517c1d37bb4 100644
--- a/app-pda/libsyncml/libsyncml-9999.ebuild
+++ b/app-pda/libsyncml/libsyncml-9999.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-9999.ebuild,v 1.7 2012/05/03 20:20:59 jdhore Exp $
-
-EAPI="2"
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-9999.ebuild,v 1.8 2014/06/22 11:44:01 ssuominen Exp $
+EAPI=5
inherit cmake-utils subversion
DESCRIPTION="Implementation of the SyncML protocol"
@@ -32,25 +31,27 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
test? ( >=dev-libs/check-0.9.7 )"
-pkg_setup() {
- if ! use obex && ! use http; then
- eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
- eerror "Please enable \"obex\" or/and \"http\" USE flags."
- die "Please enable \"obex\" or/and \"http\" USE flags."
- fi
+REQUIRED_USE="|| ( http obex )"
+
+DOCS="AUTHORS CODING ChangeLog RELEASE"
- DOCS="AUTHORS CODING ChangeLog RELEASE"
+src_prepare() {
+ # http://bugs.gentoo.org/425738
+ sed -i \
+ -e '/include/s:wbxml.h:wbxml/&:' \
+ libsyncml/parser/sml_wbxml_internals.h tests/mobiles/obex_mobile_ds_client.c || die
}
src_configure() {
- local mycmakeargs="
+ local mycmakeargs=(
-DHAVE_LIBSOUP22=OFF
$(cmake-utils_use_build doc DOCUMENTATION)
$(cmake-utils_use_enable debug TRACE)
$(cmake-utils_use_enable http HTTP)
$(cmake-utils_use_enable obex OBEX)
$(cmake-utils_use_enable obex BLUETOOTH)
- $(cmake-utils_use_enable test UNIT_TEST)"
+ $(cmake-utils_use_enable test UNIT_TEST)
+ )
cmake-utils_src_configure
}