summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-06-27 02:47:33 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-06-27 02:47:33 +0000
commit40f986bc0dad789465c01256fef8d08434ef4547 (patch)
treed80d89b24b047c1eacf0779a8b85d0b2b241a4dd /app-pda
parentpatch to support Clie TJ-35 by Guy Van Sanden <nocturn@pandora.be> (#52550) (diff)
downloadgentoo-2-40f986bc0dad789465c01256fef8d08434ef4547.tar.gz
gentoo-2-40f986bc0dad789465c01256fef8d08434ef4547.tar.bz2
gentoo-2-40f986bc0dad789465c01256fef8d08434ef4547.zip
version bump (#53696)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/multisync/ChangeLog7
-rw-r--r--app-pda/multisync/files/digest-multisync-0.821
-rw-r--r--app-pda/multisync/multisync-0.82.ebuild84
3 files changed, 91 insertions, 1 deletions
diff --git a/app-pda/multisync/ChangeLog b/app-pda/multisync/ChangeLog
index abe6934dcf09..dc080b96fc47 100644
--- a/app-pda/multisync/ChangeLog
+++ b/app-pda/multisync/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/multisync
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/ChangeLog,v 1.8 2004/06/24 21:43:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/ChangeLog,v 1.9 2004/06/27 02:47:33 liquidx Exp $
+
+*multisync-0.82 (26 Jun 2004)
+
+ 26 Jun 2004; Alastair Tse <liquidx@gentoo.org> +multisync-0.82.ebuild:
+ version bump (#53696)
24 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
multisync-0.80-r1.ebuild, multisync-0.81.ebuild:
diff --git a/app-pda/multisync/files/digest-multisync-0.82 b/app-pda/multisync/files/digest-multisync-0.82
new file mode 100644
index 000000000000..60d12d881bf2
--- /dev/null
+++ b/app-pda/multisync/files/digest-multisync-0.82
@@ -0,0 +1 @@
+MD5 499aaa3d41e33276ab162db1d1912a16 multisync-0.82.tar.bz2 1432473
diff --git a/app-pda/multisync/multisync-0.82.ebuild b/app-pda/multisync/multisync-0.82.ebuild
new file mode 100644
index 000000000000..e5bd1a7dd55e
--- /dev/null
+++ b/app-pda/multisync/multisync-0.82.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.82.ebuild,v 1.1 2004/06/27 02:47:33 liquidx Exp $
+
+inherit eutils
+
+DESCRIPTION="Client to sync apps with WinCE or mobile devices"
+HOMEPAGE="http://multisync.sourceforge.net/"
+SRC_URI="mirror://sourceforge/multisync/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="evo irmc opie ldap bluetooth"
+# evo - evolution plugin
+# irmc - bluetooth/irmc/irda plugin ( local )
+# opie - opie plugin ( local )
+# ldap - ldap plugin - experimental
+
+DEPEND=">=gnome-base/libbonobo-2.2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnome-2.2
+ >=dev-libs/glib-2
+ >=gnome-base/gconf-2
+ >=gnome-base/gnome-vfs-2.2
+ >=gnome-base/ORBit2-2.8.2
+ >=dev-libs/openssl-0.9.6j
+ evo? ( =mail-client/evolution-1.4* )
+ irmc? ( >=sys-apps/irda-utils-0.9.15
+ >=dev-libs/openobex-1
+ bluetooth? ( >=net-wireless/bluez-libs-2.7
+ >=net-wireless/bluez-utils-2.7 )
+ )
+ opie? ( >=net-misc/curl-7.10.5 )
+ ldap? ( >=net-nds/openldap-2.0.27
+ >=dev-libs/cyrus-sasl-2.1.4 )"
+
+make_plugin_list() {
+ export PLUGINS="backup_plugin syncml_plugin"
+ use irmc && PLUGINS="${PLUGINS} irmc_sync"
+ use evo && PLUGINS="${PLUGINS} evolution_sync"
+ use opie && PLUGINS="${PLUGINS} opie_sync"
+ use ldap && PLUGINS="${PLUGINS} ldap_plugin"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Fix the opie Makefile
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-0.81-gentoo.patch
+}
+
+src_compile() {
+ make_plugin_list
+
+ einfo "Building Multisync with these plugins:"
+ for plugin_dir in ${PLUGINS}
+ do
+ einfo " ${plugin_dir}"
+ done
+
+ cd ${S}
+ econf || die
+ make || die "Multisync make failed"
+
+ cd ${S}/plugins
+ for plugin_dir in ${PLUGINS}
+ do
+ cd ${S}/plugins/${plugin_dir}
+ econf || die "${plugin_dir} config failed!"
+ make || die "${plugin_dir} make failed!"
+ done
+}
+
+src_install() {
+ make_plugin_list
+ einstall || die "Multisync install failed!"
+ for plugin_dir in ${PLUGINS}
+ do
+ cd ${S}/plugins/${plugin_dir}
+ einstall || die "${plugin_dir} make failed!"
+ done
+}