summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-08-19 00:01:11 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-08-19 00:01:11 +0000
commitfe13cb134bdde93b200d8f8adc56af2787b30d98 (patch)
treed0cd91b9687f815550b9a13a523b520223791d99 /app-office
parentMasked new php ebuilds for testing (diff)
downloadgentoo-2-fe13cb134bdde93b200d8f8adc56af2787b30d98.tar.gz
gentoo-2-fe13cb134bdde93b200d8f8adc56af2787b30d98.tar.bz2
gentoo-2-fe13cb134bdde93b200d8f8adc56af2787b30d98.zip
new version, fixes build problems with -fomit-frame-pointer
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/ChangeLog7
-rw-r--r--app-office/gnucash/files/digest-gnucash-1.6.71
-rw-r--r--app-office/gnucash/gnucash-1.6.7.ebuild66
3 files changed, 73 insertions, 1 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index 91f638c0e21a..1ac8fbe24084 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for app-office/gnucash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.4 2002/08/08 03:23:31 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.5 2002/08/19 00:01:11 spider Exp $
+*gnucash-1.6.7 (19 Aug 2002)
+ 19 Aug 2002; Spider <spider@gentoo.org> gnucash-1.6.7.ebuild :
+ filter out -fomit-frame-pointer as it fails to build with this
+ update to last version
+
*gnucash-1.6.6-r1 (07 Aug 2002)
07 Aug 2002; L. Boshell <leonardop@gentoo.org> gnucash-1.6.6-r1.ebuild:
diff --git a/app-office/gnucash/files/digest-gnucash-1.6.7 b/app-office/gnucash/files/digest-gnucash-1.6.7
new file mode 100644
index 000000000000..ab827dce5585
--- /dev/null
+++ b/app-office/gnucash/files/digest-gnucash-1.6.7
@@ -0,0 +1 @@
+MD5 6ae1502593e75248fee43d841edfb8a7 gnucash-1.6.7.tar.gz 16656960
diff --git a/app-office/gnucash/gnucash-1.6.7.ebuild b/app-office/gnucash/gnucash-1.6.7.ebuild
new file mode 100644
index 000000000000..96f0fed6dee5
--- /dev/null
+++ b/app-office/gnucash/gnucash-1.6.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.6.7.ebuild,v 1.1 2002/08/19 00:01:11 spider Exp $
+
+inherit flag-o-matic
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A personal finance manager"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnucash.org/"
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-libs/libxml-1.8.3
+ >=gnome-extra/gtkhtml-0.14.0-r1
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-extra/guppi-0.35.5-r2
+ >=gnome-base/gnome-print-0.21
+ postgres? ( dev-db/postgresql )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/perl-5
+ >=dev-libs/slib-2.3.8
+ >=dev-lang/swig-1.3_alpha4
+ >=dev-libs/g-wrap-1.1.5
+ <gnome-base/libglade-2
+ media-libs/gdk-pixbuf
+ dev-util/guile
+ gnome-base/libghttp
+ nls? ( sys-devel/gettext )"
+
+
+# won't configure with this
+filter-flags -fomit-frame-pointer
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/guile
+ cp argv-list-converters.c argv-list-converters.c.old
+ sed -e "s,printf,g_print,g" \
+ argv-list-converters.c.old > argv-list-converters.c
+ rm argv-list-converters.c.old
+}
+
+src_compile() {
+ local myconf=""
+
+ use nls || myconf="--disable-nls"
+ use postgres && myconf="$myconf --enable-sql"
+
+ econf --enable-profile \
+ --enable-rpc \
+ $myconf || die "Configuration failed"
+
+ make || die # Doesn't work with make -j 4 (hallski)
+}
+
+src_install () {
+ einstall || die "Installation failed"
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING NEWS README* TODO
+}