summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-29 22:51:02 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-29 22:51:02 +0000
commitf38f380ffd2e63c11bd228c252b9af1d8ce513ea (patch)
treec0fd4349bed03220ff9adf5a4ac07730ecae7c0e /app-office
parentRespecting CC variable, closes bug #243944 (diff)
downloadgentoo-2-f38f380ffd2e63c11bd228c252b9af1d8ce513ea.tar.gz
gentoo-2-f38f380ffd2e63c11bd228c252b9af1d8ce513ea.tar.bz2
gentoo-2-f38f380ffd2e63c11bd228c252b9af1d8ce513ea.zip
Fix building w/ glibc-2.10 for bug #273877. Patch pulled from upstream.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword-plugins/ChangeLog7
-rw-r--r--app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild6
-rw-r--r--app-office/abiword-plugins/files/abiword-plugins-2.6.8-glibc-2.10.patch12
3 files changed, 23 insertions, 2 deletions
diff --git a/app-office/abiword-plugins/ChangeLog b/app-office/abiword-plugins/ChangeLog
index 7ce7fa2ab101..369a8937dff4 100644
--- a/app-office/abiword-plugins/ChangeLog
+++ b/app-office/abiword-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword-plugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/ChangeLog,v 1.63 2009/03/30 15:01:03 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/ChangeLog,v 1.64 2009/07/29 22:51:02 dirtyepic Exp $
+
+ 29 Jul 2009; Ryan Hill <dirtyepic@gentoo.org>
+ abiword-plugins-2.6.8.ebuild,
+ +files/abiword-plugins-2.6.8-glibc-2.10.patch:
+ Fix building w/ glibc-2.10 for bug #273877. Patch pulled from upstream.
30 Mar 2009; Peter Alfredsen <loki_val@gentoo.org>
abiword-plugins-2.4.6.ebuild, abiword-plugins-2.6.4.ebuild,
diff --git a/app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild b/app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild
index b70dc5cfed62..65e03b1a9c59 100644
--- a/app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild
+++ b/app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild,v 1.2 2009/03/30 15:01:03 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild,v 1.3 2009/07/29 22:51:02 dirtyepic Exp $
EAPI=2
@@ -56,6 +56,10 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
src_configure(){
local myconf="--enable-all \
--with-abiword="${WORKDIR}/abiword-${PV}" \
diff --git a/app-office/abiword-plugins/files/abiword-plugins-2.6.8-glibc-2.10.patch b/app-office/abiword-plugins/files/abiword-plugins-2.6.8-glibc-2.10.patch
new file mode 100644
index 000000000000..6e2c5e1455ca
--- /dev/null
+++ b/app-office/abiword-plugins/files/abiword-plugins-2.6.8-glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -Naurp abiword-plugins-2.6.8-orig/tools/abicommand/xp/AbiCommand.cpp abiword-plugins-2.6.8/tools/abicommand/xp/AbiCommand.cpp
+--- abiword-plugins-2.6.8-orig/tools/abicommand/xp/AbiCommand.cpp 2007-10-11 14:05:55.000000000 -0600
++++ abiword-plugins-2.6.8/tools/abicommand/xp/AbiCommand.cpp 2009-07-29 16:37:31.022705617 -0600
+@@ -551,7 +551,7 @@ AbiCommand::parseTokens (UT_Vector * pTo
+ UT_UTF8String *pCom1 =
+ const_cast < UT_UTF8String * >(static_cast < const UT_UTF8String * >(pToks->getNthItem (1)));
+ printf(" Filename %s \n",pCom1->utf8_str());
+- char *suffix = rindex (pCom1->utf8_str (), '.');
++ const char *suffix = const_cast<const char*>(rindex (pCom1->utf8_str (), '.'));
+
+ if (suffix != NULL)
+ {