summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2010-02-28 16:37:59 +0000
committerCédric Krier <cedk@gentoo.org>2010-02-28 16:37:59 +0000
commitc0289f4d1e0199815abc974a4fc80a839975b870 (patch)
treecbf44e5ff018dff87648c95c5a92efa48e968da4 /app-office
parentVersion bump (diff)
downloadgentoo-2-c0289f4d1e0199815abc974a4fc80a839975b870.tar.gz
gentoo-2-c0289f4d1e0199815abc974a4fc80a839975b870.tar.bz2
gentoo-2-c0289f4d1e0199815abc974a4fc80a839975b870.zip
Version bump
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calcurse/ChangeLog9
-rw-r--r--app-office/calcurse/calcurse-2.7.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/app-office/calcurse/ChangeLog b/app-office/calcurse/ChangeLog
index 5557363a3bd3..523711bd445b 100644
--- a/app-office/calcurse/ChangeLog
+++ b/app-office/calcurse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/calcurse
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/calcurse/ChangeLog,v 1.12 2009/01/25 16:52:31 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calcurse/ChangeLog,v 1.13 2010/02/28 16:37:59 cedk Exp $
+
+*calcurse-2.7 (28 Feb 2010)
+
+ 28 Feb 2010; Cédric Krier <cedk@gentoo.org> +calcurse-2.7.ebuild:
+ Version bump
25 Jan 2009; Markus Meier <maekke@gentoo.org> calcurse-2.3.ebuild:
amd64/x86 stable, bug #256301
diff --git a/app-office/calcurse/calcurse-2.7.ebuild b/app-office/calcurse/calcurse-2.7.ebuild
new file mode 100644
index 000000000000..154f775de061
--- /dev/null
+++ b/app-office/calcurse/calcurse-2.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calcurse/calcurse-2.7.ebuild,v 1.1 2010/02/28 16:37:59 cedk Exp $
+
+inherit eutils
+
+DESCRIPTION="a text-based personal organizer"
+HOMEPAGE="http://culot.org/calcurse/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_en linguas_fr linguas_de linguas_es linguas_nl"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm po/LINGUAS
+}
+
+src_compile() {
+ local ALL_LINGUAS=""
+
+ use linguas_en && ALL_LINGUAS="${ALL_LINGUAS} en"
+ use linguas_fr && ALL_LINGUAS="${ALL_LINGUAS} fr"
+ use linguas_de && ALL_LINGUAS="${ALL_LINGUAS} de"
+ use linguas_es && ALL_LINGUAS="${ALL_LINGUAS} es"
+ use linguas_nl && ALL_LINGUAS="${ALL_LINGUAS} nl"
+
+ ALL_LINGUAS="${ALL_LINGUAS}" econf || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ dohtml doc/*.{html,css}
+}