summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-09-27 19:43:26 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-09-27 19:43:26 +0000
commitae4458ea56186a161cefa33a34f26b9231d969a6 (patch)
tree0d9d24ca01a954b9de4899a87d12619ec0436d0e /app-office
parentadd glade 2.12 to the gnome 2.12 mask (diff)
downloadgentoo-2-ae4458ea56186a161cefa33a34f26b9231d969a6.tar.gz
gentoo-2-ae4458ea56186a161cefa33a34f26b9231d969a6.tar.bz2
gentoo-2-ae4458ea56186a161cefa33a34f26b9231d969a6.zip
First release Candidate for OpenOffice.org 2.0
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-bin/ChangeLog11
-rwxr-xr-xapp-office/openoffice-bin/files/2.0.0/ooo-wrapper2130
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0_rc150
-rw-r--r--app-office/openoffice-bin/openoffice-bin-2.0.0_rc1.ebuild175
4 files changed, 365 insertions, 1 deletions
diff --git a/app-office/openoffice-bin/ChangeLog b/app-office/openoffice-bin/ChangeLog
index 3734b82d493c..234ec3aa41d0 100644
--- a/app-office/openoffice-bin/ChangeLog
+++ b/app-office/openoffice-bin/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-office/openoffice-bin
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.95 2005/09/24 07:24:37 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.96 2005/09/27 19:43:26 suka Exp $
+
+*openoffice-bin-2.0.0_rc1 (27 Sep 2005)
+
+ 27 Sep 2005; Andreas Proschofsky <suka@gentoo.org>
+ +files/2.0.0/ooo-wrapper2, +openoffice-bin-2.0.0_rc1.ebuild:
+ First Release Candidate for OpenOffice.org 2.0! Don't let yourself be fooled
+ by the About box this is NOT (yet) the final release. This release also adds
+ back all the missing language packs of the last release and even a few more,
+ so now the ebuild supports 50 different LINGUAS settings.
24 Sep 2005; Andreas Proschofsky <suka@gentoo.org>
openoffice-bin-1.1.5.ebuild, openoffice-bin-1.9.130.ebuild:
diff --git a/app-office/openoffice-bin/files/2.0.0/ooo-wrapper2 b/app-office/openoffice-bin/files/2.0.0/ooo-wrapper2
new file mode 100755
index 000000000000..8222add9ae93
--- /dev/null
+++ b/app-office/openoffice-bin/files/2.0.0/ooo-wrapper2
@@ -0,0 +1,130 @@
+#!/usr/bin/perl -w
+#*****************************************************************************
+#
+# ooffice - Wrapper script for OpenOffice.org
+#
+# Based on the Mandrake work.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2, as
+# published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+#*****************************************************************************
+
+use strict;
+use IO::Handle;
+use Fcntl ':flock';
+
+my $Debug = $ENV{OOO_DEBUG};
+my $DebugRH = $ENV{OOO_RH_DEBUG};
+
+# Define the vendor of this particular OOo pacakge
+my $VendorName = 'Gentoo';
+# Define system installation directory
+# Autoconf totally sucks for @libdir@ type substitution
+my $SystemInstallDir = '/usr/lib/openoffice';
+# Suffix for parallel installable versioning
+my $BinSuffix = '2';
+# ooo-build version
+my $OOO_BUILDVERSION = 'PV';
+# Debugging
+
+if ( $DebugRH ) {
+ $Debug = 1;
+ $VendorName = "RedHat";
+}
+if ($Debug && $BinSuffix =~ /^\@/) {
+ $SystemInstallDir = "/usr/lib/ooo-1.9";
+ $BinSuffix = '1.9';
+}
+
+#=============================================================================
+# Main
+#=============================================================================
+
+# Parse command line arguments
+my @ooo_argv;
+my $session_quickstart;
+my $widgets_set;
+while ($ARGV[0]) {
+ $_ = shift;
+ if (m/^--session-quickstart/) {
+ $session_quickstart = 1;
+ } elsif (m/^--widgets-set/) {
+ $widgets_set = shift;
+ (defined $widgets_set) || die "Error: The option --widgets-set requires a value\n" .
+ "For example: --widgets-set gtk\n";
+ } elsif (m/^--version/) {
+ print "This is OpenOffice.org built with ooo-build-$OOO_BUILDVERSION\n";
+ exit 0;
+ } else {
+ push @ooo_argv, $_;
+ }
+}
+
+if (!@ooo_argv) {
+ my $arg;
+ if ($0 =~ m/\/oo(calc|draw|impress|math|web|writer|base)$BinSuffix$/) {
+ $arg = "-$1";
+ } elsif ($0 =~ m/\/oofromtemplate$BinSuffix$/) {
+ $arg = "slot:5500";
+ }
+
+ if ($arg) {
+ push @ooo_argv, "$arg";
+ $Debug && print "Append arg: $arg\n";
+ }
+} else {
+ $Debug && print "Ignoring type - since have filenames\n";
+}
+
+if (defined $widgets_set) {
+ $ENV{SAL_USE_VCLPLUGIN} = $widgets_set;
+}
+
+# overcome ghastly up-stream evilness
+$ENV{SAL_NOEXPANDFPICKER}='TRUE';
+
+if ($session_quickstart) {
+ $Debug && print "Execute quickstarter\n";
+ push @ooo_argv, '-quickstart';
+}
+
+# FIXME: the following two fixes should be done by OOo itself
+# create the user config directory with safe rights 700 if it we find
+# the right path and the directory does not exist
+if (open BOOTSTRAPRC, "/usr/lib/openoffice/program/bootstraprc") {
+ while (my $line = <BOOTSTRAPRC>) {
+ chomp $line;
+ if (($line =~ m/^\s*UserInstallation\s*=\s*([^\s]*)\s*$/) && ($1)) {
+ my $userConfDir=$1;
+ $userConfDir =~ s|\$SYSUSERCONFIG|$ENV{HOME}|;
+ $userConfDir =~ s|file://||;
+ mkdir ($userConfDir,0700) unless (-d $userConfDir);
+ last;
+ }
+ }
+ close BOOTSTRAPRC;
+}
+# touch ~/.recently-used with safe rights 700 if it does not exist
+if (! -f "$ENV{HOME}/.recently-used") {
+ open (RECENTLY_USED, ">$ENV{HOME}/.recently-used") &&
+ close RECENTLY_USED &&
+ chmod 0600, "$ENV{HOME}/.recently-used";
+}
+
+if (!(-f '/proc/version')) {
+ print STDERR "\n\n --- Warning - OO.o will not work without a mounted /proc filesystem --- \n\n\n";
+}
+
+# And here we go.
+exec "$SystemInstallDir/program/soffice", @ooo_argv
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0_rc1 b/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0_rc1
new file mode 100644
index 000000000000..eb108c6f8957
--- /dev/null
+++ b/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0_rc1
@@ -0,0 +1,50 @@
+MD5 38f4348297235cc2d7425d5ea6011db3 OOo_2.0.0rc1_050923_LinuxIntel_install.tar.gz 106462692
+MD5 e6f37c57e284e8475db9b02c98852b59 openoffice.org-af-2.0.0-1.i586.tar.gz 13328420
+MD5 6c3e880197c7793faf4e8ed4dc2b3c3e OOo_2.0.0rc1_050923_LinuxIntel_langpack_be-BY.tar.gz 13371433
+MD5 6ecd6054de577d32436837fc6d542b2c OOo_2.0.0rc1_050923_LinuxIntel_langpack_bg.tar.gz 13899142
+MD5 cd03e742252bc59d1d600510b0c9e4e0 openoffice.org-bn-2.0.0-1.i586.tar.gz 13242027
+MD5 eba9cbf34653f1624a1a30c63ad4eda1 openoffice.org-br-2.0.0-1.i586.tar.gz 14301022
+MD5 4e54babd2a958a993a900cc7ec08fb93 OOo_2.0.0rc1_050923_LinuxIntel_langpack_ca.tar.gz 13326360
+MD5 64d1c2a7b793de414004b5edf1881203 OOo_2.0.0rc1_050923_LinuxIntel_langpack_cs.tar.gz 13974698
+MD5 0a5dd5a82da6b1c3107979e4fef6f553 OOo_2.0.0rc1_050923_LinuxIntel_langpack_cy.tar.gz 13249147
+MD5 00b0c1cbf68b7070b0c2b8845dc3de92 OOo_2.0.0rc1_050923_LinuxIntel_langpack_da.tar.gz 13852353
+MD5 b0818aa40b4c06a7514d51347d4a0ab5 OOo_2.0.0rc1_050923_LinuxIntel_langpack_de.tar.gz 14806485
+MD5 94c0b4067daec5996241ac22b6e67cfa OOo_2.0.0rc1_050923_LinuxIntel_langpack_el.tar.gz 13375924
+MD5 973c9bb8140b08c332b346a5d7b22af3 openoffice.org-en-GB-2.0.0-1.i586.tar.gz 13382609
+MD5 ac60895eab133503c64f5b32497cfaae OOo_2.0.0rc1_050923_LinuxIntel_langpack_es.tar.gz 14121988
+MD5 ddf0d446e42e03ccf4a6084da4b76a36 OOo_2.0.0rc1_050923_LinuxIntel_langpack_et.tar.gz 14047064
+MD5 e326c4440eb024357e3f8347337aeba2 OOo_2.0.0rc1_050923_LinuxIntel_langpack_fi.tar.gz 13353046
+MD5 60b949bbadec2730923940af9e599ffb OOo_2.0.0rc1_050923_LinuxIntel_langpack_fr.tar.gz 14324365
+MD5 368325b6a0da0f22bccb6565f87f3cf1 openoffice.org-ga-2.0.0-1.i586.tar.gz 13530732
+MD5 47461ca1064333d23105e2d16b9eb3ef OOo_2.0.0rc1_050923_LinuxIntel_langpack_gu-IN.tar.gz 13385309
+MD5 f60bd617d56ef7df7376e76418426071 OOo_2.0.0rc1_050923_LinuxIntel_langpack_hr.tar.gz 13620209
+MD5 aad87a7c16eb6391a83236901e0dda14 OOo_2.0.0rc1_050923_LinuxIntel_langpack_hu.tar.gz 13429807
+MD5 a9dfe066c20188e6af3407834bac9dfb OOo_2.0.0rc1_050923_LinuxIntel_langpack_it.tar.gz 14096662
+MD5 36caebadf9189e573892f37ffa61ed2f OOo_2.0.0rc1_050923_LinuxIntel_langpack_ja.tar.gz 14868104
+MD5 0215c25b119cf372751fec562358c089 OOo_2.0.0rc1_050923_LinuxIntel_langpack_km.tar.gz 16711713
+MD5 bd0b7eca6ae543a98079969ce5f4ac5f OOo_2.0.0rc1_050923_LinuxIntel_langpack_ko.tar.gz 14008179
+MD5 b04a6cebc8e2d3f04b04dadebc278029 openoffice.org-lt-2.0.0-1.i586.tar.gz 13287300
+MD5 c7e578ad4b4aa8c57216191059edc275 openoffice.org-lv-2.0.0-1.i586.tar.gz 13270491
+MD5 d4063f87e898d1e4d2bbc3763ddcb92e openoffice.org-mk-2.0.0-1.i586.tar.gz 13973252
+MD5 0e8ddb9239534c69b7fc6156a7b7a165 openoffice.org-nb-2.0.0-1.i586.tar.gz 13293930
+MD5 cc6c912df11be63176063e2f01f67323 openoffice.org-ne-2.0.0-1.i586.tar.gz 13317544
+MD5 fe935a1f29710d9bf4f4ececca57201f OOo_2.0.0rc1_050923_LinuxIntel_langpack_nl.tar.gz 14406061
+MD5 e1cd6ab761f11f7688fb5df193b22f0d OOo_2.0.0rc1_050923_LinuxIntel_langpack_nn.tar.gz 13308096
+MD5 55355175f3af340d97302f4debc2c113 openoffice.org-ns-2.0.0-1.i586.tar.gz 13237332
+MD5 a2fd6f64efab65489447de19386b4091 OOo_2.0.0rc1_050923_LinuxIntel_langpack_pa-IN.tar.gz 13365518
+MD5 c4732b4cbec6b15b8200522ccd9e4549 OOo_2.0.0rc1_050923_LinuxIntel_langpack_pl.tar.gz 13631266
+MD5 cb0a2dd29bd62de7bee9290b5245d3c4 OOo_2.0.0rc1_050923_LinuxIntel_langpack_pt-BR.tar.gz 14097342
+MD5 c9c1b86c39a05b8a6d5a02072cb0eda4 OOo_2.0.0rc1_050923_LinuxIntel_langpack_rw.tar.gz 13637070
+MD5 3df83588edf624358090aafc9c6132b6 OOo_2.0.0rc1_050923_LinuxIntel_langpack_sh-YU.tar.gz 13323973
+MD5 37e65affa5d9f0c98712b048a7e47ec6 OOo_2.0.0rc1_050923_LinuxIntel_langpack_sk.tar.gz 13871200
+MD5 23ff0960425a0da58f2bc238ad026fd2 openoffice.org-sl-2.0.0-1.i586.tar.gz 13249901
+MD5 7489e2ba4957e8792c8fb682a6c2501b OOo_2.0.0rc1_050923_LinuxIntel_langpack_sr-CS.tar.gz 13404311
+MD5 33254d107f842dc7cf6cf85ae3694870 OOo_2.0.0rc1_050923_LinuxIntel_langpack_sv.tar.gz 13905099
+MD5 fbd31c5e56202974c3106db9680de043 OOo_2.0.0rc1_050923_LinuxIntel_langpack_sw-TZ.tar.gz 13468609
+MD5 76fc32da7092fb95660f3cb37160f614 openoffice.org-tn-2.0.0-1.i586.tar.gz 13334979
+MD5 e79a9e7567bcf670113e316a038096bb OOo_2.0.0rc1_050923_LinuxIntel_langpack_tr.tar.gz 13489604
+MD5 d9e081b22918eb7fb1a2878d52058bc4 OOo_2.0.0rc1_050923_LinuxIntel_langpack_vi.tar.gz 13323686
+MD5 1ead8d57dd7b57b633a6f2b09fd06bb5 openoffice.org-xh-2.0.0-1.i586.tar.gz 13372865
+MD5 f224bead1a4f4cca69eeea586e6ae984 OOo_2.0.0rc1_050923_LinuxIntel_langpack_zh-CN.tar.gz 14184088
+MD5 0466fe6584e430a2f459a8e507b25c25 OOo_2.0.0rc1_050923_LinuxIntel_langpack_zh-TW.tar.gz 14353708
+MD5 be18b45d7b3dac54941595d3e25de6a3 openoffice.org-zu-2.0.0-1.i586.tar.gz 13294891
diff --git a/app-office/openoffice-bin/openoffice-bin-2.0.0_rc1.ebuild b/app-office/openoffice-bin/openoffice-bin-2.0.0_rc1.ebuild
new file mode 100644
index 000000000000..3e07fe44d002
--- /dev/null
+++ b/app-office/openoffice-bin/openoffice-bin-2.0.0_rc1.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-2.0.0_rc1.ebuild,v 1.1 2005/09/27 19:43:26 suka Exp $
+
+inherit eutils fdo-mime rpm
+
+IUSE="gnome java kde"
+
+INSTDIR="/usr/lib/openoffice"
+MY_PV="${PV/_}"
+MY_PV2="${MY_PV}_050923"
+MY_PV3="${PV/_rc1}"
+S="${WORKDIR}/OOO680_m1_native_packed-5_en-US.8958/RPMS"
+DESCRIPTION="OpenOffice productivity suite"
+
+LANGPACK="OOo_${MY_PV2}_LinuxIntel_langpack"
+LANGPACKPATH="http://oootranslation.services.openoffice.org/pub/OpenOffice.org/${MY_PV}/${LANGPACK}"
+LANGLOC="http://ftp.linux.cz/pub/localization/OpenOffice.org/devel/680/OOO680_m1/Build-1/OOo_OOO680_m1_native_LinuxIntel_langpacks_rpm"
+LANGSUFFIX="${MY_PV3}-1.i586.tar.gz"
+
+SRC_URI="mirror://openoffice/contrib/rc/${MY_PV}/OOo_${MY_PV2}_LinuxIntel_install.tar.gz
+ linguas_af? ( ${LANGLOC}/openoffice.org-af-${LANGSUFFIX} )
+ linguas_be_BY? ( ${LANGPACKPATH}_be-BY.tar.gz )
+ linguas_bg? ( ${LANGPACKPATH}_bg.tar.gz )
+ linguas_bn? ( ${LANGLOC}/openoffice.org-bn-${LANGSUFFIX} )
+ linguas_br? ( ${LANGLOC}/openoffice.org-br-${LANGSUFFIX} )
+ linguas_ca? ( ${LANGPACKPATH}_ca.tar.gz )
+ linguas_cs? ( ${LANGPACKPATH}_cs.tar.gz )
+ linguas_cy? ( ${LANGPACKPATH}_cy.tar.gz )
+ linguas_da? ( ${LANGPACKPATH}_da.tar.gz )
+ linguas_de? ( ${LANGPACKPATH}_de.tar.gz )
+ linguas_el? ( ${LANGPACKPATH}_el.tar.gz )
+ linguas_en_GB? ( ${LANGLOC}/openoffice.org-en-GB-${LANGSUFFIX} )
+ linguas_es? ( ${LANGPACKPATH}_es.tar.gz )
+ linguas_et? ( ${LANGPACKPATH}_et.tar.gz )
+ linguas_fi? ( ${LANGPACKPATH}_fi.tar.gz )
+ linguas_fr? ( ${LANGPACKPATH}_fr.tar.gz )
+ linguas_ga? ( ${LANGLOC}/openoffice.org-ga-${LANGSUFFIX} )
+ linguas_gu_IN? ( ${LANGPACKPATH}_gu-IN.tar.gz )
+ linguas_hr? ( ${LANGPACKPATH}_hr.tar.gz )
+ linguas_hu? ( ${LANGPACKPATH}_hu.tar.gz )
+ linguas_it? ( ${LANGPACKPATH}_it.tar.gz )
+ linguas_ja? ( ${LANGPACKPATH}_ja.tar.gz )
+ linguas_km? ( ${LANGPACKPATH}_km.tar.gz )
+ linguas_ko? ( ${LANGPACKPATH}_ko.tar.gz )
+ linguas_lt? ( ${LANGLOC}/openoffice.org-lt-${LANGSUFFIX} )
+ linguas_lv? ( ${LANGLOC}/openoffice.org-lv-${LANGSUFFIX} )
+ linguas_mk? ( ${LANGLOC}/openoffice.org-mk-${LANGSUFFIX} )
+ linguas_nb? ( ${LANGLOC}/openoffice.org-nb-${LANGSUFFIX} )
+ linguas_ne? ( ${LANGLOC}/openoffice.org-ne-${LANGSUFFIX} )
+ linguas_nl? ( ${LANGPACKPATH}_nl.tar.gz )
+ linguas_nn? ( ${LANGPACKPATH}_nn.tar.gz )
+ linguas_ns? ( ${LANGLOC}/openoffice.org-ns-${LANGSUFFIX} )
+ linguas_pa_IN? ( ${LANGPACKPATH}_pa-IN.tar.gz )
+ linguas_pl? ( ${LANGPACKPATH}_pl.tar.gz )
+ linguas_pt_BR? ( ${LANGPACKPATH}_pt-BR.tar.gz )
+ linguas_rw? ( ${LANGPACKPATH}_rw.tar.gz )
+ linguas_sh_YU? ( ${LANGPACKPATH}_sh-YU.tar.gz )
+ linguas_sk? ( ${LANGPACKPATH}_sk.tar.gz )
+ linguas_sl? ( ${LANGLOC}/openoffice.org-sl-${LANGSUFFIX} )
+ linguas_sr_CS? ( ${LANGPACKPATH}_sr-CS.tar.gz )
+ linguas_sv? ( ${LANGPACKPATH}_sv.tar.gz )
+ linguas_sw_TZ? ( ${LANGPACKPATH}_sw-TZ.tar.gz )
+ linguas_tn? ( ${LANGLOC}/openoffice.org-tn-${LANGSUFFIX} )
+ linguas_tr? ( ${LANGPACKPATH}_tr.tar.gz )
+ linguas_vi? ( ${LANGPACKPATH}_vi.tar.gz )
+ linguas_xh? ( ${LANGLOC}/openoffice.org-xh-${LANGSUFFIX} )
+ linguas_zh_CN? ( ${LANGPACKPATH}_zh-CN.tar.gz )
+ linguas_zh_TW? ( ${LANGPACKPATH}_zh-TW.tar.gz )
+ linguas_zu? ( ${LANGLOC}/openoffice.org-zu-${LANGSUFFIX} )"
+
+HOMEPAGE="http://www.openoffice.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="!app-office/openoffice
+ virtual/x11
+ virtual/libc
+ >=dev-lang/perl-5.0
+ app-arch/zip
+ app-arch/unzip
+ java? ( >=virtual/jre-1.4.1 )
+ amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )
+ linguas_ja? ( >=media-fonts/kochi-substitute-20030809-r3 )
+ linguas_zh_CN? ( >=media-fonts/arphicfonts-0.1-r2 )
+ linguas_zh_TW? ( >=media-fonts/arphicfonts-0.1-r2 )"
+
+DEPEND="${RDEPEND}
+ sys-apps/findutils"
+
+PROVIDE="virtual/ooo"
+
+src_unpack() {
+
+ unpack ${A}
+
+ for i in base calc core01 core02 core03 core03u core04 core04u core05 core05u core06 core07 core08 core09 core10 draw impress math writer graphicfilter pyuno spellcheck testtool xsltfilter ; do
+ rpm_unpack ${S}/openoffice.org-${i}-${MY_PV3}-1.i586.rpm
+ done
+
+ rpm_unpack ${S}/desktop-integration/openoffice.org-freedesktop-menus-${MY_PV3}-1.noarch.rpm
+ use kde && rpm_unpack ${S}/desktop-integration/openoffice.org-suse-menus-${MY_PV3}-1.noarch.rpm
+
+ use gnome && rpm_unpack ${S}/openoffice.org-gnome-integration-${MY_PV3}-1.i586.rpm
+ use java && rpm_unpack ${S}/openoffice.org-javafilter-${MY_PV3}-1.i586.rpm
+
+ strip-linguas en af be_BY bg bn br ca cs cy da de el en_GB es et fi fr ga gu_IN hr hu it ja km ko lt lv mk nb ne nl nn ns pa_IN pl pt_BR rw sh_YU sk sl sr_CS sv sw_TZ tn tr vi xh zh_CN zh_TW zu
+
+ for i in ${LINGUAS}; do
+ i="${i/_/-}"
+ if [ ${i} != "en" ] ; then
+ rpm_unpack openoffice.org-${i}-${MY_PV3}-1.i586.rpm
+ rpm_unpack openoffice.org-${i}-help-${MY_PV3}-1.i586.rpm
+ rpm_unpack openoffice.org-${i}-res-${MY_PV3}-1.i586.rpm
+ fi
+ done
+
+}
+
+src_install () {
+
+ einfo "Installing OpenOffice.org into build root..."
+ dodir ${INSTDIR}
+ dodir /usr/share/icons
+ dodir /usr/share/mime
+ mv ${WORKDIR}/opt/openoffice.org2.0/* ${D}${INSTDIR}
+ mv ${WORKDIR}/usr/share/icons/* ${D}/usr/share/icons
+
+ use kde && dodir /usr/share/mimelnk/application && mv ${WORKDIR}/opt/kde3/share/mimelnk/application/* ${D}/usr/share/mimelnk/application
+
+ #Menu entries
+ cd ${D}${INSTDIR}/share/xdg/
+
+ sed -i -e s/'Exec=openoffice.org-2.0-printeradmin'/'Exec=oopadmin2'/g printeradmin.desktop || die
+
+ for desk in base calc draw impress math writer printeradmin; do
+ mv ${desk}.desktop openoffice.org-2.0-${desk}.desktop
+ sed -i -e s/openoffice.org-2.0/ooffice2/g openoffice.org-2.0-${desk}.desktop || die
+ domenu openoffice.org-2.0-${desk}.desktop
+ done
+
+ # Install wrapper script
+ newbin ${FILESDIR}/${MY_PV3}/ooo-wrapper2 ooffice2
+ sed -i -e s/PV/${PV}/g ${D}/usr/bin/ooffice2 || die
+
+ # Component symlinks
+ for app in base calc draw fromtemplate impress math web writer; do
+ dosym ooffice2 /usr/bin/oo${app}2
+ done
+
+ dosym ${INSTDIR}/program/spadmin.bin /usr/bin/oopadmin2
+
+ # Fixing some icon dir permissions
+ chmod +r -R ${D}/usr/share/icons/ || die
+
+ # Non-java weirdness see bug #99366
+ use java || rm -f ${D}${INSTDIR}/program/javaldx
+}
+
+pkg_postinst() {
+
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ einfo " To start OpenOffice.org, run:"
+ einfo
+ einfo " $ ooffice2"
+ einfo
+ einfo " Also, for individual components, you can use any of:"
+ einfo
+ einfo " oobase2, oocalc2, oodraw2, oofromtemplate2, ooimpress2, oomath2,"
+ einfo " ooweb2 or oowriter2"
+}