summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-24 07:16:12 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-24 07:16:12 +0000
commit957c7b282ec1c571bc535628011beedace8dcf79 (patch)
tree6204f527ad8469d448b6ef3e675f322b31f69034 /app-office
parentMasked Galeon 1.2.2 until a stable ebuild is verified (diff)
downloadgentoo-2-957c7b282ec1c571bc535628011beedace8dcf79.tar.gz
gentoo-2-957c7b282ec1c571bc535628011beedace8dcf79.tar.bz2
gentoo-2-957c7b282ec1c571bc535628011beedace8dcf79.zip
- The initial version. Closes #1665.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/logjam/ChangeLog9
-rw-r--r--app-office/logjam/files/digest-logjam-3.0.41
-rw-r--r--app-office/logjam/logjam-3.0.4.ebuild35
3 files changed, 45 insertions, 0 deletions
diff --git a/app-office/logjam/ChangeLog b/app-office/logjam/ChangeLog
new file mode 100644
index 000000000000..75957f7186f4
--- /dev/null
+++ b/app-office/logjam/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-office/logjam
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-office/logjam/ChangeLog,v 1.1 2002/05/24 07:16:12 agenkin Exp $
+
+*logjam-3.0.4 (24 May 2002)
+
+ 24 May 2002; Arcady Genkin <agenkin@thpoon.com> logjam-3.0.4.ebuild :
+
+ Initial version of the package, created by lsd@linuxgamers.net (Leigh Dyer). \ No newline at end of file
diff --git a/app-office/logjam/files/digest-logjam-3.0.4 b/app-office/logjam/files/digest-logjam-3.0.4
new file mode 100644
index 000000000000..000623c83017
--- /dev/null
+++ b/app-office/logjam/files/digest-logjam-3.0.4
@@ -0,0 +1 @@
+MD5 0259029e23ca6a280c6cb6ff83603ac9 logjam-3.0.4.tar.gz 142048
diff --git a/app-office/logjam/logjam-3.0.4.ebuild b/app-office/logjam/logjam-3.0.4.ebuild
new file mode 100644
index 000000000000..ed9ecf7b4e26
--- /dev/null
+++ b/app-office/logjam/logjam-3.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-office/logjam/logjam-3.0.4.ebuild,v 1.1 2002/05/24 07:16:12 agenkin Exp $
+
+DESCRIPTION="GTK-based LiveJournal client"
+HOMEPAGE="http://logjam.danga.com/"
+
+DEPEND=">=x11-libs/gtk+-1.2.10
+ net-ftp/curl
+ gnome? ( >=gnome-base/gnome-core-1.4.0 )
+ media-sound/xmms"
+
+SRC_URI=http://logjam.danga.com/download/${P}.tar.gz
+S=${WORKDIR}/${P}
+
+src_compile () {
+ local myopts
+
+ use gnome && myopts="${myopts} --with-gnome=yes"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-xmms \
+ ${myopts} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc README TODO ChangeLog COPYING AUTHORS
+}