summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-03 10:43:24 +0000
committerJustin Lecher <jlec@gentoo.org>2014-11-03 10:43:24 +0000
commit9076b582ed1a321cc230a7d32977da285d850130 (patch)
treedea1b364e236bfac015ab533a2ff258c3720e113 /app-office
parentUnrestrict tests. (diff)
downloadgentoo-2-9076b582ed1a321cc230a7d32977da285d850130.tar.gz
gentoo-2-9076b582ed1a321cc230a7d32977da285d850130.tar.bz2
gentoo-2-9076b582ed1a321cc230a7d32977da285d850130.zip
app-office/texstudio: Version Bump, #528030
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texstudio/ChangeLog7
-rw-r--r--app-office/texstudio/texstudio-2.8.6.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/app-office/texstudio/ChangeLog b/app-office/texstudio/ChangeLog
index e8b993f4463a..428cf49e8ce8 100644
--- a/app-office/texstudio/ChangeLog
+++ b/app-office/texstudio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/texstudio
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/ChangeLog,v 1.28 2014/09/16 11:51:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/ChangeLog,v 1.29 2014/11/03 10:43:24 jlec Exp $
+
+*texstudio-2.8.6 (03 Nov 2014)
+
+ 03 Nov 2014; Justin Lecher <jlec@gentoo.org> +texstudio-2.8.6.ebuild:
+ Version Bump, #528030
*texstudio-2.8.4 (16 Sep 2014)
diff --git a/app-office/texstudio/texstudio-2.8.6.ebuild b/app-office/texstudio/texstudio-2.8.6.ebuild
new file mode 100644
index 000000000000..873360e5b7f6
--- /dev/null
+++ b/app-office/texstudio/texstudio-2.8.6.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/texstudio-2.8.6.ebuild,v 1.1 2014/11/03 10:43:24 jlec Exp $
+
+EAPI=5
+
+inherit base fdo-mime prefix qt4-r2
+
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="http://texstudio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/TeXstudio%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="video"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4]
+ dev-libs/quazip
+ x11-libs/libX11
+ x11-libs/libXext
+ dev-qt/designer:4
+ >=dev-qt/qtgui-4.8.5:4
+ >=dev-qt/qtcore-4.6.1:4
+ >=dev-qt/qtscript-4.6.1:4
+ dev-qt/qtsingleapplication
+ >=dev-qt/qtsvg-4.6.1:4
+ >=dev-qt/qttest-4.6.1:4
+ video? ( media-libs/phonon )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/-/}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.4-hunspell-quazip.patch
+ "${FILESDIR}"/${PN}-2.8.2-desktop.patch
+# Get it from fedora
+ "${FILESDIR}"/${PN}-2.5-viewers-use-xdg-open.patch
+ )
+
+src_prepare() {
+ find hunspell quazip utilities/poppler-data qtsingleapplication -delete || die
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed \
+ -e '/hunspell.pri/d' \
+ -e '/quazip.pri/d' \
+ -e '/qtsingleapplication.pri/d' \
+ -e '/QUAZIP_STATIC/d' \
+ -i ${PN}.pro || die
+
+# cat >> ${PN}.pro <<- EOF
+# exists(texmakerx_my.pri):include(texmakerx_my.pri)
+# EOF
+
+ cp "${FILESDIR}"/texmakerx_my.pri ${PN}.pri || die
+ eprefixify ${PN}.pri
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ insinto /usr/share/icons/hicolor/${i}
+ newins utilities/${PN}${i}.png ${PN}.png
+ done
+ qt4-r2_src_install
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}