summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-28 02:15:14 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-28 02:15:14 +0000
commit67d3a420f65e4613d9c397b6f921b9cbbab61461 (patch)
treefb58ea518c121ce8c46a9060f49741ab19a1fb8b /app-office
parentfix for when portageq not in path (diff)
downloadgentoo-2-67d3a420f65e4613d9c397b6f921b9cbbab61461.tar.gz
gentoo-2-67d3a420f65e4613d9c397b6f921b9cbbab61461.tar.bz2
gentoo-2-67d3a420f65e4613d9c397b6f921b9cbbab61461.zip
rev bump that gives ofx/hbci and new guile support
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/ChangeLog8
-rw-r--r--app-office/gnucash/Manifest9
-rw-r--r--app-office/gnucash/files/digest-gnucash-1.8.2-r11
-rw-r--r--app-office/gnucash/gnucash-1.8.2-r1.ebuild72
4 files changed, 89 insertions, 1 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index 47160b87cc89..0ee71a0b73a4 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnucash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.17 2003/03/21 17:26:25 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.18 2003/04/28 02:15:05 liquidx Exp $
+
+*gnucash-1.8.2-r1 (28 Apr 2003)
+
+ 28 Apr 2003; Alastair Tse <liquidx@gentoo.org> gnucash-1.8.2-r1.ebuild:
+ new gnucash that has ofx and hbci support.
+ also depends on new guile-1.6.x
*gnucash-1.8.2 (21 Mar 2003)
diff --git a/app-office/gnucash/Manifest b/app-office/gnucash/Manifest
new file mode 100644
index 000000000000..c1d827bc5424
--- /dev/null
+++ b/app-office/gnucash/Manifest
@@ -0,0 +1,9 @@
+MD5 e3d18ed3efea4f733fc69662fcb83405 ChangeLog 3392
+MD5 b8e0eec1a6bcd963f2ce26db9abf9b9f gnucash-1.8.1.ebuild 1455
+MD5 54902cd500c04f0659cd9a7d3438f1cd gnucash-1.8.2.ebuild 1546
+MD5 4800e560c499c667d2c95a7e3b01c42b gnucash-1.6.8.ebuild 1882
+MD5 832a41ac0535a02b3b049140d5919e93 gnucash-1.8.2-r1.ebuild 1776
+MD5 e298b9154a60df27ab519e6b88dd4c47 files/digest-gnucash-1.8.1 66
+MD5 cdaa1f2adfbd3112916a8c2076fa04bd files/digest-gnucash-1.8.2 66
+MD5 cdaa1f2adfbd3112916a8c2076fa04bd files/digest-gnucash-1.8.2-r1 66
+MD5 8ccd6e0765bb53caad58e8f736b020e9 files/digest-gnucash-1.6.8 67
diff --git a/app-office/gnucash/files/digest-gnucash-1.8.2-r1 b/app-office/gnucash/files/digest-gnucash-1.8.2-r1
new file mode 100644
index 000000000000..a40fbd473544
--- /dev/null
+++ b/app-office/gnucash/files/digest-gnucash-1.8.2-r1
@@ -0,0 +1 @@
+MD5 3995f9df6766d2573b1cf96b6b12bea0 gnucash-1.8.2.tar.gz 6555050
diff --git a/app-office/gnucash/gnucash-1.8.2-r1.ebuild b/app-office/gnucash/gnucash-1.8.2-r1.ebuild
new file mode 100644
index 000000000000..6bf8f3260238
--- /dev/null
+++ b/app-office/gnucash/gnucash-1.8.2-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.2-r1.ebuild,v 1.1 2003/04/28 02:15:05 liquidx Exp $
+
+inherit flag-o-matic libtool
+
+# won't configure with this
+filter-flags -fomit-frame-pointer
+
+DESCRIPTION="A personal finance manager"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnucash.org/"
+
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls postgres ofx hbci debug"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-util/guile-1.6
+ >=dev-libs/slib-2.3.8
+ >=media-libs/libpng-1.0.9
+ >=media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/xpm-3.4
+ >=gnome-base/gnome-print-0.21
+ media-libs/gdk-pixbuf
+ >=gnome-extra/gtkhtml-0.14.0
+ >=gnome-extra/gal-0.13-r1
+ >=dev-libs/libxml-1.8.3
+ >=dev-libs/g-wrap-1.3.3
+ >=gnome-extra/guppi-0.35.5-r2
+
+ =sys-libs/db-1*
+ hbci? ( >=net-libs/openhbci-0.9.6 )
+ ofx? ( >=dev-libs/libofx-0.6.4 )
+ postgres? ( dev-db/postgresql )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-libs/slib-2.3.8
+ >=dev-lang/swig-1.3_alpha4
+ <gnome-base/libglade-2
+ gnome-base/libghttp
+ nls? ( sys-devel/gettext )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_compile() {
+ elibtoolize
+ local myconf=""
+
+ # allow warnings to go unheeded
+ myconf="--enable-compile-warnings=no --disable-error-on-warning"
+
+ use postgres && myconf="${myconf} --enable-sql"
+ # note: --disable-ofx doesn't work
+ use ofx && myconf="${myconf} --enable-ofx"
+
+ econf \
+ `use_enable hbci` \
+ `use_enable nls` \
+ `use_enable debug` \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ einstall pkgdatadir=${D}/usr/share/gnucash || die "install failed"
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING NEWS README* TODO
+}