summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-05-17 14:52:28 +0000
committerHanno Böck <hanno@gentoo.org>2008-05-17 14:52:28 +0000
commit4765dd5c2f11f2fbc85e52f973a3aa71f4f40110 (patch)
tree50bb3c4a99206b590f248b41b4e533fefe91f96c /app-office
parentVersion bump. (diff)
downloadgentoo-2-4765dd5c2f11f2fbc85e52f973a3aa71f4f40110.tar.gz
gentoo-2-4765dd5c2f11f2fbc85e52f973a3aa71f4f40110.tar.bz2
gentoo-2-4765dd5c2f11f2fbc85e52f973a3aa71f4f40110.zip
kspread bump with gcc43 patch and desktop-validity fix
(Portage version: 2.1.5)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kspread/ChangeLog10
-rw-r--r--app-office/kspread/files/kspread-1.6.3-validate-desktop.diff11
-rw-r--r--app-office/kspread/files/kspread-gcc43.patch46
-rw-r--r--app-office/kspread/kspread-1.6.3.ebuild67
4 files changed, 132 insertions, 2 deletions
diff --git a/app-office/kspread/ChangeLog b/app-office/kspread/ChangeLog
index 310ea73cc16a..c5c69ab7d818 100644
--- a/app-office/kspread/ChangeLog
+++ b/app-office/kspread/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kspread
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/ChangeLog,v 1.83 2007/07/26 17:36:03 corsair Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/ChangeLog,v 1.84 2008/05/17 14:52:28 hanno Exp $
+
+*kspread-1.6.3 (17 May 2008)
+
+ 17 May 2008; Hanno Boeck <hanno@gentoo.org> +files/kspread-gcc43.patch,
+ +files/kspread-1.6.3-validate-desktop.diff, +kspread-1.6.3.ebuild:
+ Fix gcc 4.3, fix desktop validity.
26 Jul 2007; Markus Rothe <corsair@gentoo.org> kspread-1.6.2.ebuild:
Stable on ppc64; bug #178697
diff --git a/app-office/kspread/files/kspread-1.6.3-validate-desktop.diff b/app-office/kspread/files/kspread-1.6.3-validate-desktop.diff
new file mode 100644
index 000000000000..8b361026e483
--- /dev/null
+++ b/app-office/kspread/files/kspread-1.6.3-validate-desktop.diff
@@ -0,0 +1,11 @@
+--- koffice-1.6.3/kspread/kspread.desktop.orig 2008-05-17 16:04:28.000000000 +0200
++++ koffice-1.6.3/kspread/kspread.desktop 2008-05-17 16:04:34.000000000 +0200
+@@ -70,7 +70,7 @@
+ GenericName[wa]=Tåvleus
+ GenericName[zh_CN]=电子表格
+ GenericName[zh_TW]=Spread 表格
+-MimeType=application/vnd.oasis.opendocument.spreadsheet;application/x-kspread;application/msexcel;text/x-csv;application/x-quattropro
++MimeType=application/vnd.oasis.opendocument.spreadsheet;application/x-kspread;application/msexcel;text/x-csv;application/x-quattropro;
+ Type=Application
+ Icon=kspread
+ X-KDE-NativeMimeType=application/vnd.oasis.opendocument.spreadsheet
diff --git a/app-office/kspread/files/kspread-gcc43.patch b/app-office/kspread/files/kspread-gcc43.patch
new file mode 100644
index 000000000000..9ac8a6f6dfe6
--- /dev/null
+++ b/app-office/kspread/files/kspread-gcc43.patch
@@ -0,0 +1,46 @@
+diff -Nrua koffice-1.6.3/kspread/plugins/scripting/kspreadcore/krs_cell.cpp koffice/kspread/plugins/scripting/kspreadcore/krs_cell.cpp
+--- koffice-1.6.3/kspread/plugins/scripting/kspreadcore/krs_cell.cpp 2007-05-30 23:43:20.000000000 +0200
++++ koffice/kspread/plugins/scripting/kspreadcore/krs_cell.cpp 2008-03-12 00:59:07.000000000 +0100
+@@ -174,12 +174,7 @@
+ return m_cell->text();
+ }
+
+-bool Cell::setText(const QString& text, bool asString) {
+-
+- //FIXME: there is some problem with asString parameter, when it's set
+- //to true KSpread says: ASSERT: "f" in Dependencies.cpp (621)
+- //kspread: Cell at row 6, col 1 marked as formula, but formula is NULL
+-
++bool Cell::setText(const QString& text) {
+ KSpread::ProtectedCheck prot;
+ prot.setSheet (m_sheet);
+ prot.add (QPoint (m_col, m_row));
+@@ -189,7 +184,7 @@
+ KSpread::DataManipulator *dm = new KSpread::DataManipulator ();
+ dm->setSheet (m_sheet);
+ dm->setValue (text);
+- dm->setParsing (!asString);
++ dm->setParsing (true);
+ dm->add (QPoint (m_col, m_row));
+ dm->execute ();
+
+diff -Nrua koffice-1.6.3/kspread/plugins/scripting/kspreadcore/krs_cell.h koffice/kspread/plugins/scripting/kspreadcore/krs_cell.h
+--- koffice-1.6.3/kspread/plugins/scripting/kspreadcore/krs_cell.h 2007-05-30 23:43:20.000000000 +0200
++++ koffice/kspread/plugins/scripting/kspreadcore/krs_cell.h 2008-03-12 00:59:07.000000000 +0100
+@@ -131,11 +131,10 @@
+ */
+ const QString text() const;
+ /**
+- * Set the text of the cell. If asString is true, the text
+- * will be handled as string else we try to parse the
+- * string to the expected value.
++ * Set the text of the cell. the text
++ * will be handled as string
+ */
+- bool setText(const QString& text, bool asString = false);
++ bool setText(const QString& text);
+
+ /**
+ * Return the textcolor as RGB-value in the format "#RRGGBB".
+
+
diff --git a/app-office/kspread/kspread-1.6.3.ebuild b/app-office/kspread/kspread-1.6.3.ebuild
new file mode 100644
index 000000000000..212989351c02
--- /dev/null
+++ b/app-office/kspread/kspread-1.6.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/kspread-1.6.3.ebuild,v 1.1 2008/05/17 14:52:28 hanno Exp $
+
+KMNAME=koffice
+MAXKOFFICEVER=1.6.3
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice spreadsheet application."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ $(deprange $PV $MAXKOFFICEVER app-office/kchart)
+ $(deprange $PV $MAXKOFFICEVER app-office/kexi)"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkochart interfaces
+ libkrossmain lib/kross/main
+ libkrossapi lib/kross/api
+ libkexidb kexi/kexidb
+ libkexidbparser kexi/kexidb/parser"
+
+KMEXTRACTONLY="lib/
+ interfaces/
+ filters/kexi
+ kexi/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/kspread"
+
+PATCHES="${FILESDIR}/kspread-1.6.3-validate-desktop.diff
+ ${FILESDIR}/kspread-gcc43.patch"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = liboofilter kspread" > ${S}/filters/Makefile.am
+
+ # Work around broken conditional
+ echo "SUBDIRS = applixspread csv dbase gnumeric latex opencalc html qpro excel kexi" > ${S}/filters/kspread/Makefile.am
+
+ for i in $(find "${S}"/lib -iname "*\.ui"); do
+ ${QTDIR}/bin/uic ${i} > ${i%.ui}.h
+ done
+
+ kde-meta_src_unpack makefiles
+}