summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-06-28 21:55:33 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-06-28 21:55:33 +0000
commit3f2563e6d83e789efd227e3a8b4f7bd2d69ced0e (patch)
tree8acbfa3ac1c3272265ab8773b827d27ae21a555c /app-office
parentUnmasking cups-1.1.15. New ghostscript should fix the problem. (diff)
downloadgentoo-2-3f2563e6d83e789efd227e3a8b4f7bd2d69ced0e.tar.gz
gentoo-2-3f2563e6d83e789efd227e3a8b4f7bd2d69ced0e.tar.bz2
gentoo-2-3f2563e6d83e789efd227e3a8b4f7bd2d69ced0e.zip
flag fixor
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/koffice-1.2_beta2.ebuild25
1 files changed, 24 insertions, 1 deletions
diff --git a/app-office/koffice/koffice-1.2_beta2.ebuild b/app-office/koffice/koffice-1.2_beta2.ebuild
index 5f5df3118baa..06f4903f4ebe 100644
--- a/app-office/koffice/koffice-1.2_beta2.ebuild
+++ b/app-office/koffice/koffice-1.2_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2_beta2.ebuild,v 1.1 2002/06/27 15:37:51 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2_beta2.ebuild,v 1.2 2002/06/28 21:55:33 verwilst Exp $
inherit kde-base || die
@@ -24,4 +24,27 @@ need-automake 1.5
need-autoconf 2.5
+src_compile() {
+
+ myconf="$myconf --enable-all"
+ kde_src_compile myconf
+
+ #the dir kchar/kdchart cannot be compiled with the -fomit-frame-pointer flag present
+ CXXFLAGS2="$CXXFLAGS"
+ CFLAGS2="$CFLAGS"
+
+ CFLAGS=${CFLAGS/-fomit-frame-pointer}
+ CXXFLAGS=${CXXFLAGS/-fomit-frame-pointer}
+ cd ${S}
+ kde_src_compile configure
+ cd ${S}/kchart/kdchart
+ make
+
+ CFLAGS="$CFLAGS2"
+ CXXFLAGS="$CXXFLAGS2"
+ cd ${S}
+ kde_src_compile configure
+ make
+
+}