summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-30 21:59:57 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-30 21:59:57 +0000
commit3743dba4d539f8b8121ba8bbb3627f84ae46a8ab (patch)
tree21bd5cf9a475a470a36658a56cdbcfd19ab5a524 /app-office
parentVersion bump, wrt bug #519010. (diff)
downloadgentoo-2-3743dba4d539f8b8121ba8bbb3627f84ae46a8ab.tar.gz
gentoo-2-3743dba4d539f8b8121ba8bbb3627f84ae46a8ab.tar.bz2
gentoo-2-3743dba4d539f8b8121ba8bbb3627f84ae46a8ab.zip
Fix building against sys-libs/ncurses[tinfo] (bug #527420).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/sc/ChangeLog6
-rw-r--r--app-office/sc/files/sc-7.16-amd64.patch5
-rw-r--r--app-office/sc/files/sc-7.16-lex-syntax.patch5
-rw-r--r--app-office/sc/sc-7.16-r1.ebuild50
4 files changed, 37 insertions, 29 deletions
diff --git a/app-office/sc/ChangeLog b/app-office/sc/ChangeLog
index 1467b582eacc..0b128941f985 100644
--- a/app-office/sc/ChangeLog
+++ b/app-office/sc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/sc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/sc/ChangeLog,v 1.25 2014/09/26 19:57:56 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/sc/ChangeLog,v 1.26 2014/10/30 21:59:57 jer Exp $
+
+ 30 Oct 2014; Jeroen Roovers <jer@gentoo.org> files/sc-7.16-amd64.patch,
+ files/sc-7.16-lex-syntax.patch, sc-7.16-r1.ebuild:
+ Fix building against sys-libs/ncurses[tinfo] (bug #527420).
26 Sep 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+files/sc-7.16-amd64.patch:
diff --git a/app-office/sc/files/sc-7.16-amd64.patch b/app-office/sc/files/sc-7.16-amd64.patch
index 266eff0986df..e381609011bb 100644
--- a/app-office/sc/files/sc-7.16-amd64.patch
+++ b/app-office/sc/files/sc-7.16-amd64.patch
@@ -1,6 +1,5 @@
-diff -Naur sc-7.16-orig/xmalloc.c sc-7.16/xmalloc.c
---- sc-7.16-orig/xmalloc.c 2002-04-25 17:37:58.000000000 -0600
-+++ sc-7.16/xmalloc.c 2008-01-17 14:41:31.000000000 -0600
+--- a/xmalloc.c
++++ b/xmalloc.c
@@ -3,19 +3,12 @@
* $Revision: 7.16 $
*/
diff --git a/app-office/sc/files/sc-7.16-lex-syntax.patch b/app-office/sc/files/sc-7.16-lex-syntax.patch
index 1c72c13df2a3..9dcb46f25f83 100644
--- a/app-office/sc/files/sc-7.16-lex-syntax.patch
+++ b/app-office/sc/files/sc-7.16-lex-syntax.patch
@@ -1,6 +1,5 @@
-diff -Naur sc-7.16-orig/lex.c sc-7.16/lex.c
---- sc-7.16-orig/lex.c 2002-08-20 16:44:26.000000000 -0600
-+++ sc-7.16/lex.c 2008-01-17 14:56:27.000000000 -0600
+--- a/lex.c
++++ b/lex.c
@@ -107,7 +107,7 @@
yylex()
{
diff --git a/app-office/sc/sc-7.16-r1.ebuild b/app-office/sc/sc-7.16-r1.ebuild
index 2d9b820091ed..7f51c50f422a 100644
--- a/app-office/sc/sc-7.16-r1.ebuild
+++ b/app-office/sc/sc-7.16-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/sc/sc-7.16-r1.ebuild,v 1.8 2014/08/10 18:17:32 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/sc/sc-7.16-r1.ebuild,v 1.9 2014/10/30 21:59:57 jer Exp $
+EAPI=5
inherit eutils multilib toolchain-funcs
DESCRIPTION="sc is a free curses-based spreadsheet program that uses key bindings similar to vi and less"
@@ -11,31 +12,36 @@ HOMEPAGE="http://ibiblio.org/pub/Linux/apps/financial/spreadsheet/"
SLOT="0"
LICENSE="public-domain"
KEYWORDS="amd64 ppc sparc x86"
-IUSE=""
-DEPEND=">=sys-libs/ncurses-5.2"
-RDEPEND="${DEPEND}
+COMMON_DEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="virtual/pkgconfig"
+RDEPEND="
+ ${COMMON_DEPEND}
!dev-lang/stratego
- !<sci-chemistry/ccp4-apps-6.1.3-r4"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i -e "/^prefix=/ s:/usr:${D}/usr:" \
- -e "/^MANDIR=/ s:${prefix}/man:${prefix}/share/man:" \
- -e "/^LIBDIR=/ s:${prefix}/lib:${prefix}/$(get_libdir):" \
- -e "/^CC=/ s:gcc:$(tc-getCC):" \
- -e "/^CFLAGS/ s:=-DSYSV3 -O2 -pipe:+=-DSYSV3:" \
- -e "/strip/ s:^:#:g" \
- Makefile
-
- epatch "${FILESDIR}"/${P}-amd64.patch
- epatch "${FILESDIR}"/${P}-lex-syntax.patch
+ !<sci-chemistry/ccp4-apps-6.1.3-r4
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-amd64.patch \
+ "${FILESDIR}"/${P}-lex-syntax.patch
+
+ sed -i \
+ -e "/^prefix=/ s:/usr:${D}/usr:" \
+ -e "/^MANDIR=/ s:${prefix}/man:${prefix}/share/man:" \
+ -e "/^LIBDIR=/ s:${prefix}/lib:${prefix}/$(get_libdir):" \
+ -e '/^LIB=/s|-lncurses|$(shell ${PKG_CONFIG} --libs ncurses)|g' \
+ -e "/^CC=/ s:gcc:$(tc-getCC):" \
+ -e "/^CFLAGS/ s:=-DSYSV3 -O2 -pipe:+=-DSYSV3:" \
+ -e "/strip/ s:^:#:g" \
+ Makefile || die
+
}
src_compile() {
+ tc-export PKG_CONFIG
# no autoconf
- emake prefix="${D}"/usr || die "emake failed"
+ emake prefix="${D}"/usr || die
}
src_install () {
@@ -43,9 +49,9 @@ src_install () {
dodir /usr/bin
dodir /usr/$(get_libdir)/sc
dodir /usr/share/man/man1
- emake install || die
+ emake install
- sed -i "s:${D}::g" sc.1
+ sed -i -e "s:${D}::g" sc.1 || die
doman sc.1 psc.1
dodoc CHANGES README sc.doc psc.doc tutorial.sc