summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-01-28 18:18:44 +0000
committerDan Armak <danarmak@gentoo.org>2003-01-28 18:18:44 +0000
commit2f96bce3cb888beb8c4c56dd0493e4a626ecc139 (patch)
treefddd9e04a41d16a748d9fcec55a96988faa22886 /app-office
parentnew ebuild (diff)
downloadgentoo-2-2f96bce3cb888beb8c4c56dd0493e4a626ecc139.tar.gz
gentoo-2-2f96bce3cb888beb8c4c56dd0493e4a626ecc139.tar.bz2
gentoo-2-2f96bce3cb888beb8c4c56dd0493e4a626ecc139.zip
new koffice rev adding a patch from koffice.org (see changelog for 1.2.1 there)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/ChangeLog10
-rw-r--r--app-office/koffice/files/digest-koffice-1.2.1-r11
-rw-r--r--app-office/koffice/files/koffice-1.2.1-kword-crashes.diff110
-rw-r--r--app-office/koffice/koffice-1.2.1-r1.ebuild29
4 files changed, 149 insertions, 1 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 2b56f5bfad4b..374e9254c74e 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-office/koffice
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.15 2002/11/24 20:14:22 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.16 2003/01/28 18:18:44 danarmak Exp $
+
+*koffice-1.2.1-r1 (28 Jan 2003)
+
+ 28 Jan 2003; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ We forgot to add changelog information for 1.2.1, so here goes: it's a
+ new bugfix release from upstream. 1.2.1-r1 adds a patch from upstream that
+ fixes two bugs in kword.
*koffice-1.2-r2 (24 Nov 2002)
diff --git a/app-office/koffice/files/digest-koffice-1.2.1-r1 b/app-office/koffice/files/digest-koffice-1.2.1-r1
new file mode 100644
index 000000000000..107814748a96
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.2.1-r1
@@ -0,0 +1 @@
+MD5 6a73aa72b094ca7b7377f74a508e804e koffice-1.2.1.tar.bz2 9275595
diff --git a/app-office/koffice/files/koffice-1.2.1-kword-crashes.diff b/app-office/koffice/files/koffice-1.2.1-kword-crashes.diff
new file mode 100644
index 000000000000..ee7f53c9138f
--- /dev/null
+++ b/app-office/koffice/files/koffice-1.2.1-kword-crashes.diff
@@ -0,0 +1,110 @@
+Index: contents.cc
+===================================================================
+RCS file: /home/kde/koffice/kword/contents.cc,v
+retrieving revision 1.49.2.1
+retrieving revision 1.49.2.2
+diff -u -p -r1.49.2.1 -r1.49.2.2
+--- kword/contents.cc 18 Oct 2002 16:59:42 -0000 1.49.2.1
++++ kword/contents.cc 20 Dec 2002 12:01:36 -0000 1.49.2.2
+@@ -134,7 +134,7 @@ KoTextCursor * KWInsertTOCCommand::remov
+ // We start from the end, to avoid the parag shifting problem
+ KoTextParag *p = textdoc->lastParag();
+ KoTextCursor *posOfTable=0L;
+- KWTextParag *posOfToc=0L;
++ KoTextParag *posOfToc=0L;
+
+ while ( p )
+ {
+@@ -142,8 +142,6 @@ KoTextCursor * KWInsertTOCCommand::remov
+ if ( parag->style() && ( parag->style()->name().startsWith( "Contents Head" ) ||
+ parag->style()->name() == "Contents Title" ) )
+ {
+- posOfToc=parag;
+-
+ kdDebug() << "KWContents::createContents Deleting paragraph " << p << " " << p->paragId() << endl;
+ // This paragraph is part of the TOC -> remove
+
+@@ -172,6 +170,7 @@ KoTextCursor * KWInsertTOCCommand::remov
+ delete p;
+ kdDebug() << "KWInsertTOCCommand::removeTOC " << p << " deleted" << endl;
+ p = next;
++ posOfToc = p;
+ kdDebug() << "KWInsertTOCCommand::removeTOC prev=" << prev << " p=" << p << endl;
+ // Fix parag chain
+ if ( prev )
+@@ -179,6 +178,8 @@ KoTextCursor * KWInsertTOCCommand::remov
+ prev->setNext( p );
+ if ( p )
+ p->setParagId( prev->paragId() + 1 );
++ else
++ posOfToc = prev;
+ }
+ else
+ {
+@@ -190,6 +191,7 @@ KoTextCursor * KWInsertTOCCommand::remov
+ {
+ textdoc->clear( true ); // recreate empty parag.
+ cursor->setParag( textdoc->firstParag() );
++ posOfToc = textdoc->firstParag();
+ break;
+ }
+ }
+@@ -198,12 +200,12 @@ KoTextCursor * KWInsertTOCCommand::remov
+ p = p->prev();
+ }
+ textdoc->invalidate();
+- if(posOfToc)
+- {
++ if(posOfToc)
++ {
+ posOfTable=new KoTextCursor( textdoc );
+ posOfTable->setParag(posOfToc );
+ posOfTable->setIndex( 0 );//start of parag
+- }
++ }
+ // ### TODO propagate parag ID changes.
+ return posOfTable;
+ }
+Index: kwview.cc
+===================================================================
+RCS file: /home/kde/koffice/kword/kwview.cc,v
+retrieving revision 1.822.2.5
+retrieving revision 1.822.2.6
+diff -u -p -r1.822.2.5 -r1.822.2.6
+--- kword/kwview.cc 12 Nov 2002 15:38:17 -0000 1.822.2.5
++++ kword/kwview.cc 24 Dec 2002 15:16:50 -0000 1.822.2.6
+@@ -251,12 +251,6 @@ KWView::KWView( KWViewMode* viewMode, QW
+ KWView::~KWView()
+ {
+ clearSelection();
+- //delete special char dlg when we close view
+- if ( m_specialCharDlg )
+- {
+- m_specialCharDlg->closeDialog();
+- }
+-
+ if ( m_findReplace )
+ {
+ // Abort any find/replace
+@@ -322,8 +316,11 @@ void KWView::clearSelection()
+ delete m_spell.kspell;
+ }
+ delete m_searchEntry;
++ m_searchEntry = 0L;
+ delete m_replaceEntry;
+- delete m_specialCharDlg;
++ m_replaceEntry = 0L;
++ if ( m_specialCharDlg )
++ m_specialCharDlg->closeDialog(); // will call slotSpecialCharDlgClosed
+ }
+
+
+@@ -3079,7 +3076,7 @@ void KWView::slotSpecialCharDlgClosed()
+ this, SLOT(slotSpecialChar(QChar,const QString &)));
+ disconnect( m_specialCharDlg, SIGNAL( finished() ),
+ this, SLOT( slotSpecialCharDlgClosed() ) );
+- delete m_specialCharDlg;
++ m_specialCharDlg->deleteLater();
+ m_specialCharDlg = 0L;
+ }
+ }
diff --git a/app-office/koffice/koffice-1.2.1-r1.ebuild b/app-office/koffice/koffice-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..3f57278faf18
--- /dev/null
+++ b/app-office/koffice/koffice-1.2.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2.1-r1.ebuild,v 1.1 2003/01/28 18:18:44 danarmak Exp $
+inherit kde-base flag-o-matic
+
+filter-flags "-fomit-frame-pointer"
+
+need-kde 3
+
+DESCRIPTION="A free, integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+SRC_URI="mirror://kde/stable/$P/src/$P.tar.bz2"
+
+KEYWORDS="x86 ~ppc"
+
+DEPEND="$DEPEND
+ >=dev-lang/python-2.2.1
+ >=media-libs/libart_lgpl-2.3.9
+ >=media-gfx/imagemagick-5.4.5"
+
+PATCHES="$FILESDIR/${P}-kword-crashes.diff"
+
+export LIBPYTHON="`python-config --libs`"
+export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+
+need-automake 1.5
+need-autoconf 2.5
+