summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-25 19:18:47 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-25 19:18:47 +0000
commit1abd0421bd768c4608a07e46f476039407411d57 (patch)
tree7a2eb497119665d9df839137ace2d4b6c1378a89 /app-office
parentamd64 stable, bug 211419 (diff)
downloadgentoo-2-1abd0421bd768c4608a07e46f476039407411d57.tar.gz
gentoo-2-1abd0421bd768c4608a07e46f476039407411d57.tar.bz2
gentoo-2-1abd0421bd768c4608a07e46f476039407411d57.zip
bump to 2.2.2, fix crashers and rendering problems
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/glabels/ChangeLog7
-rw-r--r--app-office/glabels/glabels-2.2.2.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/app-office/glabels/ChangeLog b/app-office/glabels/ChangeLog
index 6761cbfa7629..c540e7cee2e0 100644
--- a/app-office/glabels/ChangeLog
+++ b/app-office/glabels/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/glabels
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/glabels/ChangeLog,v 1.28 2008/02/24 11:03:57 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/glabels/ChangeLog,v 1.29 2008/02/25 19:18:47 eva Exp $
+
+*glabels-2.2.2 (25 Feb 2008)
+
+ 25 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org> +glabels-2.2.2.ebuild:
+ bump to 2.2.2, fix crashers and rendering problems
*glabels-2.2.1 (24 Feb 2008)
diff --git a/app-office/glabels/glabels-2.2.2.ebuild b/app-office/glabels/glabels-2.2.2.ebuild
new file mode 100644
index 000000000000..d0c891f5e0a5
--- /dev/null
+++ b/app-office/glabels/glabels-2.2.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/glabels/glabels-2.2.2.ebuild,v 1.1 2008/02/25 19:18:47 eva Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Program for creating labels and business cards"
+HOMEPAGE="http://glabels.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc eds"
+
+RDEPEND=">=dev-libs/glib-2.12
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libgnome-2.16
+ >=gnome-base/libgnomeui-2.16
+ >=dev-libs/libxml2-2.6
+ >=gnome-base/libglade-2.6
+ eds? ( >=gnome-extra/evolution-data-server-1.8 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.28
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with eds libebook)
+ --disable-update-mimedb
+ --disable-update-desktopdb"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix missing pkg-config macro (bug 204276)
+ epatch "${FILESDIR}/${PN}-2.2.1-pkg-config-macro.patch"
+
+ # drop gtk-doc for eautoreconf
+ use doc || epatch "${FILESDIR}/${PN}-2.2.1-drop-gtk-doc.patch"
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ewarn "This version of ${PN} has a file format change. Files will be"
+ ewarn "automatically converted to the new format but it is a one way"
+ ewarn "process only. Make backups."
+}