summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2014-05-30 22:24:35 +0000
committerVlastimil Babka <caster@gentoo.org>2014-05-30 22:24:35 +0000
commit0ec6bedfb57c3f1a68217f5b3913ee8668dc2920 (patch)
treeb8a0ccbd02f451e36ac987a3284ac83d91b4f303 /app-office/taskcoach
parentVersion bump to 2.10 series, move to reworked init script. Clean out some old... (diff)
downloadgentoo-2-0ec6bedfb57c3f1a68217f5b3913ee8668dc2920.tar.gz
gentoo-2-0ec6bedfb57c3f1a68217f5b3913ee8668dc2920.tar.bz2
gentoo-2-0ec6bedfb57c3f1a68217f5b3913ee8668dc2920.zip
Version bump. Stopped renaming upstream executable taskcoach.py to taskcoach, as it was fragile. Fixes bug #488416.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4E61DE84)
Diffstat (limited to 'app-office/taskcoach')
-rw-r--r--app-office/taskcoach/ChangeLog10
-rw-r--r--app-office/taskcoach/taskcoach-1.3.40.ebuild43
2 files changed, 51 insertions, 2 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index 27f411267d13..051b7b45ed1f 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/taskcoach
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.92 2013/09/09 17:54:05 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.93 2014/05/30 22:24:35 caster Exp $
+
+*taskcoach-1.3.40 (30 May 2014)
+
+ 30 May 2014; Vlastimil Babka <caster@gentoo.org> +taskcoach-1.3.40.ebuild:
+ Version bump. Stopped renaming upstream executable taskcoach.py to taskcoach,
+ as it was fragile. Fixes bug #488416.
*taskcoach-1.3.32-r1 (09 Sep 2013)
diff --git a/app-office/taskcoach/taskcoach-1.3.40.ebuild b/app-office/taskcoach/taskcoach-1.3.40.ebuild
new file mode 100644
index 000000000000..b050a22dea0e
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.3.40.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.3.40.ebuild,v 1.1 2014/05/30 22:24:35 caster Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 eutils versionator
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org http://pypi.python.org/pypi/TaskCoach"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-10.0"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES.txt README.txt )
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doicon "icons.in/${PN}.png"
+ make_desktop_entry ${PN}.py "Task Coach" ${PN} Office
+}
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ if ! version_is_at_least 1.3.40 ${REPLACING_VERSIONS}; then
+ elog "Since version 1.3.40, the Task Coach executable is called ${PN}.py"
+ fi
+ fi
+}