summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-05-26 20:25:32 +0000
committerJason Zaman <perfinion@gentoo.org>2015-05-26 20:25:32 +0000
commit9919211215fe76c3d6459ef01c694b402ce9dbe9 (patch)
tree7495ae29c794d064020dcb3ca6c4cba8afdd83e9 /app-office/orage
parentwww-servers/tomcat: removed obsolete files (diff)
downloadgentoo-2-9919211215fe76c3d6459ef01c694b402ce9dbe9.tar.gz
gentoo-2-9919211215fe76c3d6459ef01c694b402ce9dbe9.tar.bz2
gentoo-2-9919211215fe76c3d6459ef01c694b402ce9dbe9.zip
version bump, fix db slot dep
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x7EF137EC935B0EAF)
Diffstat (limited to 'app-office/orage')
-rw-r--r--app-office/orage/ChangeLog10
-rw-r--r--app-office/orage/orage-4.10.0.ebuild8
-rw-r--r--app-office/orage/orage-4.12.1.ebuild54
3 files changed, 66 insertions, 6 deletions
diff --git a/app-office/orage/ChangeLog b/app-office/orage/ChangeLog
index c7b474f6dd00..674f29e71ff9 100644
--- a/app-office/orage/ChangeLog
+++ b/app-office/orage/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/orage
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.82 2014/04/22 13:48:24 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.83 2015/05/26 20:25:32 perfinion Exp $
+
+*orage-4.12.1 (26 May 2015)
+
+ 26 May 2015; Jason Zaman <perfinion@gentoo.org> +orage-4.12.1.ebuild,
+ orage-4.10.0.ebuild:
+ version bump, fix db slot dep
22 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> -orage-4.8.4.ebuild:
old
diff --git a/app-office/orage/orage-4.10.0.ebuild b/app-office/orage/orage-4.10.0.ebuild
index e5f76e6e3461..670992b42116 100644
--- a/app-office/orage/orage-4.10.0.ebuild
+++ b/app-office/orage/orage-4.10.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.10.0.ebuild,v 1.7 2014/04/16 07:49:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.10.0.ebuild,v 1.8 2015/05/26 20:25:32 perfinion Exp $
EAPI=5
inherit multilib xfconf
@@ -17,8 +17,8 @@ IUSE="berkdb dbus debug libnotify +xfce_plugins_clock"
RDEPEND=">=dev-libs/libical-0.48:=
dev-libs/popt:=
>=x11-libs/gtk+-2.10:2
- berkdb? ( >=sys-libs/db-4 )
- dbus? ( >=dev-libs/dbus-glib-0.100 )
+ berkdb? ( >=sys-libs/db-4:= )
+ dbus? ( >=dev-libs/dbus-glib-0.100:= )
libnotify? ( >=x11-libs/libnotify-0.7:= )
xfce_plugins_clock? ( >=xfce-base/xfce4-panel-4.10 )"
DEPEND="${RDEPEND}
diff --git a/app-office/orage/orage-4.12.1.ebuild b/app-office/orage/orage-4.12.1.ebuild
new file mode 100644
index 000000000000..97f6b26430ea
--- /dev/null
+++ b/app-office/orage/orage-4.12.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.12.1.ebuild,v 1.1 2015/05/26 20:25:32 perfinion Exp $
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A time managing application (and panel plug-in) for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="berkdb dbus debug libnotify +xfce_plugins_clock"
+
+RDEPEND=">=dev-libs/libical-0.48:=
+ dev-libs/popt:=
+ >=x11-libs/gtk+-2.10:2=
+ berkdb? ( >=sys-libs/db-4:= )
+ dbus? ( >=dev-libs/dbus-glib-0.100:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ xfce_plugins_clock? ( >=xfce-base/xfce4-panel-4.10:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable xfce_plugins_clock libxfce4panel)
+ $(use_enable dbus)
+ $(use_enable libnotify)
+ $(use_with berkdb bdb4)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+ # PM doesn't let directory to be replaced by a symlink, see src_install()
+ rm -rf "${EROOT}"/usr/share/${PN}/doc
+}
+
+src_install() {
+ xfconf_src_install \
+ docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ imagesdir="${EPREFIX}"/usr/share/doc/${PF}/html/images
+
+ # Create compability symlink for retarded path hardcoding in src/{mainbox,parameters}.c
+ dosym /usr/share/doc/${PF}/html /usr/share/${PN}/doc/C
+}