summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-06 13:05:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-06 13:05:28 +0000
commit91cfea67a920f46c4e859af3126bb9f0ff721cd4 (patch)
tree326c7d074676b51e6643cbd03dfdced04d70da4e /app-office/orage
parentversion bump, use lilv instead of slv2 for lv2 plugins, slv2 will be deprecat... (diff)
downloadgentoo-2-91cfea67a920f46c4e859af3126bb9f0ff721cd4.tar.gz
gentoo-2-91cfea67a920f46c4e859af3126bb9f0ff721cd4.tar.bz2
gentoo-2-91cfea67a920f46c4e859af3126bb9f0ff721cd4.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-office/orage')
-rw-r--r--app-office/orage/ChangeLog7
-rw-r--r--app-office/orage/orage-4.8.3.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-office/orage/ChangeLog b/app-office/orage/ChangeLog
index 2680d4c3c840..c52939d69210 100644
--- a/app-office/orage/ChangeLog
+++ b/app-office/orage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/orage
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.54 2012/01/06 10:56:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.55 2012/01/06 13:05:28 ssuominen Exp $
+
+*orage-4.8.3 (06 Jan 2012)
+
+ 06 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +orage-4.8.3.ebuild:
+ Version bump.
06 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> -orage-4.8.1.ebuild:
old
diff --git a/app-office/orage/orage-4.8.3.ebuild b/app-office/orage/orage-4.8.3.ebuild
new file mode 100644
index 000000000000..7f93b07bd8ca
--- /dev/null
+++ b/app-office/orage/orage-4.8.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.8.3.ebuild,v 1.1 2012/01/06 13:05:28 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="A time managing application (and panel plug-in) for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/orage/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="berkdb dbus debug libnotify +xfce_plugins_clock"
+
+RDEPEND=">=dev-libs/libical-0.48
+ dev-libs/popt
+ >=x11-libs/gtk+-2.10:2
+ berkdb? ( >=sys-libs/db-4 )
+ dbus? ( >=dev-libs/dbus-glib-0.90 )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ xfce_plugins_clock? ( >=xfce-base/xfce4-panel-4.8 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable xfce_plugins_clock libxfce4panel)
+ $(use_enable dbus)
+ $(use_enable libnotify)
+ $(use_with berkdb bdb4)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}