summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-06-03 22:36:21 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-06-03 22:36:21 +0000
commitf3358974f552fcbe4bf9a1e16941748fedf795fd (patch)
tree36c67706896708c79469dae733e3a1fae26f5cac /app-office/ooqstart-gnome
parentadd more error messages and fix use static logic in install (diff)
downloadgentoo-2-f3358974f552fcbe4bf9a1e16941748fedf795fd.tar.gz
gentoo-2-f3358974f552fcbe4bf9a1e16941748fedf795fd.tar.bz2
gentoo-2-f3358974f552fcbe4bf9a1e16941748fedf795fd.zip
gcc4 patch
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-office/ooqstart-gnome')
-rw-r--r--app-office/ooqstart-gnome/ChangeLog6
-rw-r--r--app-office/ooqstart-gnome/Manifest7
-rw-r--r--app-office/ooqstart-gnome/files/ooqstart-gnome-0.8.3-gcc4.patch11
-rw-r--r--app-office/ooqstart-gnome/ooqstart-gnome-0.8.3.ebuild3
4 files changed, 22 insertions, 5 deletions
diff --git a/app-office/ooqstart-gnome/ChangeLog b/app-office/ooqstart-gnome/ChangeLog
index 25b9f4e73cf7..70c434d04be8 100644
--- a/app-office/ooqstart-gnome/ChangeLog
+++ b/app-office/ooqstart-gnome/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/ooqstart-gnome
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ooqstart-gnome/ChangeLog,v 1.3 2005/04/10 18:41:25 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ooqstart-gnome/ChangeLog,v 1.4 2005/06/03 22:36:21 halcy0n Exp $
+
+ 03 Jun 2005; <halcyon@gentoo.org> +files/ooqstart-gnome-0.8.3-gcc4.patch,
+ ooqstart-gnome-0.8.3.ebuild:
+ Patch to fix compilation with gcc4
10 Apr 2005; Andreas Proschofsky <suka@gentoo.org>
ooqstart-gnome-0.8.3.ebuild:
diff --git a/app-office/ooqstart-gnome/Manifest b/app-office/ooqstart-gnome/Manifest
index 6565d5d27a54..c7f76aa0ca94 100644
--- a/app-office/ooqstart-gnome/Manifest
+++ b/app-office/ooqstart-gnome/Manifest
@@ -1,6 +1,7 @@
-MD5 a2e0c468ccf9d573a0a4647f81e6eaca ChangeLog 625
+MD5 67087867f6a8217f89ceafd42d502f94 ChangeLog 770
MD5 6e27642eb774b668fe48a47e475f2495 metadata.xml 400
-MD5 f76385347f3cd355a094e96ee75c9305 ooqstart-gnome-0.8.3.ebuild 1072
-MD5 b8e5e4d8a4016a754ab52481fc66a00d files/gnome-ooqstart.png 3962
+MD5 33237096be91b4e7c94ad0e9ab9d2131 ooqstart-gnome-0.8.3.ebuild 1108
MD5 d262aad066c0dd58486d7a8a095b598d files/digest-ooqstart-gnome-0.8.3 62
+MD5 b8e5e4d8a4016a754ab52481fc66a00d files/gnome-ooqstart.png 3962
MD5 6e3446ddec68a391cd1f63851e4942c6 files/gnome2update.patch.bz2 8004
+MD5 d44da1879b15d8fd3f96d3cbfd54d0d1 files/ooqstart-gnome-0.8.3-gcc4.patch 350
diff --git a/app-office/ooqstart-gnome/files/ooqstart-gnome-0.8.3-gcc4.patch b/app-office/ooqstart-gnome/files/ooqstart-gnome-0.8.3-gcc4.patch
new file mode 100644
index 000000000000..aa3ef187f681
--- /dev/null
+++ b/app-office/ooqstart-gnome/files/ooqstart-gnome-0.8.3-gcc4.patch
@@ -0,0 +1,11 @@
++++ model.cxx 2005-05-16 01:43:21.304891328 +0200
+--- model.cxx.orig 2005-05-16 01:41:52.195438024 +0200
+@@ -72,7 +72,7 @@
+ }
+
+ // Child process execution point
+- execlp(arg1,arg1, arg2, arg3, 0);
++ execlp(arg1,arg1, arg2, arg3, (char*)NULL);
+
+ // Execution should never reach this point.
+ // If it does, there was an error.
diff --git a/app-office/ooqstart-gnome/ooqstart-gnome-0.8.3.ebuild b/app-office/ooqstart-gnome/ooqstart-gnome-0.8.3.ebuild
index 9bdd01dc3afa..548ec1842305 100644
--- a/app-office/ooqstart-gnome/ooqstart-gnome-0.8.3.ebuild
+++ b/app-office/ooqstart-gnome/ooqstart-gnome-0.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ooqstart-gnome/ooqstart-gnome-0.8.3.ebuild,v 1.6 2005/04/10 18:41:25 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ooqstart-gnome/ooqstart-gnome-0.8.3.ebuild,v 1.7 2005/06/03 22:36:21 halcy0n Exp $
inherit eutils
@@ -28,6 +28,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/gnome2update.patch.bz2
+ epatch ${FILESDIR}/${P}-gcc4.patch
}
src_install() {