summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-07-14 11:06:50 +0000
committerDan Armak <danarmak@gentoo.org>2001-07-14 11:06:50 +0000
commita840ea431d60336acea65795f7d95e50a236652b (patch)
tree844ef0d6c98c698172f2755e55853e73df00cdb1 /app-office/lyx-base
parentgv is a ghostscript frontend used by lyx etc. We should have had this long ago. (diff)
downloadgentoo-2-a840ea431d60336acea65795f7d95e50a236652b.tar.gz
gentoo-2-a840ea431d60336acea65795f7d95e50a236652b.tar.bz2
gentoo-2-a840ea431d60336acea65795f7d95e50a236652b.zip
The lyx ebuild. lyx-base actually buids lyx and depends latex and xforms. lyx-utuls depends on everything lyx can make use of. lyx depends on the other two.
Diffstat (limited to 'app-office/lyx-base')
-rw-r--r--app-office/lyx-base/files/digest-lyx-base-1.1.6.21
-rw-r--r--app-office/lyx-base/lyx-base-1.1.6.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-office/lyx-base/files/digest-lyx-base-1.1.6.2 b/app-office/lyx-base/files/digest-lyx-base-1.1.6.2
new file mode 100644
index 000000000000..8bd65e598fe2
--- /dev/null
+++ b/app-office/lyx-base/files/digest-lyx-base-1.1.6.2
@@ -0,0 +1 @@
+MD5 08509dfa31bede1015255607a874d25c lyx-1.1.6fix2.tar.gz
diff --git a/app-office/lyx-base/lyx-base-1.1.6.2.ebuild b/app-office/lyx-base/lyx-base-1.1.6.2.ebuild
new file mode 100644
index 000000000000..5f30159ccfba
--- /dev/null
+++ b/app-office/lyx-base/lyx-base-1.1.6.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <ermak@netvision.net.il>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.3 2001/07/05 02:43:36 drobbins Exp
+
+# The real version of LyX is 1.1.6fix2. As Portage has no support for
+# arbitrary suffixes like 'fix' (yet), this is translated into 1.1.6.2.
+P=lyx-1.1.6fix2
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+
+DESCRIPTION="LyX is an Xwindows graphical frontend for LaTeX. Instead\
+ of forcing you to learn LaTeX markup syntax and use the\
+ proper tags, however, it is a WYSIWYM program."
+
+SRC_URI="ftp://ftp.lyx.org/pub/${A}"
+
+HOMEPAGE="http://www.lyx.org/"
+
+# This lyx-base ebuild only depends on the absolutely necessary packages.
+# The acompanying lyx-utils ebuild depends on lyx-base and on everything
+# else that lyx can use.
+DEPEND="virtual/x11 x11-libs/xforms app-text/tetex
+ >=sys-devel/perl-5"
+
+src_compile() {
+
+ try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}
+
+ try emake
+
+}
+
+src_install () {
+
+ # install-strip is a special target provided by the LyX makefile
+ # for striping installed binaries.
+ try make DESTDIR=${D} install-strip
+
+}
+