summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-07-20 00:06:04 +0000
committerAron Griffis <agriffis@gentoo.org>2004-07-20 00:06:04 +0000
commit7da187b778257b08e96418329cdbce68c22c47d3 (patch)
treeeeb280d2d6c2d2fbea47a5473fe542f123aa39fa /app-office/linuxtrade
parentstable on x86 (Manifest recommit) (diff)
downloadgentoo-2-7da187b778257b08e96418329cdbce68c22c47d3.tar.gz
gentoo-2-7da187b778257b08e96418329cdbce68c22c47d3.tar.bz2
gentoo-2-7da187b778257b08e96418329cdbce68c22c47d3.zip
New ebuild for linuxtrade, ncurses-based realtime quote tracker, submitted by me
Diffstat (limited to 'app-office/linuxtrade')
-rw-r--r--app-office/linuxtrade/ChangeLog11
-rw-r--r--app-office/linuxtrade/Manifest3
-rw-r--r--app-office/linuxtrade/files/digest-linuxtrade-3.652
-rw-r--r--app-office/linuxtrade/files/linuxtrade-3.65-bool.patch47
-rw-r--r--app-office/linuxtrade/linuxtrade-3.65.ebuild38
-rw-r--r--app-office/linuxtrade/metadata.xml18
6 files changed, 119 insertions, 0 deletions
diff --git a/app-office/linuxtrade/ChangeLog b/app-office/linuxtrade/ChangeLog
new file mode 100644
index 000000000000..8126a6a15d8d
--- /dev/null
+++ b/app-office/linuxtrade/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-office/linuxtrade
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/linuxtrade/ChangeLog,v 1.1 2004/07/20 00:06:04 agriffis Exp $
+
+*linuxtrade-3.65 (19 Jul 2004)
+
+ 19 Jul 2004; Aron Griffis <agriffis@gentoo.org>
+ +files/linuxtrade-3.65-bool.patch, +linuxtrade-3.65.ebuild:
+ New ebuild for linuxtrade, ncurses-based realtime quote tracker, submitted by
+ me
+
diff --git a/app-office/linuxtrade/Manifest b/app-office/linuxtrade/Manifest
new file mode 100644
index 000000000000..089ad23d59fb
--- /dev/null
+++ b/app-office/linuxtrade/Manifest
@@ -0,0 +1,3 @@
+MD5 d9e68e9734cd860b52175f5353990213 linuxtrade-3.65.ebuild 716
+MD5 9578561316ef42794a3138b64b61ec17 wget-log 360
+MD5 94a86d8c8973fd2e07442f8bc93eae64 files/digest-linuxtrade-3.65 140
diff --git a/app-office/linuxtrade/files/digest-linuxtrade-3.65 b/app-office/linuxtrade/files/digest-linuxtrade-3.65
new file mode 100644
index 000000000000..52fd3a22e248
--- /dev/null
+++ b/app-office/linuxtrade/files/digest-linuxtrade-3.65
@@ -0,0 +1,2 @@
+MD5 376fc56f9caa457519616243d495e6c8 linuxtrade_3.65.orig.tar.gz 853297
+MD5 1e52db93fe9d7a0ef040ff40fa70e8b1 linuxtrade_3.65-5.diff.gz 8831
diff --git a/app-office/linuxtrade/files/linuxtrade-3.65-bool.patch b/app-office/linuxtrade/files/linuxtrade-3.65-bool.patch
new file mode 100644
index 000000000000..f67e11555749
--- /dev/null
+++ b/app-office/linuxtrade/files/linuxtrade-3.65-bool.patch
@@ -0,0 +1,47 @@
+--- linuxtrade-3.65/alert.c.bool 2002-12-27 01:03:32.000000000 -0500
++++ linuxtrade-3.65/alert.c 2004-07-19 19:26:56.000000000 -0400
+@@ -679,7 +679,7 @@
+ int i;
+ ALERT *ap;
+ float var;
+- int bool;
++ int bule;
+ time_t now;
+ struct tm *tm;
+ int dowrite = 0;
+@@ -707,9 +707,9 @@
+
+ switch (ap->op)
+ {
+- case '<': bool = var < ap->val; break;
+- case '>': bool = var > ap->val; break;
+- case '=': bool = var = ap->val; break;
++ case '<': bule = var < ap->val; break;
++ case '>': bule = var > ap->val; break;
++ case '=': bule = var = ap->val; break;
+ default: continue;
+ case 'f':
+ time(&now); tm = localtime(&now);
+@@ -723,7 +723,7 @@
+ continue;
+ }
+ else
+- bool = var <= ap->val;
++ bule = var <= ap->val;
+ break;
+ case 'F':
+ time(&now); tm = localtime(&now);
+@@ -737,11 +737,11 @@
+ continue;
+ }
+ else
+- bool = var >= ap->val;
++ bule = var >= ap->val;
+ break;
+ }
+
+- if (!bool)
++ if (!bule)
+ continue;
+
+ ap->alstate = ALERT_TRIG; // Alerts are one-shot
diff --git a/app-office/linuxtrade/linuxtrade-3.65.ebuild b/app-office/linuxtrade/linuxtrade-3.65.ebuild
new file mode 100644
index 000000000000..42138fd9a702
--- /dev/null
+++ b/app-office/linuxtrade/linuxtrade-3.65.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/linuxtrade/linuxtrade-3.65.ebuild,v 1.1 2004/07/20 00:06:04 agriffis Exp $
+
+inherit eutils
+
+DESCRIPTION="real-time stock market tracker and news console"
+HOMEPAGE="http://linuxtrade.rkkda.com/"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${P/-/_}.orig.tar.gz
+ mirror://debian/pool/main/l/${PN}/${P/-/_}-5.diff.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+
+ # This package is no longer open source so won't be releasing any
+ # updated versions. Might as well use the Debian patches in that
+ # case.
+ epatch ${DISTDIR}/${P/-/_}-5.diff.gz
+
+ # Don't use reserved word "bool" as a variable
+ epatch ${FILESDIR}/${PN}-3.65-bool.patch
+}
+
+src_install() {
+ einstall || die
+
+ # This package gets a little overeager installing desktop files.
+ # Just keep the one in /usr/share/applications and the icon in
+ # /usr/share/pixmaps
+ rm -r ${D}/usr/share/{gnome,applnk,icons}
+}
diff --git a/app-office/linuxtrade/metadata.xml b/app-office/linuxtrade/metadata.xml
new file mode 100644
index 000000000000..a25cea67094a
--- /dev/null
+++ b/app-office/linuxtrade/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>agriffis@gentoo.org</email>
+</maintainer>
+<longdescription>
+Linuxtrade is a lightweight curses-based program with all the cool
+features expected from a real-time stock market trading console:
+portfolios, real time quotes, charts with live updates, time and
+sales, fundamental and technical indicators, top ten and market
+movers, news articles, alerts, option chains, the Briefing.com In Play
+and Up/Downgrades lists, earnings, splits and quiet period calendars,
+and Level 2 market depth indications from the Archipelago and the
+Island ECN's.
+</longdescription>
+</pkgmetadata>