summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-09-27 23:39:20 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-09-27 23:39:20 +0000
commit67198020b0e3811aa26a64b9901cd6738886e9c2 (patch)
tree9f4dfe16377ecf2e2870524bb870b907c6393b36 /app-office/karbon
parentVersion bump. (diff)
downloadgentoo-2-67198020b0e3811aa26a64b9901cd6738886e9c2.tar.gz
gentoo-2-67198020b0e3811aa26a64b9901cd6738886e9c2.tar.bz2
gentoo-2-67198020b0e3811aa26a64b9901cd6738886e9c2.zip
Version bump.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'app-office/karbon')
-rw-r--r--app-office/karbon/ChangeLog7
-rw-r--r--app-office/karbon/files/digest-karbon-1.6_rc13
-rw-r--r--app-office/karbon/karbon-1.6_rc1.ebuild52
3 files changed, 61 insertions, 1 deletions
diff --git a/app-office/karbon/ChangeLog b/app-office/karbon/ChangeLog
index c16abcf576a2..5d0bcf1cb962 100644
--- a/app-office/karbon/ChangeLog
+++ b/app-office/karbon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/karbon
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.44 2006/09/15 18:43:15 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.45 2006/09/27 23:39:20 carlo Exp $
+
+*karbon-1.6_rc1 (27 Sep 2006)
+
+ 27 Sep 2006; Carsten Lohrke <carlo@gentoo.org> +karbon-1.6_rc1.ebuild:
+ Version bump.
*karbon-1.6_beta1 (15 Sep 2006)
diff --git a/app-office/karbon/files/digest-karbon-1.6_rc1 b/app-office/karbon/files/digest-karbon-1.6_rc1
new file mode 100644
index 000000000000..22dfd6c9ed05
--- /dev/null
+++ b/app-office/karbon/files/digest-karbon-1.6_rc1
@@ -0,0 +1,3 @@
+MD5 2134a0d09a3f98b91a062c7bafb57622 koffice-1.5.92.tar.bz2 54676447
+RMD160 4006772a542c24132ef7b7d16ad087beb6eb76cd koffice-1.5.92.tar.bz2 54676447
+SHA256 a4df08decea688dddfeec7b47e0fb4e96bf75e1c85b72b721d315d718bae11c5 koffice-1.5.92.tar.bz2 54676447
diff --git a/app-office/karbon/karbon-1.6_rc1.ebuild b/app-office/karbon/karbon-1.6_rc1.ebuild
new file mode 100644
index 000000000000..20465f174dc1
--- /dev/null
+++ b/app-office/karbon/karbon-1.6_rc1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/karbon-1.6_rc1.ebuild,v 1.1 2006/09/27 23:39:20 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice vector drawing application."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ >=media-gfx/imagemagick-5.5.2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkopalette lib/kopalette
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/karbon"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = liboofilter karbon" > $S/filters/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}