summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-22 15:43:51 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-22 15:43:51 +0000
commit232b721f9c4abdc794c869f39b7fda518a537ef5 (patch)
tree9b7bc6f7c7efd471f2e732dcffa243e9a2591d09 /app-office/impressive
parentvanilla-3.12.8 + genpatches-3.12-9 + grsecurity-3.0-3.12.8-201401191015 (diff)
downloadgentoo-2-232b721f9c4abdc794c869f39b7fda518a537ef5.tar.gz
gentoo-2-232b721f9c4abdc794c869f39b7fda518a537ef5.tar.bz2
gentoo-2-232b721f9c4abdc794c869f39b7fda518a537ef5.zip
app-office/impressive: Version Bump, #498882
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-office/impressive')
-rw-r--r--app-office/impressive/ChangeLog10
-rw-r--r--app-office/impressive/impressive-0.10.3-r2.ebuild15
-rw-r--r--app-office/impressive/impressive-0.10.4.ebuild47
-rw-r--r--app-office/impressive/metadata.xml4
4 files changed, 65 insertions, 11 deletions
diff --git a/app-office/impressive/ChangeLog b/app-office/impressive/ChangeLog
index 86c82b051097..d042ab6e63f5 100644
--- a/app-office/impressive/ChangeLog
+++ b/app-office/impressive/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/impressive
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/ChangeLog,v 1.7 2013/06/08 15:39:32 floppym Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/ChangeLog,v 1.8 2014/01/22 15:43:51 jlec Exp $
+
+*impressive-0.10.4 (22 Jan 2014)
+
+ 22 Jan 2014; Justin Lecher <jlec@gentoo.org> impressive-0.10.3-r2.ebuild,
+ +impressive-0.10.4.ebuild, metadata.xml:
+ Version Bump, #498882
08 Jun 2013; Mike Gilbert <floppym@gentoo.org> impressive-0.10.3-r2.ebuild:
Add missing python deps.
diff --git a/app-office/impressive/impressive-0.10.3-r2.ebuild b/app-office/impressive/impressive-0.10.3-r2.ebuild
index a3dd3da8e987..bcb96b3a89f5 100644
--- a/app-office/impressive/impressive-0.10.3-r2.ebuild
+++ b/app-office/impressive/impressive-0.10.3-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/impressive-0.10.3-r2.ebuild,v 1.2 2013/06/08 15:39:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/impressive-0.10.3-r2.ebuild,v 1.3 2014/01/22 15:43:51 jlec Exp $
EAPI=5
+
PYTHON_COMPAT=( python{2_6,2_7} )
inherit eutils python-single-r1
@@ -41,11 +42,11 @@ src_install() {
dobin impressive.py
# compatibility symlinks
- dosym impressive.py /usr/bin/impressive || die
- dosym impressive.py /usr/bin/keyjnote || die
+ dosym impressive.py /usr/bin/impressive
+ dosym impressive.py /usr/bin/keyjnote
# docs
- doman impressive.1 || die
- dohtml impressive.html || die
- dodoc changelog.txt demo.pdf || die
+ doman impressive.1
+ dohtml impressive.html
+ dodoc changelog.txt demo.pdf
}
diff --git a/app-office/impressive/impressive-0.10.4.ebuild b/app-office/impressive/impressive-0.10.4.ebuild
new file mode 100644
index 000000000000..2b14eab6aba3
--- /dev/null
+++ b/app-office/impressive/impressive-0.10.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/impressive-0.10.4.ebuild,v 1.1 2014/01/22 15:43:51 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ app-text/pdftk
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ x11-misc/xdg-utils
+ x11-apps/xrandr
+ || ( app-text/xpdf app-text/ghostscript-gpl )
+ || ( media-fonts/dejavu media-fonts/ttf-bitstream-vera media-fonts/corefonts )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}.py
+
+ # compatibility symlinks
+ dosym impressive.py /usr/bin/impressive
+ dosym impressive.py /usr/bin/keyjnote
+
+ # docs
+ doman impressive.1
+ dohtml impressive.html
+ dodoc changelog.txt demo.pdf
+}
diff --git a/app-office/impressive/metadata.xml b/app-office/impressive/metadata.xml
index bee05b79a412..a5e6348a54e8 100644
--- a/app-office/impressive/metadata.xml
+++ b/app-office/impressive/metadata.xml
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <herd>sci</herd>
+ <herd>python</herd>
+ <herd>sci</herd>
</pkgmetadata>