summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-10-27 16:35:54 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-10-27 16:35:54 +0000
commitd499d4d10ab0ea48a78acdaefb1acbc868bb4980 (patch)
tree30ebc661c5fd582312313f5d7b3a3d71a3c1bc25 /app-office/imposter
parentdepend on xen-r1 ebuild (diff)
downloadgentoo-2-d499d4d10ab0ea48a78acdaefb1acbc868bb4980.tar.gz
gentoo-2-d499d4d10ab0ea48a78acdaefb1acbc868bb4980.tar.bz2
gentoo-2-d499d4d10ab0ea48a78acdaefb1acbc868bb4980.zip
after ages a new release
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'app-office/imposter')
-rw-r--r--app-office/imposter/ChangeLog8
-rw-r--r--app-office/imposter/files/digest-imposter-0.31
-rw-r--r--app-office/imposter/files/imposter-0.3-ignore-modifiers.patch22
-rw-r--r--app-office/imposter/imposter-0.3.ebuild39
4 files changed, 69 insertions, 1 deletions
diff --git a/app-office/imposter/ChangeLog b/app-office/imposter/ChangeLog
index 84cb1ea78c77..c0e44026c8df 100644
--- a/app-office/imposter/ChangeLog
+++ b/app-office/imposter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/imposter
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/imposter/ChangeLog,v 1.7 2005/01/01 15:34:25 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/imposter/ChangeLog,v 1.8 2005/10/27 16:35:54 suka Exp $
+
+*imposter-0.3 (27 Oct 2005)
+
+ 27 Oct 2005; Andreas Proschofsky <suka@gentoo.org>
+ +files/imposter-0.3-ignore-modifiers.patch, +imposter-0.3.ebuild:
+ Update to the latest release, closes bug #87889
05 Oct 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
imposter-0.2.ebuild:
diff --git a/app-office/imposter/files/digest-imposter-0.3 b/app-office/imposter/files/digest-imposter-0.3
new file mode 100644
index 000000000000..29ffc43f3c9e
--- /dev/null
+++ b/app-office/imposter/files/digest-imposter-0.3
@@ -0,0 +1 @@
+MD5 5bcaa0fe3fec26840c8f1ecefc891887 imposter-0.3.tar.gz 169592
diff --git a/app-office/imposter/files/imposter-0.3-ignore-modifiers.patch b/app-office/imposter/files/imposter-0.3-ignore-modifiers.patch
new file mode 100644
index 000000000000..022b1089d380
--- /dev/null
+++ b/app-office/imposter/files/imposter-0.3-ignore-modifiers.patch
@@ -0,0 +1,22 @@
+diff -ur imposter-0.3.orig/src/ui.c imposter-0.3/src/ui.c
+--- imposter-0.3.orig/src/ui.c 2005-04-01 16:41:44.000000000 +0300
++++ imposter-0.3/src/ui.c 2005-04-08 13:39:33.000000000 +0300
+@@ -4,6 +4,9 @@
+ ** modify it under the terms of GNU General Public License.
+ */
+
++ /* Ignore some modifier keys in keyboard handling. */
++ #define imposter_ignore_modifiers(a) ((a) &(~(GDK_LOCK_MASK|GDK_MOD2_MASK)))
++
+ #include "common.h"
+
+ static GtkWidget *menu_bar, *window, *area;
+@@ -43,7 +46,7 @@
+ char *key;
+ int i;
+
+- if (ev->state) return FALSE;
++ if (imposter_ignore_modifiers(ev->state)) return FALSE;
+ key = gdk_keyval_name (ev->keyval);
+ if (key) {
+ for (i = 0; defkeys[i].key; i++) {
diff --git a/app-office/imposter/imposter-0.3.ebuild b/app-office/imposter/imposter-0.3.ebuild
new file mode 100644
index 000000000000..0c7f9ed2bc38
--- /dev/null
+++ b/app-office/imposter/imposter-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/imposter/imposter-0.3.ebuild,v 1.1 2005/10/27 16:35:54 suka Exp $
+
+inherit eutils
+
+DESCRIPTION="Imposter is a standalone viewer for the presentations created by OpenOffice.org Impress software"
+HOMEPAGE="http://imposter.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/imposter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="iksemel"
+DEPEND="virtual/x11
+ dev-libs/atk
+ x11-libs/pango
+ dev-libs/glib
+ dev-util/pkgconfig
+ >=x11-libs/gtk+-2.4.0
+ iksemel? ( >=dev-libs/iksemel-1.2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Patch by Recai OktaÅŸ <roktas@omu.edu.tr>, backported from CVS...
+ epatch "${FILESDIR}/${P}-ignore-modifiers.patch"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}