summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-04-23 08:22:37 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-04-23 08:22:37 +0000
commit55af3bf6e00115f07f094f2204de2873a75b0b07 (patch)
tree03ca4a63ee7a163d917b28bdf1b6b876473125d1 /app-office/homebank
parentFixed compiling with gcc-4.3, thanks to Peter Alfredsen (bug #218946). (diff)
downloadgentoo-2-55af3bf6e00115f07f094f2204de2873a75b0b07.tar.gz
gentoo-2-55af3bf6e00115f07f094f2204de2873a75b0b07.tar.bz2
gentoo-2-55af3bf6e00115f07f094f2204de2873a75b0b07.zip
Version bump.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-office/homebank')
-rw-r--r--app-office/homebank/ChangeLog7
-rw-r--r--app-office/homebank/homebank-3.8.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/app-office/homebank/ChangeLog b/app-office/homebank/ChangeLog
index 8614f8195d4b..4753586fae62 100644
--- a/app-office/homebank/ChangeLog
+++ b/app-office/homebank/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/homebank
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/ChangeLog,v 1.3 2008/04/01 13:45:30 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/ChangeLog,v 1.4 2008/04/23 08:22:37 calchan Exp $
+
+*homebank-3.8 (23 Apr 2008)
+
+ 23 Apr 2008; Denis Dupeyron <calchan@gentoo.org> +homebank-3.8.ebuild:
+ Version bump.
01 Apr 2008; Denis Dupeyron <calchan@gentoo.org> homebank-3.7.ebuild:
eautoconf was enough, thanks to Tiziano Müller.
diff --git a/app-office/homebank/homebank-3.8.ebuild b/app-office/homebank/homebank-3.8.ebuild
new file mode 100644
index 000000000000..dc95d830b779
--- /dev/null
+++ b/app-office/homebank/homebank-3.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/homebank-3.8.ebuild,v 1.1 2008/04/23 08:22:37 calchan Exp $
+
+inherit autotools fdo-mime
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ofx"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=x11-libs/gtk+-2.0
+ ofx? ( >=dev-libs/libofx-0.7 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ gnome-base/librsvg"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's/-Werror//' configure.ac \
+ -e 's/LDFLAGS="${LDFLAGS} -lofx"/LIBS="${LIBS} -lofx"/' \
+ configure.ac || die "sed failed"
+
+ eautoconf
+}
+
+src_compile() {
+ econf $(use_with ofx) || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}