summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-06-03 16:22:51 +0000
committerPacho Ramos <pacho@gentoo.org>2011-06-03 16:22:51 +0000
commit0b2073d5250a093eb47bf4686d613872de7447d9 (patch)
treed5c33b9b86747d3e9fefd906638824204f1e30f0 /app-office/gnumeric
parentx86 stable per bug 369683 (diff)
downloadgentoo-2-0b2073d5250a093eb47bf4686d613872de7447d9.tar.gz
gentoo-2-0b2073d5250a093eb47bf4686d613872de7447d9.tar.bz2
gentoo-2-0b2073d5250a093eb47bf4686d613872de7447d9.zip
Version bump.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/ChangeLog7
-rw-r--r--app-office/gnumeric/gnumeric-1.10.15.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 47c010fe4ae7..248b486245aa 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnumeric
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.221 2011/03/26 21:04:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.222 2011/06/03 16:22:51 pacho Exp $
+
+*gnumeric-1.10.15 (03 Jun 2011)
+
+ 03 Jun 2011; Pacho Ramos <pacho@gentoo.org> +gnumeric-1.10.15.ebuild:
+ Version bump.
*gnumeric-1.10.14 (26 Mar 2011)
diff --git a/app-office/gnumeric/gnumeric-1.10.15.ebuild b/app-office/gnumeric/gnumeric-1.10.15.ebuild
new file mode 100644
index 000000000000..ce2b699a5b4a
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.10.15.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.10.15.ebuild,v 1.1 2011/06/03 16:22:51 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="python? 2:2.4"
+
+inherit gnome2 flag-o-matic python
+
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+HOMEPAGE="http://projects.gnome.org/gnumeric/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="gnome perl python"
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, wait for next release
+# also fails tests due to 80-bit long story
+RESTRICT="test"
+
+RDEPEND="sys-libs/zlib
+ app-arch/bzip2
+ >=dev-libs/glib-2.12:2
+ >=gnome-extra/libgsf-1.14.19[gnome?]
+ >=x11-libs/goffice-0.8.15:0.8
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.12
+
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/cairo[svg]
+
+ gnome? (
+ >=gnome-base/gconf-2:2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libbonoboui-2.2 )
+ perl? ( dev-lang/perl )
+ python? ( >=dev-python/pygtk-2:2 )
+"
+# libgda? (
+# >=gnome-extra/libgda-4.1.1:4.0
+# >=gnome-extra/libgnomedb-3.99.6:4.0 )
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ >=dev-util/pkgconfig-0.18
+ app-text/scrollkeeper"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-ssindex
+ --disable-static
+ --without-gda
+ --with-zlib
+ $(use_with perl)
+ $(use_with python)
+ $(use_with gnome)"
+ DOCS="AUTHORS BEVERAGES BUGS ChangeLog HACKING MAINTAINERS NEWS README"
+ use python && python_set_active_version 2
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+}