summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-06-07 12:18:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-06-07 12:18:32 +0000
commit53ed5ca5dbd783dc7e07cf0c2d35b01c42b3eec5 (patch)
tree4a422e6a47150df5df0c61a90da846bb6d1a7a99 /app-office/gnotime
parentRemoved old versions. (diff)
downloadgentoo-2-53ed5ca5dbd783dc7e07cf0c2d35b01c42b3eec5.tar.gz
gentoo-2-53ed5ca5dbd783dc7e07cf0c2d35b01c42b3eec5.tar.bz2
gentoo-2-53ed5ca5dbd783dc7e07cf0c2d35b01c42b3eec5.zip
Fix column descriptions, bug #222325.
(Portage version: 2.1.5.4)
Diffstat (limited to 'app-office/gnotime')
-rw-r--r--app-office/gnotime/ChangeLog8
-rw-r--r--app-office/gnotime/files/gnotime-2.3.0-fix-columns.patch12
-rw-r--r--app-office/gnotime/gnotime-2.3.0-r2.ebuild53
3 files changed, 72 insertions, 1 deletions
diff --git a/app-office/gnotime/ChangeLog b/app-office/gnotime/ChangeLog
index a99f9078f9f6..fc4a2724082d 100644
--- a/app-office/gnotime/ChangeLog
+++ b/app-office/gnotime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnotime
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnotime/ChangeLog,v 1.41 2008/04/05 13:58:20 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnotime/ChangeLog,v 1.42 2008/06/07 12:18:31 eva Exp $
+
+*gnotime-2.3.0-r2 (07 Jun 2008)
+
+ 07 Jun 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gnotime-2.3.0-fix-columns.patch, +gnotime-2.3.0-r2.ebuild:
+ Fix column descriptions, bug #222325.
*gnotime-2.3.0-r1 (05 Apr 2008)
diff --git a/app-office/gnotime/files/gnotime-2.3.0-fix-columns.patch b/app-office/gnotime/files/gnotime-2.3.0-fix-columns.patch
new file mode 100644
index 000000000000..2b4b3ce9f232
--- /dev/null
+++ b/app-office/gnotime/files/gnotime-2.3.0-fix-columns.patch
@@ -0,0 +1,12 @@
+diff -Naur work.old/gnotime-2.3.0/src/projects-tree.c work/gnotime-2.3.0/src/projects-tree.c
+--- work.old/gnotime-2.3.0/src/projects-tree.c 2008-01-23 18:50:29.000000000 +0200
++++ work/gnotime-2.3.0/src/projects-tree.c 2008-03-10 15:53:47.000000000 +0200
+@@ -266,7 +266,7 @@
+ priv->column_definitions[8].default_width = 72;
+
+ priv->column_definitions[9].name = "description";
+- priv->column_definitions[9].model_column = TITLE_COLUMN;
++ priv->column_definitions[9].model_column = DESCRIPTION_COLUMN;
+ priv->column_definitions[9].renderer = priv->text_renderer;
+ priv->column_definitions[9].value_property_name = "text";
+ priv->column_definitions[9].label = _("Description");
diff --git a/app-office/gnotime/gnotime-2.3.0-r2.ebuild b/app-office/gnotime/gnotime-2.3.0-r2.ebuild
new file mode 100644
index 000000000000..d392a6c7f94c
--- /dev/null
+++ b/app-office/gnotime/gnotime-2.3.0-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnotime/gnotime-2.3.0-r2.ebuild,v 1.1 2008/06/07 12:18:31 eva Exp $
+
+EAPI="1"
+
+inherit eutils gnome2
+
+DESCRIPTION="utility to track time spent on activities"
+HOMEPAGE="http://gttr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gttr/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14
+ >=gnome-base/libgnome-2.0
+ >=gnome-base/libgnomeui-2.0.3
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libglade-2.0
+ >=gnome-extra/gtkhtml-3.14.3:3.14
+ >=gnome-base/gconf-2.0
+ dev-libs/libxml2
+ >=dev-libs/dbus-glib-0.74
+ dev-scheme/guile
+ dev-libs/qof
+ x11-libs/libXScrnSaver
+ x11-libs/pango"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ >=app-text/scrollkeeper-0.3.11
+ doc? ( ~app-text/docbook-xml-dtd-4.2 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-schemas-install"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # man generation needs docbook-xml-dtd
+ use doc || sed -i -e "s/SUBDIRS = man/SUBDIRS = /" doc/C/Makefile.{in,am}
+
+ # Fix column descriptions, bug #222325
+ epatch "${FILESDIR}/${P}-fix-columns.patch"
+}