summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-08 21:33:46 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-08 21:33:46 +0000
commitb7fbea2f6c7100f41d4972778cfd67306139a00b (patch)
tree3aaf2d34444dec569a5fffcc3e9b403be439acf3 /app-office/akonadi-server
parentVersion bump, related to bug #297465 (diff)
downloadgentoo-2-b7fbea2f6c7100f41d4972778cfd67306139a00b.tar.gz
gentoo-2-b7fbea2f6c7100f41d4972778cfd67306139a00b.tar.bz2
gentoo-2-b7fbea2f6c7100f41d4972778cfd67306139a00b.zip
[/home/alexxy/gentoo-x86/app-office/akonadi-server] Version bump
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'app-office/akonadi-server')
-rw-r--r--app-office/akonadi-server/ChangeLog8
-rw-r--r--app-office/akonadi-server/akonadi-server-1.3.0.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index 4f0dbea61fc7..eaf1823a6a81 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.30 2010/01/20 07:30:26 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.31 2010/02/08 21:33:46 alexxy Exp $
+
+*akonadi-server-1.3.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org>
+ +akonadi-server-1.3.0.ebuild:
+ Version bump
20 Jan 2010; Jonathan Callen <abcd@gentoo.org>
akonadi-server-1.2.1.ebuild:
diff --git a/app-office/akonadi-server/akonadi-server-1.3.0.ebuild b/app-office/akonadi-server/akonadi-server-1.3.0.ebuild
new file mode 100644
index 000000000000..3f422f2f4560
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.3.0.ebuild,v 1.1 2010/02/08 21:33:46 alexxy Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="http://pim.kde.org/akonadi"
+SRC_URI="http://download.akonadi-project.org/${P/-server/}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="+mysql postgres sqlite"
+
+RDEPEND="
+ dev-libs/boost
+ >=dev-libs/soprano-2.2
+ >=x11-libs/qt-gui-4.5.0:4[dbus]
+ >=x11-libs/qt-sql-4.5.0:4[mysql?,postgres?,sqlite?]
+ x11-misc/shared-mime-info
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=kde-base/automoc-0.9.88
+"
+
+S="${WORKDIR}/${P/-server/}"
+
+src_install() {
+ # Set default storage backend in order: MySQL, PostgreSQL, SQLite
+ if use mysql; then
+ driver="QMYSQL"
+ elif use postgres; then
+ driver="QPSQL"
+ elif use sqlite; then
+ driver="QSQLITE"
+ fi
+ # Who knows, maybe it accidentally fixes our permission issues
+ mkdir -p "${D}"/usr/share/config/akonadi || die "mkdir failed"
+ cat <<-EOF > "${D}"/usr/share/config/akonadi/akonadiserverrc
+[%General]
+Driver=${driver}
+EOF
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ if use mysql || use postgres || use sqlite; then
+ local func=elog
+ ( use postgres || use sqlite ) && func=ewarn
+ echo
+ ${func} "${driver} has been set as your default akonadi storage backend."
+ ${func} "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ ${func} "Available drivers are:"
+ ${func} "QMYSQL, QPSQL (testing), QSQLITE (experimental)"
+ ${func} "Be advised that QMYSQL is the one fully tested and officially supported."
+ use sqlite && ewarn "If you experience random data losses using QSQLITE driver, you have been warned."
+ echo
+ else
+ echo
+ ewarn "You have decided to build akonadi-server with"
+ ewarn "'mysql', 'postgres' and 'sqlite' USE flags disabled."
+ ewarn "akonadi-server will not be functional."
+ echo
+ fi
+}