summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-12-12 22:27:26 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-12-12 22:27:26 +0000
commitde5c5396a42de4fdcdc5716749de55c2100f05c8 (patch)
tree142987ca082ace0fc14df95d587c8243dced3dd0 /app-office/abiword
parentversion bump (diff)
downloadgentoo-2-de5c5396a42de4fdcdc5716749de55c2100f05c8.tar.gz
gentoo-2-de5c5396a42de4fdcdc5716749de55c2100f05c8.tar.bz2
gentoo-2-de5c5396a42de4fdcdc5716749de55c2100f05c8.zip
rev bump to fix bug #157804
(Portage version: 2.1.2_rc3-r2)
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/ChangeLog9
-rw-r--r--app-office/abiword/abiword-2.4.5-r1.ebuild89
-rw-r--r--app-office/abiword/files/11_history_fullpath.dpatch73
-rw-r--r--app-office/abiword/files/16_fcfini_crash.dpatch26
-rw-r--r--app-office/abiword/files/digest-abiword-2.4.5-r13
5 files changed, 199 insertions, 1 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index eb409463d526..c35e39f2df84 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.161 2006/10/15 01:46:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.162 2006/12/12 22:27:26 compnerd Exp $
+
+*abiword-2.4.5-r1 (12 Dec 2006)
+
+ 12 Dec 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/11_history_fullpath.dpatch, +files/16_fcfini_crash.dpatch,
+ +abiword-2.4.5-r1.ebuild:
+ Add patches from debian to a revbump to fix bug #157804
15 Oct 2006; Aron Griffis <agriffis@gentoo.org> -abiword-2.2.10.ebuild,
-abiword-2.4.1.ebuild, -abiword-2.4.2.ebuild, -abiword-2.4.2-r1.ebuild:
diff --git a/app-office/abiword/abiword-2.4.5-r1.ebuild b/app-office/abiword/abiword-2.4.5-r1.ebuild
new file mode 100644
index 000000000000..b5eed807633a
--- /dev/null
+++ b/app-office/abiword/abiword-2.4.5-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.4.5-r1.ebuild,v 1.1 2006/12/12 22:27:26 compnerd Exp $
+
+inherit eutils fdo-mime alternatives
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gnome spell xml"
+
+RDEPEND="virtual/xft
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2.4
+ >=x11-libs/pango-1.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ sys-libs/zlib
+ >=media-libs/libpng-1.2
+ dev-libs/popt
+ >=media-libs/fontconfig-2.1
+ >=app-text/wv-1
+ >=dev-libs/fribidi-0.10.4
+ xml? ( >=dev-libs/libxml2-2.4.10 )
+ !xml? ( dev-libs/expat )
+ spell? ( >=app-text/enchant-1.1 )
+ gnome? (
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-extra/gucharmap-1.4 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+S=${WORKDIR}/${P}/abi
+
+src_compile() {
+ # Patch taken from debian to use full path for file history
+ epatch ${FILESDIR}/11_history_fullpath.dpatch
+
+ # Patch taken from debian to prevent crash on exit
+ epatch ${FILESDIR}/16_fcfini_crash.dpatch
+
+ # this is a hack since I don't want to go hack in the gnome-vfs
+ # headerfiles. The issue is about gnome-vfs containing "long long"
+ # which makes gcc 3.3.1 balk
+ sed -i -e 's:-pedantic::g' configure
+
+ local myconf="$(use_enable gnome) \
+ $(use_enable gnome gucharmap) \
+ $(use_enable spell enchant) \
+ $(use_enable debug) \
+ $(use_with xml libxml2) \
+ --enable-threads \
+ --disable-scripting \
+ --with-sys-wv"
+
+ econf $myconf || die "./configure failed"
+
+ emake all-recursive || die "Compilation failed"
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dosed "s:Exec=abiword:Exec=abiword-2.4:" /usr/share/applications/abiword.desktop
+
+ rm -f ${D}/usr/bin/abiword-2.4
+ rm -f ${D}/usr/bin/abiword
+ dosym AbiWord-2.4 /usr/bin/abiword-2.4
+
+ dodoc *.TXT docs/build/BUILD.TXT user/wp/readme.txt
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ alternatives_auto_makesym "/usr/bin/abiword" "/usr/bin/abiword-[0-9].[0-9]"
+
+ einfo "As of version 2.4, all abiword plugins have been moved"
+ einfo "into a seperate abiword-plugins package"
+ einfo "You can install them by running emerge abiword-plugins"
+}
diff --git a/app-office/abiword/files/11_history_fullpath.dpatch b/app-office/abiword/files/11_history_fullpath.dpatch
new file mode 100644
index 000000000000..059dac6cc2ab
--- /dev/null
+++ b/app-office/abiword/files/11_history_fullpath.dpatch
@@ -0,0 +1,73 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 11_history_fullpath.dpatch by Joshua Kwan <joshk@triplehelix.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Store absolute paths, however gnarly, into history, when relative file
+## DP: paths are used on the command line.
+
+--- abiword-2.2.0/abi/src/wp/ap/xp/ap_App.cpp~ 2004-11-23 02:02:17.000000000 -0800
++++ abiword-2.2.0/abi/src/wp/ap/xp/ap_App.cpp 2004-11-23 02:02:04.000000000 -0800
+@@ -18,6 +18,8 @@
+ * 02111-1307, USA.
+ */
+
++#include <limits.h>
++
+ #include "ap_Features.h"
+ #include "ap_App.h"
+ #include "ap_Args.h"
+@@ -50,13 +50,45 @@
+ {
+ int kWindowsOpened = 0;
+ const char *file = NULL;
++
++#ifdef WIN32
++# define arch_separator '\\'
++#else
++# define arch_separator '/'
++#endif
++ char cwd[PATH_MAX];
+ poptContext poptcon = args->poptcon;
++
++ getcwd(cwd, PATH_MAX);
+
+ while ((file = poptGetArg (poptcon)) != NULL) {
+ XAP_Frame * pFrame = newFrame();
++ char* fullpath = NULL;
++
++ if (*file != arch_separator)
++ {
++ size_t file_len = strlen(file);
++#ifdef WIN32
++ if (file_len > 1 && (file[1] != ':' || !(file[0] != '\\' && file[1] != '\\'))) /* check for C:\Blah.doc and \\share\Blah.doc */
++#endif
++ {
++ size_t len = strlen(cwd) + file_len + 2; /* C/F + NUL */
++ fullpath = (char*)malloc(len);
++
++ /* First, resolve the path into an absolute one as best as we can */
++ snprintf(fullpath, len, "%s%c%s", cwd, arch_separator, file);
++ }
++ }
+
+ UT_Error error = pFrame->loadDocument
+- (file, IEFT_Unknown, true);
++ (fullpath ? fullpath : file, IEFT_Unknown, true);
++
++ if (fullpath != NULL)
++ {
++ free (fullpath);
++ fullpath = NULL;
++ }
++
+ if (!error)
+ {
+ kWindowsOpened++;
+@@ -74,6 +106,7 @@
+ pFrame->loadDocument(NULL, IEFT_Unknown);
+ pFrame->raise();
+
++ /* OK to use relative path here. We get it */
+ errorMsgBadFile (pFrame, file, error);
+ }
+
diff --git a/app-office/abiword/files/16_fcfini_crash.dpatch b/app-office/abiword/files/16_fcfini_crash.dpatch
new file mode 100644
index 000000000000..73b9d895caab
--- /dev/null
+++ b/app-office/abiword/files/16_fcfini_crash.dpatch
@@ -0,0 +1,26 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 16_fcfini_crash.dpatch by Joshua Kwan <joshk@triplehelix.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+Index: xap_UnixApp.cpp
+===================================================================
+RCS file: /cvsroot/abi/src/af/xap/unix/xap_UnixApp.cpp,v
+retrieving revision 1.102.2.1
+retrieving revision 1.102.2.2
+diff -u -r1.102.2.1 -r1.102.2.2
+--- a/abi/src/af/xap/unix/xap_UnixApp.cpp 12 May 2006 20:40:11 -0000 1.102.2.1
++++ b/abi/src/af/xap/unix/xap_UnixApp.cpp 15 Sep 2006 22:53:03 -0000 1.102.2.2
+@@ -134,10 +134,6 @@
+ DELETEP(m_pUnixToolbarIcons);
+
+ delete m_fontManager;
+-
+-#if FC_MINOR > 2
+- FcFini();
+-#endif
+ }
+
+ bool XAP_UnixApp::initialize(const char * szKeyBindingsKey, const char * szKeyBindingsDefaultValue)
diff --git a/app-office/abiword/files/digest-abiword-2.4.5-r1 b/app-office/abiword/files/digest-abiword-2.4.5-r1
new file mode 100644
index 000000000000..92a5bbc12741
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-2.4.5-r1
@@ -0,0 +1,3 @@
+MD5 e018669a154164d31c768f773a1c95b4 abiword-2.4.5.tar.bz2 24930028
+RMD160 f0de27f97135f8fff9b4400b05d74a27eee348cd abiword-2.4.5.tar.bz2 24930028
+SHA256 b8e5f61697c6d796e8f9f0812886666487fd0125bc777ca093c096b4b3e31264 abiword-2.4.5.tar.bz2 24930028