summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-03-23 09:32:05 +0000
committerAlin Năstac <mrness@gentoo.org>2007-03-23 09:32:05 +0000
commit6f633e361f99dcac62e7cf2a46dcf2fc208e0ae0 (patch)
tree5b5feb59ce4c235b7fa6538c1efda53aa4d644ad /app-mobilephone
parentVersion bump. (diff)
downloadgentoo-2-6f633e361f99dcac62e7cf2a46dcf2fc208e0ae0.tar.gz
gentoo-2-6f633e361f99dcac62e7cf2a46dcf2fc208e0ae0.tar.bz2
gentoo-2-6f633e361f99dcac62e7cf2a46dcf2fc208e0ae0.zip
Version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gammu/ChangeLog7
-rw-r--r--app-mobilephone/gammu/files/digest-gammu-1.10.03
-rw-r--r--app-mobilephone/gammu/gammu-1.10.0.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index 4d7694610703..7261c6a4a11d 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/gammu
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.32 2007/01/14 15:00:12 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.33 2007/03/23 09:32:05 mrness Exp $
+
+*gammu-1.10.0 (23 Mar 2007)
+
+ 23 Mar 2007; Alin Năstac <mrness@gentoo.org> +gammu-1.10.0.ebuild:
+ Version bump.
14 Jan 2007; Alin Năstac <mrness@gentoo.org>
-files/gammu-1.05.00-backup-limits.patch,
diff --git a/app-mobilephone/gammu/files/digest-gammu-1.10.0 b/app-mobilephone/gammu/files/digest-gammu-1.10.0
new file mode 100644
index 000000000000..132cdd0def8c
--- /dev/null
+++ b/app-mobilephone/gammu/files/digest-gammu-1.10.0
@@ -0,0 +1,3 @@
+MD5 05b623c30cfd69ea97f0bc054b19928d gammu-1.10.0.tar.bz2 889856
+RMD160 d17c5595782fde59c9b5f91bd4820fa01924979e gammu-1.10.0.tar.bz2 889856
+SHA256 91062db1fd62095bdda21782e076157a343e0181e684738c2edbfff5fc860f64 gammu-1.10.0.tar.bz2 889856
diff --git a/app-mobilephone/gammu/gammu-1.10.0.ebuild b/app-mobilephone/gammu/gammu-1.10.0.ebuild
new file mode 100644
index 000000000000..2ea374178b33
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.10.0.ebuild,v 1.1 2007/03/23 09:32:05 mrness Exp $
+
+DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
+HOMEPAGE="http://www.gammu.org"
+SRC_URI="ftp://dl.cihar.com/gammu/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="debug bluetooth irda mysql"
+
+RDEPEND="bluetooth? ( net-wireless/bluez-libs )
+ mysql? ( virtual/mysql )"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )"
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ use bluetooth && myconf="${myconf} --with-bluedir=/usr/lib" \
+ || myconf="${myconf} --disable-bluetooth"
+ use mysql || myconf="${myconf} --disable-mysql"
+ use irda || myconf="${myconf} --disable-irda"
+ econf \
+ --prefix=/usr \
+ --enable-cb \
+ --enable-7110incoming \
+ ${myconf} || die "configure failed"
+
+ emake shared || die "make failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" installshared || die "install failed"
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${P}"
+}