summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-09-16 20:16:50 +0000
committerAlin Năstac <mrness@gentoo.org>2009-09-16 20:16:50 +0000
commit8c7d42b6a68d80e8ca8c839007d24740f9c6537d (patch)
tree32e2b319d2d4d3363eebae02495d3dec74ff11d3 /app-mobilephone/kannel
parentCheck if old-style pid-file is present, remove ipv6 setting in default config... (diff)
downloadgentoo-2-8c7d42b6a68d80e8ca8c839007d24740f9c6537d.tar.gz
gentoo-2-8c7d42b6a68d80e8ca8c839007d24740f9c6537d.tar.bz2
gentoo-2-8c7d42b6a68d80e8ca8c839007d24740f9c6537d.zip
Create ssl cert in --config phase (#285152).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone/kannel')
-rw-r--r--app-mobilephone/kannel/ChangeLog5
-rw-r--r--app-mobilephone/kannel/kannel-1.4.3.ebuild30
2 files changed, 28 insertions, 7 deletions
diff --git a/app-mobilephone/kannel/ChangeLog b/app-mobilephone/kannel/ChangeLog
index 894b568728ab..0ed16cda3de2 100644
--- a/app-mobilephone/kannel/ChangeLog
+++ b/app-mobilephone/kannel/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-mobilephone/kannel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/ChangeLog,v 1.18 2009/03/01 16:04:24 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/ChangeLog,v 1.19 2009/09/16 20:16:50 mrness Exp $
+
+ 16 Sep 2009; Alin Năstac <mrness@gentoo.org> kannel-1.4.3.ebuild:
+ Create ssl cert in --config phase (#285152).
*kannel-1.4.3 (01 Mar 2009)
diff --git a/app-mobilephone/kannel/kannel-1.4.3.ebuild b/app-mobilephone/kannel/kannel-1.4.3.ebuild
index 0d983ab4bf58..fcdd6d3d1d78 100644
--- a/app-mobilephone/kannel/kannel-1.4.3.ebuild
+++ b/app-mobilephone/kannel/kannel-1.4.3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/kannel-1.4.3.ebuild,v 1.1 2009/03/01 16:04:24 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/kannel-1.4.3.ebuild,v 1.2 2009/09/16 20:16:50 mrness Exp $
EAPI="2"
WANT_AUTOMAKE=none
-inherit eutils autotools flag-o-matic
+inherit eutils autotools flag-o-matic ssl-cert
DESCRIPTION="Powerful SMS and WAP gateway"
HOMEPAGE="http://www.kannel.org/"
@@ -39,10 +39,7 @@ pkg_setup() {
enewuser kannel -1 -1 /var/log/kannel kannel
}
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-custom-wap-ports.patch"
epatch "${FILESDIR}/${P}-nolex.patch" # flex is not used
epatch "${FILESDIR}/${P}-external-libuuid.patch"
@@ -95,3 +92,24 @@ src_install() {
newinitd "${FILESDIR}/kannel-initd" kannel
newconfd "${FILESDIR}/kannel-confd" kannel
}
+
+pkg_postinst() {
+ if use ssl; then
+ elog "SSL certificate can be created by running"
+ elog " emerge --config =${CATEGORY}/${PF}"
+ fi
+}
+
+pkg_config() {
+ if use ssl; then
+ if install_cert /etc/kannel/cert; then
+ chown kannel "${ROOT}"etc/kannel/cert.pem
+ einfo "For using this certificate, you have to add following line to your kannel.conf:"
+ einfo ' ssl-certkey-file = "/etc/kannel/cert.pem"'
+ einfo "You can safely remove cert.{key,crt,csr} files, these are not used by kannel."
+ fi
+ else
+ eerror "This phase exists only for creating kannel SSL certificate"
+ eerror "and ssl USE flag is disabled for this package!"
+ fi
+}