summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-01-07 13:07:11 +0000
committerAlin Năstac <mrness@gentoo.org>2006-01-07 13:07:11 +0000
commitba28e1f7f6c02c13f5762d3e1643fb6879fc804d (patch)
tree5ba5aa4f402824d1e86cc3dabab193099f7f3b19 /app-mobilephone/gammu/gammu-1.04.0-r1.ebuild
parentunmask conky-1.3.5 - dependencies are sparc happy (diff)
downloadgentoo-2-ba28e1f7f6c02c13f5762d3e1643fb6879fc804d.tar.gz
gentoo-2-ba28e1f7f6c02c13f5762d3e1643fb6879fc804d.tar.bz2
gentoo-2-ba28e1f7f6c02c13f5762d3e1643fb6879fc804d.zip
Ebuild redesign imposed by upstream changes (#118074). The new ebuild don't add --enable-6210calendar to configure line since it forces gammu to use Nokia 6210 frames for calendar, frames that are incompatible with other models (#117350).
(Portage version: 2.0.53)
Diffstat (limited to 'app-mobilephone/gammu/gammu-1.04.0-r1.ebuild')
-rw-r--r--app-mobilephone/gammu/gammu-1.04.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-mobilephone/gammu/gammu-1.04.0-r1.ebuild b/app-mobilephone/gammu/gammu-1.04.0-r1.ebuild
new file mode 100644
index 000000000000..dd3d2639b219
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.04.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.04.0-r1.ebuild,v 1.1 2006/01/07 13:07:11 mrness Exp $
+
+inherit eutils
+
+MY_MAJOR_VER=${PV:0:3}
+
+DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
+SRC_URI="http://www.mwiacek.com/zips/gsm/${PN}/stable/${MY_MAJOR_VER/./_}x/${P}.tar.gz"
+HOMEPAGE="http://www.gammu.net/projects/gammu.php"
+
+IUSE="debug bluetooth irda mysql"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="bluetooth? ( net-wireless/bluez-libs )
+ mysql? ( dev-db/mysql )"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-devfunc-sock.patch
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ use bluetooth && myconf="${myconf} --with-bluedir=/usr/lib" \
+ || myconf="${myconf} --disable-bluetooth"
+ use mysql || myconf="${myconf} --disable-mysql"
+ use irda || myconf="${myconf} --disable-irda"
+ econf \
+ --prefix=/usr \
+ --enable-cb \
+ --enable-7110incoming \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ make "DESTDIR=${D}" install || die "install failed"
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${P}"
+}