summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-06-28 17:51:45 +0000
committerAlin Năstac <mrness@gentoo.org>2006-06-28 17:51:45 +0000
commit06f2f2f77714fa0d754c2b78e93b26d8270d0aa2 (patch)
tree7a7a4381a17f07cab4f16971481c11cb7bfcb0a2 /app-mobilephone/bemused
parentadd patch to fix compilation on non-mips arches where linux-mips tree headers... (diff)
downloadgentoo-2-06f2f2f77714fa0d754c2b78e93b26d8270d0aa2.tar.gz
gentoo-2-06f2f2f77714fa0d754c2b78e93b26d8270d0aa2.tar.bz2
gentoo-2-06f2f2f77714fa0d754c2b78e93b26d8270d0aa2.zip
Fix compilation errors on gcc-4.1 (#138368).
(Portage version: 2.1-r1)
Diffstat (limited to 'app-mobilephone/bemused')
-rw-r--r--app-mobilephone/bemused/ChangeLog6
-rw-r--r--app-mobilephone/bemused/bemused-1.73.ebuild10
-rw-r--r--app-mobilephone/bemused/files/bemused-1.73-gcc41.patch29
3 files changed, 43 insertions, 2 deletions
diff --git a/app-mobilephone/bemused/ChangeLog b/app-mobilephone/bemused/ChangeLog
index 48d09ceddebf..aaf7dd9552b5 100644
--- a/app-mobilephone/bemused/ChangeLog
+++ b/app-mobilephone/bemused/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-mobilephone/bemused
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bemused/ChangeLog,v 1.3 2006/05/05 14:37:10 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bemused/ChangeLog,v 1.4 2006/06/28 17:51:45 mrness Exp $
+
+ 28 Jun 2006; Alin Nastac <mrness@gentoo.org>
+ +files/bemused-1.73-gcc41.patch, bemused-1.73.ebuild:
+ Fix compilation errors on gcc-4.1 (#138368).
05 May 2006; Jon Hood <squinky86@gentoo.org> bemused-1.73.ebuild:
Add ~amd64, #108312.
diff --git a/app-mobilephone/bemused/bemused-1.73.ebuild b/app-mobilephone/bemused/bemused-1.73.ebuild
index f710363419d3..fd94bd53cdb9 100644
--- a/app-mobilephone/bemused/bemused-1.73.ebuild
+++ b/app-mobilephone/bemused/bemused-1.73.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bemused/bemused-1.73.ebuild,v 1.3 2006/05/05 14:37:10 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bemused/bemused-1.73.ebuild,v 1.4 2006/06/28 17:51:45 mrness Exp $
+
+inherit eutils
MY_P=${PN}linuxserver-${PV/./_}
@@ -18,6 +20,12 @@ S="${WORKDIR}/${PN}linuxserver${PV}"
DEPEND="media-sound/xmms
net-wireless/bluez-libs"
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+}
+
src_install() {
dobin bemusedlinuxserver
insinto /etc
diff --git a/app-mobilephone/bemused/files/bemused-1.73-gcc41.patch b/app-mobilephone/bemused/files/bemused-1.73-gcc41.patch
new file mode 100644
index 000000000000..a927754eb72a
--- /dev/null
+++ b/app-mobilephone/bemused/files/bemused-1.73-gcc41.patch
@@ -0,0 +1,29 @@
+diff -Nru bemusedlinuxserver1.73.orig/BemusedServerDlg.h bemusedlinuxserver1.73/BemusedServerDlg.h
+--- bemusedlinuxserver1.73.orig/BemusedServerDlg.h 2004-05-01 17:24:32.000000000 +0300
++++ bemusedlinuxserver1.73/BemusedServerDlg.h 2006-06-28 20:47:58.812926250 +0300
+@@ -63,11 +63,11 @@
+ void HandleBluetooth();
+
+ bool CheckWinamp(const char* aWindowName);
+- bool CBemusedServerDlg::ReadFile(int handle,char* buffer,int maxbytes,long unsigned int* bytesread,int* bla);
+- bool CBemusedServerDlg::ReadFile(int handle,unsigned char* buffer,int maxbytes,long unsigned int* bytesread,int* bla);
+- bool CBemusedServerDlg::WriteFile(int handle, char* buffer,int maxbytes, long unsigned int* byteswritten,int* bla);
+- bool CBemusedServerDlg::WriteFile(int handle,unsigned char* buffer,int maxbytes, long unsigned int* byteswritten,int* bla);
+- char* CBemusedServerDlg::GetLastError();
++ bool ReadFile(int handle,char* buffer,int maxbytes,long unsigned int* bytesread,int* bla);
++ bool ReadFile(int handle,unsigned char* buffer,int maxbytes,long unsigned int* bytesread,int* bla);
++ bool WriteFile(int handle, char* buffer,int maxbytes, long unsigned int* byteswritten,int* bla);
++ bool WriteFile(int handle,unsigned char* buffer,int maxbytes, long unsigned int* byteswritten,int* bla);
++ char* GetLastError();
+
+ void WriteListToPhone();
+ void WriteDirectoryListToPhone();
+@@ -99,7 +99,7 @@
+ void FadeOut();
+ void ReadIniFile();
+
+- void CBemusedServerDlg::AddBookmarks(CDirTreeNode* aNode, CDirTreeNode* pNode, bool aRecursive);
++ void AddBookmarks(CDirTreeNode* aNode, CDirTreeNode* pNode, bool aRecursive);
+ void GenerateFileList(const char* aRoot, bool aRecursive);
+ void ReadDir(char* aDir, CDirTreeNode* aNode, bool aRecursive);
+ bool WriteNodeToBuffer(CDirTreeNode* aNode, unsigned char*& aBufferPtr, int& aSizeRemaining);