summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-04-25 18:54:25 +0000
committerJeroen Roovers <jer@gentoo.org>2012-04-25 18:54:25 +0000
commitdfe66e3b8d2c37689129495775ad5236d52a4caa (patch)
tree24f0da280f5a3e718177380a550b59c93c282021 /app-misc
parentarm stable, bug #412985 (diff)
downloadgentoo-2-dfe66e3b8d2c37689129495775ad5236d52a4caa.tar.gz
gentoo-2-dfe66e3b8d2c37689129495775ad5236d52a4caa.tar.bz2
gentoo-2-dfe66e3b8d2c37689129495775ad5236d52a4caa.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/nut/ChangeLog8
-rw-r--r--app-misc/nut/files/nut-17.7-makefile.patch69
-rw-r--r--app-misc/nut/nut-17.7.ebuild45
3 files changed, 121 insertions, 1 deletions
diff --git a/app-misc/nut/ChangeLog b/app-misc/nut/ChangeLog
index e1ca418865f1..30014e625115 100644
--- a/app-misc/nut/ChangeLog
+++ b/app-misc/nut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/nut
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.36 2012/03/13 11:21:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.37 2012/04/25 18:54:25 jer Exp $
+
+*nut-17.7 (25 Apr 2012)
+
+ 25 Apr 2012; Jeroen Roovers <jer@gentoo.org> +nut-17.7.ebuild,
+ +files/nut-17.7-makefile.patch:
+ Version bump.
*nut-17.5 (13 Mar 2012)
diff --git a/app-misc/nut/files/nut-17.7-makefile.patch b/app-misc/nut/files/nut-17.7-makefile.patch
new file mode 100644
index 000000000000..309d229395f2
--- /dev/null
+++ b/app-misc/nut/files/nut-17.7-makefile.patch
@@ -0,0 +1,69 @@
+--- Makefile.org 2012-04-24 19:13:25.000000000 +0200
++++ Makefile 2012-04-25 20:45:25.721953488 +0200
+@@ -8,15 +8,6 @@
+ EXECUTABLE := nut
+ LIBS := -lm
+
+-FLTK_CONFIG := $(shell fltk-config --version 2>/dev/null)
+-ifeq ($(FLTK_CONFIG),)
+-HAVE_FLTK = 0
+-FLTK_NUT =
+-else
+-HAVE_FLTK = 1
+-FLTK_NUT = fltk/Nut
+-endif
+-
+ OS := $(shell uname -s)
+ ifeq ($(OS),HP-UX)
+ CC = cc
+@@ -25,7 +16,7 @@
+ OPT = -O1
+ endif
+
+-CFLAGS := $(OPT) -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR)
++CFLAGS += -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR)
+ ifeq ($(CC),gcc)
+ CFLAGS += $(OPT) -Wall -fno-inline -ansi
+ endif
+@@ -38,7 +29,7 @@
+ all: nut $(FLTK_NUT)
+
+ nut: $(OBJS)
+- $(CC) $(OPT) -o $(EXECUTABLE) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(EXECUTABLE) $(OBJS) $(LIBS)
+
+ ifeq ($(HAVE_FLTK),1)
+ $(FLTK_NUT):
+--- fltk/Makefile.org 2012-04-24 19:13:01.000000000 +0200
++++ fltk/Makefile 2012-04-25 20:48:45.668679700 +0200
+@@ -5,7 +5,7 @@
+ NUTDIR := \".nutdb\"
+ FOODDIR := \"$(libdir)\"
+ EXECUTABLE := Nut
+-LIBS := `fltk-config --ldflags`
++LIBS := $(shell fltk-config --ldflags)
+
+ OS := $(shell uname -s)
+ ifeq ($(OS),HP-UX)
+@@ -16,11 +16,7 @@
+ OPT = -Os
+ endif
+
+-CFLAGS := -I.. `fltk-config --optim --cflags` $(OPT) -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR)
+-
+-ifeq ($(CXX),g++)
+-CFLAGS := -I.. `fltk-config --optim --cflags` -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR) -Wall -fno-inline -ansi
+-endif
++CFLAGS := -I.. $(shell fltk-config --optim --cflags) $(OPT) -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR) -Wall -fno-inline -ansi
+
+ CXXFLAGS := $(CFLAGS)
+
+@@ -28,7 +24,7 @@
+ OBJS := ../anameal.o ../db.o ../food.o ../meal.o ../options.o ../prtmenu.o ../recmeal.o ../util.o $(patsubst %.cc,%.o,$(SOURCE))
+
+ nut: $(OBJS)
+- $(CXX) $(OPT) -o $(EXECUTABLE) $(OBJS) $(LIBS)
++ $(CXX) $(CFLAGS) $(LDFLAGS) -o $(EXECUTABLE) $(OBJS) $(LIBS)
+
+ deps:
+ makedepend -Y.. ../anameal.c ../db.c ../food.c ../meal.c ../options.c ../prtmenu.c ../recmeal.c ../util.c *.cc >/dev/null 2>&1
diff --git a/app-misc/nut/nut-17.7.ebuild b/app-misc/nut/nut-17.7.ebuild
new file mode 100644
index 000000000000..ac000025ee4b
--- /dev/null
+++ b/app-misc/nut/nut-17.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-17.7.ebuild,v 1.1 2012/04/25 18:54:25 jer Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Record what you eat and analyze your nutrient levels"
+HOMEPAGE="http://nut.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
+IUSE="fltk"
+
+RDEPEND="
+ fltk? ( x11-libs/fltk:1 )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-17.7-makefile.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) FOODDIR=\\\"/usr/share/nut\\\"
+ if use fltk; then
+ cd fltk
+ emake CXX=$(tc-getCXX) FOODDIR=\\\"/usr/share/nut\\\"
+ fi
+}
+
+src_install() {
+ insinto /usr/share/nut
+ doins raw.data/*
+ dobin nut
+ doman nut.1
+ if use fltk; then
+ dobin fltk/Nut
+ doicon nut.xpm
+ make_desktop_entry Nut nut nut Education
+ fi
+}