summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-27 09:18:14 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-27 09:18:14 +0000
commit5e30da1e786e7c77da98873a378967472a6e5ccf (patch)
tree27d2d6494931e23c275f21c4d4f1b22a43f0dd7f /app-misc
parentVersion bump (diff)
downloadgentoo-2-5e30da1e786e7c77da98873a378967472a6e5ccf.tar.gz
gentoo-2-5e30da1e786e7c77da98873a378967472a6e5ccf.tar.bz2
gentoo-2-5e30da1e786e7c77da98873a378967472a6e5ccf.zip
Fix for new Python situation, #311515
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/byobu/ChangeLog7
-rw-r--r--app-misc/byobu/byobu-2.65-r1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-misc/byobu/ChangeLog b/app-misc/byobu/ChangeLog
index 24323dd81eab..fc3862159ce5 100644
--- a/app-misc/byobu/ChangeLog
+++ b/app-misc/byobu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/byobu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/ChangeLog,v 1.8 2010/03/21 02:02:52 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/ChangeLog,v 1.9 2010/03/27 09:18:14 jlec Exp $
+
+*byobu-2.65-r1 (27 Mar 2010)
+
+ 27 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +byobu-2.65-r1.ebuild:
+ Fix for new Python situation, #311515
*byobu-2.65 (20 Mar 2010)
diff --git a/app-misc/byobu/byobu-2.65-r1.ebuild b/app-misc/byobu/byobu-2.65-r1.ebuild
new file mode 100644
index 000000000000..40a7effdffcd
--- /dev/null
+++ b/app-misc/byobu/byobu-2.65-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-2.65-r1.ebuild,v 1.1 2010/03/27 09:18:14 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+MY_UBUNTU_RELEASE=lucid
+MY_UBUNTU_PLVL=1
+MY_UBUNTU_P="${PV}-0ubuntu${MY_UBUNTU_PLVL}"
+
+DESCRIPTION="A set of profiles for the GNU Screen console window manager (app-misc/screen)"
+HOMEPAGE="https://launchpad.net/byobu"
+SRC_URI="https://launchpad.net/ubuntu/${MY_UBUNTU_RELEASE}/+source/byobu/${MY_UBUNTU_P}/+files/byobu_${PV}.orig.tar.gz
+ https://launchpad.net/ubuntu/${MY_UBUNTU_RELEASE}/+source/byobu/${MY_UBUNTU_P}/+files/byobu_${MY_UBUNTU_P}.diff.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/debhelper"
+RDEPEND="app-misc/screen
+ dev-libs/newt"
+
+src_prepare() {
+ EPATCH_OPTS="-p1" epatch "${WORKDIR}"/*.diff
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ ln -s "${D}" debian/byobu
+ ln -s "${D}" debian/byobu-extras
+ emake --makefile=debian/rules install || die
+ rm -rf "${D}/debian"
+}
+
+pkg_postinst() {
+ elog 'To access the functionality of this package, please run the command "byobu"'
+ elog 'in place of "screen".'
+}