summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-06-09 18:02:44 +0000
committerMichael Weber <xmw@gentoo.org>2015-06-09 18:02:44 +0000
commit411690e77f698cbc5e41a95c8aef1e11f53e6d9b (patch)
tree1e61239fec3e1cb364efae5680563e3df9c1064e /app-misc
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-411690e77f698cbc5e41a95c8aef1e11f53e6d9b.tar.gz
gentoo-2-411690e77f698cbc5e41a95c8aef1e11f53e6d9b.tar.bz2
gentoo-2-411690e77f698cbc5e41a95c8aef1e11f53e6d9b.zip
Version bump (bug 484688, thanks Sergey Popov).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/hexcompare/ChangeLog8
-rw-r--r--app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch14
-rw-r--r--app-misc/hexcompare/hexcompare-1.0.4.ebuild29
3 files changed, 50 insertions, 1 deletions
diff --git a/app-misc/hexcompare/ChangeLog b/app-misc/hexcompare/ChangeLog
index 274e2f68a44c..053d5c881a79 100644
--- a/app-misc/hexcompare/ChangeLog
+++ b/app-misc/hexcompare/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/hexcompare
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hexcompare/ChangeLog,v 1.2 2015/06/09 11:44:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hexcompare/ChangeLog,v 1.3 2015/06/09 18:02:44 xmw Exp $
+
+*hexcompare-1.0.4 (09 Jun 2015)
+
+ 09 Jun 2015; Michael Weber <xmw@gentoo.org>
+ +files/hexcompare-1.0.4-Makefile.patch, +hexcompare-1.0.4.ebuild:
+ Version bump (bug 484688, thanks Sergey Popov).
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
new file mode 100644
index 000000000000..5ccef2047bc7
--- /dev/null
+++ b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
@@ -0,0 +1,14 @@
+--- hexcompare-1.0.4/Makefile
++++ hexcompare-1.0.4/Makefile
+@@ -1,9 +1,9 @@
+-CFLAGS = -O3 -Wall -Wextra -pedantic -Wformat-security -std=gnu89
++CFLAGS += -Wall -Wextra -pedantic -Wformat-security -std=gnu89
+
+ all: hexcompare
+
+ hexcompare: main.c gui.c
+- $(CC) $(CFLAGS) -o hexcompare main.c gui.c -lncurses
++ $(CC) $(CFLAGS) `pkg-config --cflags ncurses` -o hexcompare main.c gui.c `pkg-config --libs ncurses`
+
+ clean:
+ rm -f *.o
diff --git a/app-misc/hexcompare/hexcompare-1.0.4.ebuild b/app-misc/hexcompare/hexcompare-1.0.4.ebuild
new file mode 100644
index 000000000000..f46ba341b68c
--- /dev/null
+++ b/app-misc/hexcompare/hexcompare-1.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hexcompare/hexcompare-1.0.4.ebuild,v 1.1 2015/06/09 18:02:44 xmw Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="ncurses-based visual comparison of binary files"
+HOMEPAGE="http://hexcompare.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:5"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}