summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2012-08-30 08:55:13 +0000
committerAndreas Proschofsky <suka@gentoo.org>2012-08-30 08:55:13 +0000
commit1ead43b586d6b70ccb00442b012eab9ccc3ae90f (patch)
treed43c4f493b582fd3e9a93310d60b6ef65db0298c /app-misc/tasque
parentx86 stable wrt bug #428372 (diff)
downloadgentoo-2-1ead43b586d6b70ccb00442b012eab9ccc3ae90f.tar.gz
gentoo-2-1ead43b586d6b70ccb00442b012eab9ccc3ae90f.tar.bz2
gentoo-2-1ead43b586d6b70ccb00442b012eab9ccc3ae90f.zip
Finally a new release of tasque, mostly bug fixes though ;)
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/tasque')
-rw-r--r--app-misc/tasque/ChangeLog7
-rw-r--r--app-misc/tasque/tasque-0.1.11.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/app-misc/tasque/ChangeLog b/app-misc/tasque/ChangeLog
index 258cb51513dc..7886f25ae270 100644
--- a/app-misc/tasque/ChangeLog
+++ b/app-misc/tasque/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/tasque
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tasque/ChangeLog,v 1.8 2012/05/29 18:50:55 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tasque/ChangeLog,v 1.9 2012/08/30 08:55:13 suka Exp $
+
+*tasque-0.1.11 (30 Aug 2012)
+
+ 30 Aug 2012; Andreas Proschofsky <suka@gentoo.org> +tasque-0.1.11.ebuild:
+ Finally a new release of tasque, mostly bug fixes though ;)
29 May 2012; Andreas Proschofsky <suka@gentoo.org>
-files/tasque-0.1.8-debug-fixup.patch, tasque-0.1.9.ebuild,
diff --git a/app-misc/tasque/tasque-0.1.11.ebuild b/app-misc/tasque/tasque-0.1.11.ebuild
new file mode 100644
index 000000000000..e9b3a817ffa7
--- /dev/null
+++ b/app-misc/tasque/tasque-0.1.11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tasque/tasque-0.1.11.ebuild,v 1.1 2012/08/30 08:55:13 suka Exp $
+
+EAPI="4"
+
+inherit eutils gnome.org mono
+
+DESCRIPTION="Tasky is a simple task management app (TODO list) for the Linux Desktop"
+HOMEPAGE="http://live.gnome.org/Tasque"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+rememberthemilk +sqlite hiveminder debug"
+
+RDEPEND=">=dev-dotnet/gtk-sharp-2.12.7-r5
+ >=dev-dotnet/gnome-sharp-2.24.0
+ >=dev-dotnet/notify-sharp-0.4.0_pre20080912
+ >=dev-dotnet/ndesk-dbus-0.6
+ >=dev-dotnet/ndesk-dbus-glib-0.4
+ sqlite? ( dev-db/sqlite:3 )
+ "
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ BACKEND=false
+ for usef in sqlite hiveminder rememberthemilk
+ do
+ use $usef && BACKEND=true
+ done
+ if [[ "${BACKEND}" != "true" ]]
+ then
+ eerror "You must select one of the following backends by enabling their useflag:"
+ eerror "sqlite ( uses a local, file-backed database to keep track of your TODO list )"
+ eerror "rememberthemilk ( integrates with www.rememberthemilk.com )"
+ eerror "hiveminder ( integrates with www.hiveminder.com )"
+ die "Please select a backend"
+ fi
+}
+
+src_configure() {
+ #http://bugzilla.gnome.org/show_bug.cgi?id=568910
+ export GTK_DOTNET_20_LIBS=" " \
+ GTK_DOTNET_20_CFLAGS=" "
+ econf --disable-backend-icecore \
+ --disable-backend-eds \
+ --disable-appindicator \
+ --enable-backend-rtm \
+ $(use_enable sqlite backend-sqlite) \
+ $(use_enable hiveminder backend-hiveminder) \
+ $(use_enable debug)
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "emake failed"
+ dodoc NEWS TODO README AUTHORS || die "docs installation failed"
+ mv_command="cp -pPR" mono_multilib_comply
+}