summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-09-28 10:40:11 +0000
committerFabian Groffen <grobian@gentoo.org>2011-09-28 10:40:11 +0000
commitdcedc40110615c0e70d26917e240ec3dda8987bd (patch)
tree000aabeb38353780637ef7a9c9f7fc2b983e9d8f /app-misc/sphinx
parentFix init script depecrated variables, version bumps (diff)
downloadgentoo-2-dcedc40110615c0e70d26917e240ec3dda8987bd.tar.gz
gentoo-2-dcedc40110615c0e70d26917e240ec3dda8987bd.tar.bz2
gentoo-2-dcedc40110615c0e70d26917e240ec3dda8987bd.zip
Fixed for and marked ~sparc-solaris, ~sparc64-solaris
(Portage version: 2.2.01.19295-prefix/cvs/SunOS i386)
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/ChangeLog6
-rw-r--r--app-misc/sphinx/files/sphinx-2.0.1_beta-solaris.patch35
-rw-r--r--app-misc/sphinx/sphinx-2.0.1_beta.ebuild5
3 files changed, 43 insertions, 3 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index 2a7116688e80..23912ad04ab5 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/sphinx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.36 2011/05/29 15:31:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.37 2011/09/28 10:40:10 grobian Exp $
+
+ 28 Sep 2011; Fabian Groffen <grobian@gentoo.org> sphinx-2.0.1_beta.ebuild,
+ +files/sphinx-2.0.1_beta-solaris.patch:
+ Fixed for and marked ~sparc-solaris, ~sparc64-solaris
29 May 2011; Fabian Groffen <grobian@gentoo.org> sphinx-2.0.1_beta.ebuild,
+files/sphinx-2.0.1_beta-darwin8.patch:
diff --git a/app-misc/sphinx/files/sphinx-2.0.1_beta-solaris.patch b/app-misc/sphinx/files/sphinx-2.0.1_beta-solaris.patch
new file mode 100644
index 000000000000..6cc69d2ccd96
--- /dev/null
+++ b/app-misc/sphinx/files/sphinx-2.0.1_beta-solaris.patch
@@ -0,0 +1,35 @@
+link against required libraries
+include sys/fcntl.h for F_[SG]ET constants
+don't try to use an undefined constant
+
+--- api/libsphinxclient/configure.in
++++ api/libsphinxclient/configure.in
+@@ -33,6 +33,9 @@
+ dnl Checks for header files.
+ AC_CHECK_HEADERS(string.h strings.h unistd.h stdint.h)
+
++AC_CHECK_LIB([nsl], gethostbyname)
++AC_CHECK_LIB([socket], connect)
++
+ DEFAULT_INSTALL_PREFIX="/usr/local"
+
+ AC_ARG_ENABLE(debug,
+--- api/libsphinxclient/sphinxclient.c
++++ api/libsphinxclient/sphinxclient.c
+@@ -57,6 +57,7 @@
+ #include <netdb.h>
+ #include <errno.h>
+ #include <sys/un.h>
++ #include <sys/fcntl.h>
+ #endif
+
+ //////////////////////////////////////////////////////////////////////////
+@@ -1280,7 +1281,7 @@
+ static sphinx_bool net_write ( int fd, const char * bytes, int len, sphinx_client * client )
+ {
+ int res;
+-#if defined(_WIN32) || defined(SO_NOSIGPIPE)
++#if defined(_WIN32) || defined(SO_NOSIGPIPE) || !defined(MSG_NOSIGNAL)
+ res = send ( fd, bytes, len, 0 );
+ #else
+ res = send ( fd, bytes, len, MSG_NOSIGNAL );
diff --git a/app-misc/sphinx/sphinx-2.0.1_beta.ebuild b/app-misc/sphinx/sphinx-2.0.1_beta.ebuild
index f34c9e9fe078..67a328f5d402 100644
--- a/app-misc/sphinx/sphinx-2.0.1_beta.ebuild
+++ b/app-misc/sphinx/sphinx-2.0.1_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-2.0.1_beta.ebuild,v 1.2 2011/05/29 15:31:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-2.0.1_beta.ebuild,v 1.3 2011/09/28 10:40:10 grobian Exp $
EAPI=3
inherit eutils autotools
@@ -18,7 +18,7 @@ SRC_URI="http://sphinxsearch.com/files/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x86-macos"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
IUSE="debug id64 mysql odbc postgres stemmer test"
RDEPEND="mysql? ( virtual/mysql )
@@ -40,6 +40,7 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${P}-darwin8.patch
+ epatch "${FILESDIR}"/${P}-solaris.patch
# drop nasty hardcoded search path breaking Prefix
sed -i -e '/\/usr\/local\//d' configure.ac || die